[FreeBSD] Probleme mit Zeichensatz

11/03/2010 - 15:53 von Christian Baer | Report spam
Hallo Leute!

Ich habe eindeutig zu lange kein neues System mehr aufgesetzt. Da
verliert man scheinbar gewisse Fàhigkeiten. :-)

Vor kurzem habe ich ein neues System mit FreeBSD 8.0 aufgesetzt. Derzeit
làuft darauf p2. slrn gebaut, alles kein Problem - bis auf den
Zeichensatz. Ich greife auf die Kiste per ssh zu, weil kein Monitor
angeschlossen.

slrn zeigte mal die Umlaute richtig an und mal nicht. Warum das ab und
an mal klapp (ohne daß ich etwas an den Einstellungen geàndert habe),
will mir gerade nicht so wirklich einleuchten.

Damit slrn sich vernünftig verhàlt und Umlaute sowohl anzeigt als auch
verschickt, dachte ich, ich trage mal etwas in meine .login_conf ein:

me:\
:charset=UTF-8:\
# :lang=en_US.UTF-8:

Wohlgemerkt, erst nur die erste Zeile. Aus welcher Motivation heraus
dann slrn meinte Deutsch werden zu müssen, kann ich nicht sagen. Deshalb
habe ich dann die zweite Zeile eingefügt. Ich möchte also grundsàtzlich
Deutsch schreiben (so wie hier auch), aber trotzdem englische
Systemmeldungen bekommen und die Anwendungen sollen ihre Ausgaben auch
auf Englisch machen.

Was mache ich falsch?

Gruß
Christian

Ich kam.
Ich ging.
Und ich war da gewesen.
 

Lesen sie die antworten

#1 Stefan Ollermann
26/03/2010 - 20:52 | Warnen spam
Christian Baer wrote:

me:\
:charset=UTF-8:\
# :lang=en_US.UTF-8:

Wohlgemerkt, erst nur die erste Zeile. Aus welcher Motivation heraus
dann slrn meinte Deutsch werden zu müssen, kann ich nicht sagen. Deshalb
habe ich dann die zweite Zeile eingefügt. Ich möchte also grundsàtzlich
Deutsch schreiben (so wie hier auch), aber trotzdem englische
Systemmeldungen bekommen und die Anwendungen sollen ihre Ausgaben auch
auf Englisch machen.



Wie sieht denn die Variable LC_ALL aus? Die hat Vorrang vor den anderen LC_*
Variablen und vor der LANG.

Was mache ich falsch?



Du willst in einer englischen Umgebung mit deutschen Umlauten schreiben -
also z.B. auf einer "Tastatur" ohne diesen Tasten.

Du kannst LC_ALL und LANG generell nicht setzen und dann nur die anderen
notwendigen LC_* Variablen anpassen.

Gruß
Christian



Gruß,
Stefan

Ähnliche fragen