[FreeBSD] USB Ethernet arbeitet nur wenn promiscous?

29/04/2010 - 00:01 von Christoph | Report spam
Hallo,

mein (privates) Internet-Uplink làuft über einen kleinen BSD-PC als
Router. Da er nur ein richtiges Netzwerkinterface hat geht die
DSL-Seite über einen USB-Adapter (aue0).

Das ganze làuft seit Jahren.
Nun habe ich das Teil von 6.4 auf 7.3 upggraded.

Nachdem das alles durchgelaufen ist funktioniert der USB-Adapter
nur noch wenn ich ihn in den promiscous mode versetze.

Aufgefallen ist mir das beim debuggen, mit tcpdump on ging
alles wunderbar, ohne gar nicht.

Aber auch "ifconfig aue0 promisc" erweckt das Teil wieder
zum Leben.

Kennt jemand das Problem?
Gibt es dafür eine Lösung?

Gruß

Christoph Weber-Fahr
 

Lesen sie die antworten

#1 Sylwester S.
29/04/2010 - 13:57 | Warnen spam
Christoph wrote:
Hallo,



Hi,


mein (privates) Internet-Uplink làuft über einen kleinen BSD-PC als
Router. Da er nur ein richtiges Netzwerkinterface hat geht die
DSL-Seite über einen USB-Adapter (aue0).

Das ganze làuft seit Jahren.
Nun habe ich das Teil von 6.4 auf 7.3 upggraded.

Nachdem das alles durchgelaufen ist funktioniert der USB-Adapter
nur noch wenn ich ihn in den promiscous mode versetze.

Aufgefallen ist mir das beim debuggen, mit tcpdump on ging
alles wunderbar, ohne gar nicht.

Aber auch "ifconfig aue0 promisc" erweckt das Teil wieder
zum Leben.

Kennt jemand das Problem?
Gibt es dafür eine Lösung?



Schau mal bitte was ifconfig aue0 für eine HW-Adresse ausgibt.
Ich hatte mal das Problem, als das experimentelle Ethernet-Modul
für den EEEPC eine falsche HW-Addr ausgelesen hat (i.d.f.
FF:FF:FF:FF:FF:FF).


Gruß

Christoph Weber-Fahr



Gruß,
Sylwester

Ähnliche fragen