FRITZ!Box Fon (UI) && Wifi-router && DHCP Problem

29/11/2007 - 12:26 von Matthias Apitz | Report spam
Hallo,

in einer griechischen Taverne, wo ich als Stammgast gelte, hat
der Wirt einen AP und flatrate und also kein Problem damit, wenn
ich dort sitzend meine mails oder News lese und seinen Wein
dabei trinke.

nun das Problem: manchmal habe ich keinen connect zum Internet
und ich habe gestern nun mal untersucht, was da eigentlich im
Detail passiert; alle Details siehe unten;

- voellig problemlos ist das ASSOCIATING zum AP mit wpa_supplicant

- wenn das interface iwi0 UP kommt, wird (automatisch per script)
mit "dhcclient iwi0" IP addr, gateway und DNS bezogen;
eingenartig ist, dass dies manchmal die IP
192.168.2.101 netmask 0xffffff00
und manchmal die IP
192.168.178.20 netmask 0xffffff00
zugewiesen wird und nur mit der letzteren kommt man dann ins
Internet

- kontaktiert man jeweils die gateway IP addr mit HTTP ergibt sich bei
192.168.2.1 dass sich "Wireless Router 54 Mbit/s" meldet und bei
192.168.178.1 eine "FRITZ!Box Fon (UI), Firmware-Version 06.03.14"
meldet;

- in die "FRITZ!Box Fon (UI)" kann ich sogar mit HTTP reinsehen, weil
kein password vergeben ist; die hat aber nur DSL, LAN und USB
interfaces, ueber Wifi verfuegt sie offenbar nicht;

- wenn die IP addr 192.168.2.101 per DHCP zugeteilt wurde (und also
kein Zugriff auf das Internet besteht) kann ich einfach per
"ifconfig iwi0 192.168.178.20" die andere addr reinschreiben, das
routing auf 192.168.178.1 einstellen und schon geht der Zugriff
auf das Internet (bis zu einem re-ASSOCIATING und anschliessendem
automatischem DHCP die andere, falsche, IP bezogen wird);

Frage: warum bekommt man mit DHCP diese IP 192.168.2.101 und
manchmal die der "FRITZ!Box Fon (UI)"?

matthias

# /usr/sbin/wpa_supplicant -d -i iwi0 -c /etc/wpa_supplicant.conf
Initializing interface 'iwi0' conf '/etc/wpa_supplicant.conf' driver 'default' c
trl_interface 'N/A'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group=0 (from group name 'wheel')
eapol_version=1
ap_scan=1
fast_reauth=1
Priority group 0
id=0 ssid='xxxxxx'
id=1 ssid='xxxxxx'
id=2 ssid='xxxxxx'
id=3 ssid='xxxxxx'
id=4 ssid='xxxxxx'
id=5 ssid='xxxxxx'
id=6 ssid='Olgruamluck'
Initializing interface (2) 'iwi0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
Own MAC address: 00:13:ce:a1:e6:81
wpa_driver_bsd_set_wpa: enabled=1
wpa_driver_bsd_set_wpa_internal: wpa=3 privacy=1
wpa_driver_bsd_del_key: keyidx=0
wpa_driver_bsd_del_key: keyidx=1
wpa_driver_bsd_del_key: keyidx=2
wpa_driver_bsd_del_key: keyidx=3
wpa_driver_bsd_set_countermeasures: enabled=0
wpa_driver_bsd_set_drop_unencrypted: enabled=1
Setting scan request: 0 sec 100000 usec
Added interface iwi0
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
Received 0 bytes of scan results (1 BSSes)
Scan results: 1
Selecting BSS from priority group 0
0: 00:01:e3:0e:97:99 ssid='Olgruamluck' wpa_ie_len=0 rsn_ie_len=0 caps=0x1
skip - no WPA/RSN IE
selected non-WPA AP 00:01:e3:0e:97:99 ssid='Olgruamluck'
Trying to associate with 00:01:e3:0e:97:99 (SSID='Olgruamluck' freq$37 MHz)
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
wpa_driver_bsd_set_auth_alg alg 0x1 authmode 1
WPA: clearing AP WPA IE
WPA: clearing AP RSN IE
WPA: clearing own WPA/RSN IE
No keys have been configured - skip key clearing
wpa_driver_bsd_set_drop_unencrypted: enabled=0
State: SCANNING -> ASSOCIATING
wpa_driver_bsd_associate: ssid 'Olgruamluck' wpa ie len 0 pairwise 0 group 0 key
mgmt 2
wpa_driver_bsd_associate: set PRIVACY 0
Setting authentication timeout: 10 sec 0 usec
EAPOL: External notification - portControl=ForceAuthorized
State: ASSOCIATING -> ASSOCIATED
Associated to a new BSS: BSSID:01:e3:0e:97:99
Associated with 00:01:e3:0e:97:99
WPA: Association event - clear replay counter
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
EAPOL: External notification - portEnabled=1
EAPOL: SUPP_PAE entering state S_FORCE_AUTH
EAPOL: SUPP_BE entering state IDLE
Cancelling authentication timeout
State: ASSOCIATED -> COMPLETED
CTRL-EVENT-CONNECTED - Connection to 00:01:e3:0e:97:99 completed (auth)



# dhcclient iwi0
# ifconfig iwi0
iwi0: flagsˆ43<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
inet 192.168.2.101 netmask 0xffffff00 broadcast 192.168.2.255
ether 00:13:ce:a1:e6:81
media: IEEE 802.11 Wireless Ethernet autoselect (DS/11Mbps)
status: associated
ssid Olgruamluck channel 6 bssid 00:01:e3:0e:97:99
authmode OPEN privacy OFF txpowmax 100 bmiss 10 protmode CTS
roaming MANUAL bintval 100

http://192.168.2.1/login_en.htm
Wireless Router 54 Mbit/s

# ifconfig iwi0 192.168.178.20
# route add default 192.168.178.1
add net default: gateway 192.168.178.1


http://192.168.178.1/
FRITZ!Box Fon (UI), Firmware-Version 06.03.14
DSL Aktiv
Anschluss 5664/1056 kBit/s
LAN Aktiv

# ping 193.31.11.194
PING 193.31.11.194 (193.31.11.194): 56 data bytes
64 bytes from 193.31.11.194: icmp_seq=0 ttl$5 timeC.116 ms
64 bytes from 193.31.11.194: icmp_seq=1 ttl$5 timeC.412 ms
64 bytes from 193.31.11.194: icmp_seq=2 ttl$5 timeD.161 ms


Matthias Apitz
Manager Technical Support - OCLC PICA GmbH
e <m.apitz@oclcpica.org> - w http://www.oclcpica.org/ http://www.UnixArea.de/
b http://gurucubano.blogspot.com/
Don't top-post, read RFC1855 http://www.faqs.org/rfcs/rfc1855.html
 

Lesen sie die antworten

#1 Martin Bodenstedt
29/11/2007 - 13:18 | Warnen spam
Matthias Apitz schrieb:

- wenn das interface iwi0 UP kommt, wird (automatisch per script)
mit "dhcclient iwi0" IP addr, gateway und DNS bezogen;
eingenartig ist, dass dies manchmal die IP
192.168.2.101 netmask 0xffffff00
und manchmal die IP
192.168.178.20 netmask 0xffffff00
zugewiesen wird und nur mit der letzteren kommt man dann ins
Internet



Das liegt offensichtlich an zwei gleichzeitig aktiven DHCP Servern.

Es darf aber nur einen geben, nàmlich den Router mit Verbindung zum
Internet (nur dann wird der korrekte Gateway eingetragen).

Wenn der nachgeschaltete WLAN - Router auch noch einen aktiven DHCP
Server hat, so kann man das machen, muss aber auf diesem eine statische
Route eintragen, damit er weiss, dass er alles zur Fritzbox schieben
soll - gut ist das aber nicht).

Sinnvoller ist es, den WLAN-Router als reinen Access Point zu betreiben.
Er bekommt dann (zu Managmentzwecken) eine IP aus dem LAN des Routers
(aber ausserhalb dessen dhcp Adressraum!) und sein dhcp-Service muss
dann deaktiviert werden. Wenn dann ein Client eine Assoziation zum AP
aufbaut wird anschließend der dhcp Request transparent durchgereicht und
vom Router beantwortet.

Martin Bodenstedt

(www.die-bodenstedts.de / www.maboko.de)

Ähnliche fragen