FritzBox7170 WLAN - bcm43xx

29/01/2008 - 14:54 von Karlheinz Sautter | Report spam
Hallo NG,

Die Hardware:
Hp nx6325 Notebook mit
bcm43xx: Chip ID 0x4311, rev 0x1

Fritzbox 7170 Wlan


Auf dem Notbook ist Debian/lenny installiert, uname -a sagt:
Linux venus 2.6.22-3-486 #1 Mon Nov 12 07:53:08 UTC 2007 i686 GNU/Linux

Das Problem:
Kein Internetzugang über Wlan

Was bisher geschah:
Treiber installieren mit
apt-get install bcm43xx-fwcutter

lsmod liefert:

lsmod | grep bcm43
bcm43xx 416800 0
firmware_class 9472 2 pcmcia,bcm43xx
ieee80211softmac 28416 1 bcm43xx
ieee80211 31304 2 bcm43xx,ieee80211softmac



# ifup eth0 && iwconfig && ifconfig
lo no wireless extensions.

eth1 no wireless extensions.

eth0 IEEE 802.11b/g ESSID:"FritzFunk7170" Nickname:"Broadcom 4311"
Mode:Managed Frequency=2.437 GHz Access Point: Invalid
Bit Rate=1 Mb/s Tx-Power dBm
RTS thr:off Fragment thr:off
Encryption key:4-hier ist der Key47 Security mode:open
Link Quality=0/100 Signal level=0 dBm Noise level=0 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 Link encap:Ethernet Hardware Adresse 00:14:a5:f6:b0:9b
inet Adresse:192.168.1.12 Bcast:192.168.1.255
Maske:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metrik:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:78 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlànge:1000
RX bytes:0 (0.0 B) TX bytes:3783 (3.6 KiB)
Interrupt:10

schnipp


in /etc/network/interfaces steht:

schnipp--

iface eth1 inet static
address 192.168.1.2
netmask 255.255.255.0
broadcast 192.168.1.255
gateway 192.168.1.100

iface eth0 inet static
wireless-essid FritzFunk7170
wireless-key 4-hier ist der Key47
address 192.168.1.12
netmask 255.255.255.0
gateway 192.168.1.100


Zu diesem Problem habe ich schon viel gegoogelt, aber ohne ERfolg.
Warum klappt der Zugang ins Netz nicht?

Danke für Tips
Karlheinz
 

Lesen sie die antworten

#1 Bastian Lutz
29/01/2008 - 15:21 | Warnen spam
Hallo Karlheinz!

Karlheinz Sautter schrieb:
Die Hardware:
Hp nx6325 Notebook mit
bcm43xx: Chip ID 0x4311, rev 0x1



Ohne nachgesehen zu haben: Ist das nicht LAN? Ich muesste sonst mal bei
mir am Notebook nachschauen.

Fritzbox 7170 Wlan


Auf dem Notbook ist Debian/lenny installiert, uname -a sagt:
Linux venus 2.6.22-3-486 #1 Mon Nov 12 07:53:08 UTC 2007 i686 GNU/Linux

Das Problem:
Kein Internetzugang über Wlan

Was bisher geschah:
Treiber installieren mit
apt-get install bcm43xx-fwcutter

lsmod liefert:

lsmod | grep bcm43
bcm43xx 416800 0
firmware_class 9472 2 pcmcia,bcm43xx
ieee80211softmac 28416 1 bcm43xx
ieee80211 31304 2 bcm43xx,ieee80211softmac



# ifup eth0 && iwconfig && ifconfig
lo no wireless extensions.

eth1 no wireless extensions.

eth0 IEEE 802.11b/g ESSID:"FritzFunk7170" Nickname:"Broadcom 4311"
Mode:Managed Frequency=2.437 GHz Access Point: Invalid
Bit Rate=1 Mb/s Tx-Power dBm
RTS thr:off Fragment thr:off
Encryption key:4-hier ist der Key47 Security mode:open
Link Quality=0/100 Signal level=0 dBm Noise level=0 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 Link encap:Ethernet Hardware Adresse 00:14:a5:f6:b0:9b
inet Adresse:192.168.1.12 Bcast:192.168.1.255
Maske:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metrik:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:78 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlànge:1000
RX bytes:0 (0.0 B) TX bytes:3783 (3.6 KiB)
Interrupt:10

schnipp


in /etc/network/interfaces steht:

schnipp--

iface eth1 inet static
address 192.168.1.2
netmask 255.255.255.0
broadcast 192.168.1.255
gateway 192.168.1.100

iface eth0 inet static
wireless-essid FritzFunk7170
wireless-key 4-hier ist der Key47
address 192.168.1.12
netmask 255.255.255.0
gateway 192.168.1.100



Vielleicht versucht er wg. dem selben Subnet ueber das LAN zu gehen?
Versuch doch mal das LAN-eth zu deaktivieren.

Zu diesem Problem habe ich schon viel gegoogelt, aber ohne ERfolg.
Warum klappt der Zugang ins Netz nicht?



Mein Standard-Tipp lautet Knoepfchen/Schalter/Fn-Tastenkombination
betaetigen. Leuchtet wenigstens deine WLAN-LED?

Hast du darauf geachtet, immer WPA zu verwenden (manche dumme/aeltere
Konfig-Proggis kennen nur WEP).
Hast du auch wpa_supplicant installiert?

Hier im uebrigen meine funktionsfaehige Konstellation:
- Acer Travelmate 800er mit Dell-WLAN-Modul (Broadcom-Chip)
- Kubuntu 7.10, WLAN-Firmware per Klick in "eingeschraenke Treiber"
installiert
- Fritzbox 7050

Probiere doch mal das (K)Ubuntu 7.10 Live-System (hoffentlich kann man
da auch die WLAN-Firmware nachladen) und vergleiche, wenn es funktioniert.

Ansonsten wuerde ich dir heute Abend mal ein paar weitere Infos von
meiner Konfig posten.

HTH

Bastian Lutz

Wenn jemand irgendwas von Anonymitaet faselt, wenn er oder jemand
anderes (meist Newbies) darauf hingewiesen wurde, dass er einen Realname
verwenden sollte, hat er den Hinweis nicht richtig gelesen.

Ähnliche fragen