Funktion ANZAHL mit mehr als 30 Argumenten

12/07/2008 - 20:38 von Daniela Handlin | Report spam
Hallo NG'ler,

Ich möchte die Anzahl der belegegten Felder ermitteln. Die Tabelle ist
folgendermaßen aufgebaut:
Es gibt 52 Wochen (Spalten). Jede Woche hat drei Untergruppen (ja, nein,
egal). In den Zeilen stehen die Namen der Teilnehmer. Nun möchte ich die
Anzahl der Felder einer Person ermitteln, die mit JA belegt sind. Da die
JA-Felder aber in jeder 3. Spalte sind, ist jedes Feld ein Argument und
somit komme ich auf 52 Argumente. Es sind aber nur 30 zugelassen.

Gibt es dafür eine Lösung?

Ich wollte es schon mit Bereichsnamen versuchen, aber dann müsste ich
für jede Zeile einen anderen Bereichsnamen vergeben, da er sonst die
JA-Felder aller Teilnehmer zusammenzàhlen würde. Das scheint mir zu
aufwendig. Und wenn neue Zeilen (Teilnehmer) hinzukommen, müsste ich
wieder einen neuen Bereichsnamen kreieren.

Ich arbeite mit Win XP, Prof. und Excel 2003

Gruß
Dani
 

Lesen sie die antworten

#1 Claus Busch
12/07/2008 - 20:49 | Warnen spam
Hallo Daniela,

Am Sat, 12 Jul 2008 20:38:43 +0200 schrieb Daniela Handlin:


Ich möchte die Anzahl der belegegten Felder ermitteln. Die Tabelle ist
folgendermaßen aufgebaut:
Es gibt 52 Wochen (Spalten). Jede Woche hat drei Untergruppen (ja, nein,
egal). In den Zeilen stehen die Namen der Teilnehmer. Nun möchte ich die
Anzahl der Felder einer Person ermitteln, die mit JA belegt sind. Da die
JA-Felder aber in jeder 3. Spalte sind, ist jedes Feld ein Argument und
somit komme ich auf 52 Argumente. Es sind aber nur 30 zugelassen.



warum hast du pro Woche 3 Spalten. In einer Woche kann doch nur Ja, Nein
*oder* egal pro Person vorkommen, oder irre ich mich. Du könntest die
Zellen mit einer Gültigkeit belegen => Zulassen => Liste und dann als
Quelle "Ja";"Nein";"Egal". Dann könntest du über Dropdown den Eintrag
auswàhlen.
In der jetztigen Konstellation deiner Tabelle könntest du die
Ja-Eintràge so zàhlen:
=SUMMENPRODUKT(N(B2:FJ2="ja")) und für jeden Teilnehmer herunterziehen.


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP2 / Vista Ultimate
Office 2003 SP2 / 2007 Ultimate

Ähnliche fragen