Geigerzähler mit ZP1400 nach Elektor 1980 - Fehlersuche

02/02/2014 - 20:52 von Wolfgang Strobl | Report spam
Den hier <http://www.mystrobl.de/Plone/bastel...aehler>
gezeigten Geigerzàhler habe ich ein paar Jahre vor dem Reaktorunfall in
Tschernobyl zusammengelötet, danach lag er jahrelang unbenutzt im
Schrank. Das Geràt basierte auf einem Bausatz nach einem Artikel in
Elektor Januar 1980.

Kurz vor dem Reaktorunfall hatte ich gerade angefangen, den Zàhler mit
meinem Nascom II über die Parallelschnittstelle auszulesen und konnte
damals tatsàchlich eine leichte Erhöhung des Hintergrundpegels - i.W.
Beta, Jod 131in der Luft, wenn ich mich recht erinnere - beobachten,
i.W. weil der Versuchsaufbau damals gerade zufàllig rund um die Uhr
durchlief. Die Daten gaben quantitativ allerdings nicht viel her, vor
allem weil es an einem zuverlàssigen Zeitmaßstab fehlte.

Danach hatte ich hauptsàchlich damit zu tun, einer physikalisch ziemlich
unbedarften, aber um so besorgteren ehemaligen Kollegin zu erlàutern,
warum ein solches Geràt völlig ungeeignet ist, eine potentielle
Kontamination von Lebensmitteln - Pfifferlingen aus Polen, Wildschwein
aus Bayern - zu bewerten. Begriffen und geglaubt hat sie es IMHO nie.

Egal. Da ich gerade wieder angefangen habe, ein wenig mit Elektronik
herumzuspielen, bot sich an, das Geràt ein wenig aufzubohren, um das
neue DS2072, den Pickit 2 und vor allem den XC8-Compiler von Microchip
mal an einem konkreten Problem auszuprobieren.

Außerdem, immerhin ist das verwendete Zàhlrohr, ein Valvo ZP1400, gar
nicht so schlecht, zwar nicht sehr empfindlich,aber immerhin in der
Lage, auch Alphastrahlung zu detektieren. So etwas sollte nicht im
Schrank herumliegen. :-)

Besondere Probleme sind dabei zujnàchst nicht aufgetaucht, das Geràt
tut's, der Digitalausgang liefert pro Entladung einen sauberen Puls von
etwa 80 Microsekunden Dauer und einer Amplitude von knapp 3 Volt. Etwas
wenig für einen 5V-Eingang, aber das ist bei Bedarf behebbar. Notfalls
dreht man die Versorgungsspannung des PIC etwas runter.

Aktuell habe ich ein kleines q&d-Programm für den 12F975 - davon habe
ich noch ein paar hier rumliegen - das den Timer0 die Impulse zàhlen
làßt, diese vom Timer1 gesteuert in einen Ringpuffer im EEPROM schreibt
dessen Inhalt auf Request via Software-RS232 über einen RS232 nach
USB-Converter abliefert, wo es dann mit einer kleinen GUI-Anwendung
ausgelesen und grafisch dargestellt werden kann.

Beim Herumspielen mit dem Geigerzàhler fiel auf, daß der nicht wie
vorgesehen nur um die 10-20 mA zieht, sondern um die 350 mA. In der
Anfangsphase nach dem Einschalten ist das normal, da die Kaskade erst
hochgepumpt werden muß. Ist die Zielspannung erreicht, wird der
Oszillator normalerweise abgeschaltet und nur noch gelegentlich
nachgepumpt. Hier aber leider nicht.

Leider ist mir nicht gelungen, die Ursache genügend einzugrenzen.

Bei microcontroller.net gibt es eine brauchbare Kopie des Artikels und
Schaltplans
<http://www.mikrocontroller.net/atta...el.pdf>

Die Schaltung ist nicht sonderlich tiefsinnig. Anschauen mit dem DSO
zeigt, daß alle relevanten Schaltungsteile sich wie erwartet verhalten,
soweit man das ohne konkrete Prüfwerte sagen kann.

Das Verhalten ist. i.W. wie folgt: mit P1 kann die Spannung der Kaskade
justiert werden, i.W. indem die Vergleichsseite eines Spannungsteilers
eingestellt wird. Bis zu ca. 450 V verhàlt sich das Teil wie erwartet
mit einem Eingangsstrom von < 50 mA. Regelt man hoch, so geht das bis
480 bis 500 V gut, dann geht der Strom abrupt auf 350 mA hoch und die
Spannung der Kaskade (A und K) auf ca 400 V runter. Gleichzeitig kann
man auf dem Oszi sehen, daß der Oszillator anspringt und an bleibt,,
wàhrend sonst nur gelegentliche Pumpvorgànge zu sehen sind.

Faktisch sieht man eine funktionierende Regelung, die halt auf die
abgesunkene Spannung richtig reagiert. Schließt man einen der
10M-Widerstànde mit einer Spitzzange kurz und erhöht so die
Messspannung, hört das Pumpen auch wie erwartet auf.

Unter dem Strich sieht es so aus, also ob irgend einer der Bestandteile
der Spannungskaskade durchschlüge.

Aber welcher? Mögliche Kandidaten sind: Sekundàrwicklung des
umgedrehten Trafos, einer der acht Kondensatoren, oder eine der Dioden.
Statisches Messen ergibt nichts, per Vielfachmessinstrument erhalte ich
die erwartenden Durchflusspannungen der Dioden und Kapazitàten der
Elkos. Auch die im Betrieb gemessenen Spannungen geben mir keinen
Auflschluß. Der erste Kondensator der Kaskade (C4) hat im Betrieb
weniger Spannung als die anderen, das muß aber, glaube ich, so sein.

Frage: gibt es irgend ein naheliegendes Testverfahren? Mir fehlen leider
die Mittel, um die Bauteile unter kontrollierter Hochspannug zu testen.
Natürlich könnte ich alle Bauteile auswechseln, befürchte aber, daß ein
genau passender Trafo nicht ganz einfach zu bekommen ist, auch wenn das
eigentlich ein ganz einfacher Kleinleistungstrafo ist. Ich möchte aber
auch nicht alle Kondensatoren und Dioden auslöten, neue bestellen und
einbauen, nur um dann festzustellen, daß es doch der Trafo war.

Das neu erworbene DSO gibt ganz neue Einblicke in die Funktion so einer
Schaltung. Mir fehlt allerdings jegliche Erfahrung, wie sich eine
dynamisch versagende Diode, ein Elko oder eine Trafowicklung im
Spannungsgraph àußert, insofern hilft das nicht wirklich weiter. Für
Tipps, wonach man schauen könnte, wàre ich durchaus dankbar. Zwar tut es
das Teil auch so, jedoch ist mir trotzdem etwas unwohl damit.


Wir danken für die Beachtung aller Sicherheitsbestimmungen
 

Lesen sie die antworten

#1 Horst-D.Winzler
02/02/2014 - 21:36 | Warnen spam
Am 02.02.2014 20:52, schrieb Wolfgang Strobl:
Den hier <http://www.mystrobl.de/Plone/bastel...aehler>
gezeigten Geigerzàhler habe ich ein paar Jahre vor dem Reaktorunfall in
Tschernobyl zusammengelötet, danach lag er jahrelang unbenutzt im
Schrank. Das Geràt basierte auf einem Bausatz nach einem Artikel in
Elektor Januar 1980.


Beim Herumspielen mit dem Geigerzàhler fiel auf, daß der nicht wie
vorgesehen nur um die 10-20 mA zieht, sondern um die 350 mA.



Das Problem dürften die Elkos in der Kaskade sein. Trenn mal die Kaskade
vom Trafo.
Mein Vorschlag, anderen Übertrager mit höherer Schaltfrequenz und somit
entsprechend kleineren Kapazitàt der Kondensatoren. Dann könnte du auch
mit einer Verdopplung auskommen.

BTW Es empfiehlt sich, Geràte mit Elkos einmal im Jahr etwa eine Stunde
in Betrieb zu nehmen.
mfg hdw

Ähnliche fragen