Genaue Strom- und Spannungsanzeige für Netzteil mit LM317?

10/03/2014 - 16:16 von Peter Heitzer | Report spam
Für ein kleines einstellbares Netzgeràt möchte ich einen LM317 oder
anderen einstellbaren Dreibeiner verwenden. Das Netzgeràt soll auch
eine Spannungs und eine Stromanzeige (LCD Einbaumessgeràt)
erhalten. Da ich auch Ströme mit einer Auflösung von 100 µA genau
messen will habe ich mit dem Regler ein Problem resultierend aus dem
Spannungsabfall am Shunt zur Strommessung.
Wenn ich den Meßbereich des LCD-Meters voll ausnützen will, habe ich
bis zu 200 mV Spannungsabfall. Die Spannungsanzeige weicht dann um
diesen Betrag ab, wenn ich nach dem Shunt messe. Messe ich die Spannung
am Reglerausgang (vor dem Shunt) zeigt das Meßgeràt weniger an, als
an den Ausgangsbuchsen anliegt.
Meine Idee ist nun, den Spannungsteiler des Reglers nicht zwischen
Reglerausgang und Masse zu legen, sondern die Spannung an der Ausgangsbuchse
über einen Opamp zu puffern und dann den Spannungsteiler an den
gepufferten Ausgang zu legen. Dadurch sollte der Spannungsabfall am
Shunt ausgeregelt werden.

Funktioniert diese Lösung oder habe ich etwas übersehen?

Dipl.-Inform(FH) Peter Heitzer, peter.heitzer@rz.uni-regensburg.de
HTML mails will be forwarded to /dev/null.
 

Lesen sie die antworten

#1 Edzard Egberts
10/03/2014 - 17:05 | Warnen spam
Peter Heitzer schrieb:
Für ein kleines einstellbares Netzgeràt möchte ich einen LM317 oder
anderen einstellbaren Dreibeiner verwenden. Das Netzgeràt soll auch
eine Spannungs und eine Stromanzeige (LCD Einbaumessgeràt)
erhalten. Da ich auch Ströme mit einer Auflösung von 100 µA genau
messen will habe ich mit dem Regler ein Problem resultierend aus dem
Spannungsabfall am Shunt zur Strommessung.
Wenn ich den Meßbereich des LCD-Meters voll ausnützen will, habe ich
bis zu 200 mV Spannungsabfall. Die Spannungsanzeige weicht dann um
diesen Betrag ab, wenn ich nach dem Shunt messe. Messe ich die Spannung
am Reglerausgang (vor dem Shunt) zeigt das Meßgeràt weniger an, als
an den Ausgangsbuchsen anliegt.
Meine Idee ist nun, den Spannungsteiler des Reglers nicht zwischen
Reglerausgang und Masse zu legen, sondern die Spannung an der Ausgangsbuchse
über einen Opamp zu puffern und dann den Spannungsteiler an den
gepufferten Ausgang zu legen. Dadurch sollte der Spannungsabfall am
Shunt ausgeregelt werden.

Funktioniert diese Lösung oder habe ich etwas übersehen?



Ich kann mir gar nicht vorstellen, wie das funktionieren soll - Du hast
nicht zufàllig einen Schaltplan?

Jedenfalls würde ich den Shunt einfach vor den Spannungsregler in die
Plus-Leitung setzen. Dann stimmen schon einmal Ausgangsspannung und die
Spannungsmessung und Du hast nur noch das Problem, dass der gemessene
Strom um den Stromverbrauch des Spannungsreglers (so 50 bis 100 µA) zu
hoch ist.

Diesen Offset könnte man einfach herunterdrehen, indem man mit einer
Festspannung und Poti den entsprechenden Strom nach dem Shunt einspeist.
Laut Datenblatt àndert sich dieser Strom nicht so besonders viel (Das
LCD-Meter làsst sich nicht "nullen"?).

Wenn es unbedingt ein OpAmp sein soll, vielleicht anhand des
Spannungsabfalls über den Fußpunkt-Widerstand genau den entsprechenden
Strom nach dem Shunt einspeisen. Das ist schaltungstechnisch aber wieder
aufwàndiger und könnte die Spannungsregelung stören.

Ähnliche fragen