[gentoo-user-de] 2.6.24->2.6.27: ACLs funktionieren nicht mehr

02/11/2008 - 09:10 von Andreas Baier | Report spam
Hallo,

Ich verwende ACL + XFS. Bei dem Umstieg von Kernel 2.6.24 zu 2.6.27 r2 (beides
Gentoo-Sources) scheinen die ACLs nicht mehr zu funktionieren:

$ getfacl /home/
getfacl: /home/: Das Argument ist ungültig

rsync: get_acl: sys_acl_get_file(/var, ACL_TYPE_ACCESS): Invalid argument (22)
rsync error: some files/attrs were not transferred (see previous errors) (code
23) at main.c(1040) [sender=3.0.4]

Es scheint ein Kernel-Problem zu sein, da bei einem Neustart von 2.6.24 die
Probleme verschwinden.

Ein erstes Suchen brachte mir leider noch keine Lösung

# gunzip -c /proc/config.gz | grep -i acl
CONFIG_EXT2_FS_POSIX_ACL=y
CONFIG_EXT3_FS_POSIX_ACL=y
CONFIG_FS_POSIX_ACL=y
CONFIG_XFS_POSIX_ACL=y
CONFIG_GENERIC_ACL=y
CONFIG_TMPFS_POSIX_ACL=y
CONFIG_NFS_V3_ACL=y
CONFIG_NFSD_V2_ACL=y
CONFIG_NFSD_V3_ACL=y
CONFIG_NFS_ACL_SUPPORT=y

$ dmesg | grep -i acl
[ 0.449286] SGI XFS with ACLs, security attributes, realtime, large block
numbers, no debug enabled

# emerge -pv acl

These are the packages that would be merged, in order:

Calculating dependencies ... done!
[ebuild R ] sys-apps/acl-2.2.47 USE="nfs nls" 0 kB

Vielen Dank für jeden Hinweis
Gruß Andreas
 

Lesen sie die antworten

#1 Andreas Baier
04/11/2008 - 19:50 | Warnen spam
Hallo nochmal,

und zwar scheint es sich bei meinem ACL-Problem um einen XFS-Bug unter Kernel
2.6.27 zu handeln, denn unter ext3 und Konsorten funktionieren ACLs
einwandfrei.

Kann das vielleicht jemand bestàtigen?

Gruß Andreas

Ich verwende ACL + XFS. Bei dem Umstieg von Kernel 2.6.24 zu 2.6.27 r2
(beides Gentoo-Sources) scheinen die ACLs nicht mehr zu funktionieren:

$ getfacl /home/
getfacl: /home/: Das Argument ist ungültig

rsync: get_acl: sys_acl_get_file(/var, ACL_TYPE_ACCESS): Invalid argument
(22) rsync error: some files/attrs were not transferred (see previous
errors) (code 23) at main.c(1040) [sender=3.0.4]

Es scheint ein Kernel-Problem zu sein, da bei einem Neustart von 2.6.24 die
Probleme verschwinden.

Ein erstes Suchen brachte mir leider noch keine Lösung

# gunzip -c /proc/config.gz | grep -i acl
CONFIG_EXT2_FS_POSIX_ACL=y
CONFIG_EXT3_FS_POSIX_ACL=y
CONFIG_FS_POSIX_ACL=y
CONFIG_XFS_POSIX_ACL=y
CONFIG_GENERIC_ACL=y
CONFIG_TMPFS_POSIX_ACL=y
CONFIG_NFS_V3_ACL=y
CONFIG_NFSD_V2_ACL=y
CONFIG_NFSD_V3_ACL=y
CONFIG_NFS_ACL_SUPPORT=y

$ dmesg | grep -i acl
[ 0.449286] SGI XFS with ACLs, security attributes, realtime, large
block numbers, no debug enabled

# emerge -pv acl

These are the packages that would be merged, in order:

Calculating dependencies ... done!
[ebuild R ] sys-apps/acl-2.2.47 USE="nfs nls" 0 kB

Vielen Dank für jeden Hinweis
Gruß Andreas

Ähnliche fragen