[gentoo-user-de] alte Programmversion installieren

25/03/2010 - 12:10 von Stefan Nowy | Report spam
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)

Hallo!

Ich habe (leider) ein paar updates gemacht, dabei wurden einige
libraries aktualisiert; nun startet die installierte Version von
inkscape (0.46-r5) nicht mehr.

Das eigentliche Problem: im portage-tree ist nur noch Version 0.47 von
inkscape vorhanden ist, welche ein "feature" hat, das fà¼r mich aber ein
"bug" ist, sprich ich brauche unbedingt Version 0.46!

emerge -pv "=media-gfx/inkscape-0.46-r5"
liefert
emerge: there are no ebuilds to satisfy "=media-gfx/inkscape-0.46-r5"

Das ebuild ist lokal aber noch vorhanden
(/var/db/pkg/media-gfx/inkscape-0.46-r5)


Was macht man in so einer Situation am Besten?
Wie kann ich die alte Version nochmal kompilieren und installieren?


Danke und viele Grà¼àŸe
Stefan




 

Lesen sie die antworten

#1 Felix Schuster
25/03/2010 - 12:20 | Warnen spam
Hi!

On Don, 2010-03-25 at 12:02 +0100, Stefan Nowy wrote:
Was macht man in so einer Situation am Besten?
Wie kann ich die alte Version nochmal kompilieren und installieren?



Verwend ein lokales overlay (und - falls notwendig: maskier die
aktuelleren Versionen)!

Schöne Grüße
Felix
Felix Schuster
Vienna, Austria

Ähnliche fragen