[gentoo-user-de] baselayout-2 und crypt-swap

03/05/2008 - 08:10 von Bernd Wurst | Report spam

Hallo.

Ich habe heute mein ~amd64-System mal auf baselayout-2 und openRC umgestellt.

Das einzige was jetzt Probleme macht ist mein Crypt-Swap (konfiguriert à¼ber
dmcrypt-init-script). An dieser Konfiguration wurde eigentlich à¼berhaupt
nichts verà¤ndert, doch jetzt bleibt das System beim Ausfà¼hren von cryptsetup
(also bei der Anzeige der Parameter und vor "Running pre_mount command") ca.
eine halbe Minute stehen.

Beim ersten Versuch dachte ich, das System sei eingefroren, aber beim nà¤chsten
boot habe ich parallel auf dem Laptop nach Lösungen gesucht und plötzlich hat
der Rechner weiter gebootet.

Hat jemand ne Idee?

GruàŸ,
Bernd



gentoo-user-de@lists.gentoo.org mailing list
 

Lesen sie die antworten

#1 Dirk Heinrichs
03/05/2008 - 12:40 | Warnen spam

Am Samstag, 3. Mai 2008 schrieb Bernd Wurst:

Ich habe heute mein ~amd64-System mal auf baselayout-2 und openRC
umgestellt.

Das einzige was jetzt Probleme macht ist mein Crypt-Swap (konfiguriert à¼ber
dmcrypt-init-script). An dieser Konfiguration wurde eigentlich à¼berhaupt
nichts verà¤ndert, doch jetzt bleibt das System beim Ausfà¼hren von
cryptsetup (also bei der Anzeige der Parameter und vor "Running pre_mount
command") ca. eine halbe Minute stehen.

Beim ersten Versuch dachte ich, das System sei eingefroren, aber beim
nà¤chsten boot habe ich parallel auf dem Laptop nach Lösungen gesucht und
plötzlich hat der Rechner weiter gebootet.

Hat jemand ne Idee?




Kurzer Blick in /lib/rcscripts/addons/dm-crypt-start.sh zeigt das das Keyfile
von /dev/urandom geholt wird. Eventuell ist das der Grund.

Bye...

Dirk



mailing list

Ähnliche fragen