[gentoo-user-de] bluetooth mit hci?

18/07/2009 - 09:20 von Thomas Bruns | Report spam
Hallo NG

wie bekomme ich bluetooth mit hci zum laufen?

ich habe folgendes Installiert:
[I] net-wireless/bluez
Available versions: (~)4.28 (~)4.38 (~)4.39 {alsa cups debug doc
gstreamer old-daemons test-programs usb}
Installed versions: 4.39(08:30:59 18.07.2009)(alsa cups usb -debug -doc
-gstreamer -old-daemons -test-programs)

hab

/etc/init.d/bluetooth start
* Starting Bluetooth ...
* Starting bluetoothd ...
[ ok ]
* Starting rfcomm ...

gemacht und
ps -ae | grep hcid -> keineAusgabe
ps -ae | grep sdpd -> keine Ausgabe
hciconfig -a -> keine Ausgabe
hcitool scan
Device is not available: No such device

lsusb
Bus 004 Device 001: ID 1d6b:0001
Bus 002 Device 001: ID 1d6b:0002
Bus 006 Device 001: ID 1d6b:0001
Bus 007 Device 001: ID 1d6b:0001
Bus 008 Device 002: ID 046d:c404 Logitech, Inc. TrackMan Wheel
Bus 008 Device 001: ID 1d6b:0001
Bus 003 Device 001: ID 1d6b:0001
Bus 005 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle
(HCI mode)
Bus 005 Device 001: ID 1d6b:0001
Bus 001 Device 001: ID 1d6b:0002

cat /proc/bus/usb/devices | grep -e^[TPD] | grep -e Cls=e0 -B1 -A1
T: Bus Lev Prnt Port Cnt Dev#= 3 Spd MxCh= 0
D: Ver= 1.10 Cls=e0(unk. ) Sub Prot MxPSd #Cfgs= 1
P: Vendor=0a12 ProdID01 Rev= 8.28

Gruß
Thomas

CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -msse4.1 -msse4.2 -pipe"
CXXFLAGS="-march=core2 -O2 -msse4.1 -msse4.2 -pipe"
LDFLAGS="-Wl,-O1,--hash-style=gnu,--sort-common,--as-needed"
 

Lesen sie die antworten

#1 André Glücksmann
18/07/2009 - 16:10 | Warnen spam
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)

Thomas Bruns wrote:
Hallo NG

wie bekomme ich bluetooth mit hci zum laufen?

ich habe folgendes Installiert:
[I] net-wireless/bluez
Available versions: (~)4.28 (~)4.38 (~)4.39 {alsa cups debug doc
gstreamer old-daemons test-programs usb}
Installed versions: 4.39(08:30:59 18.07.2009)(alsa cups usb -debug -doc
-gstreamer -old-daemons -test-programs)

hab

/etc/init.d/bluetooth start
* Starting Bluetooth ...
* Starting bluetoothd ...
[ ok ]
* Starting rfcomm ...

gemacht und
ps -ae | grep hcid -> keineAusgabe
ps -ae | grep sdpd -> keine Ausgabe
hciconfig -a -> keine Ausgabe
hcitool scan
Device is not available: No such device

lsusb
Bus 004 Device 001: ID 1d6b:0001
Bus 002 Device 001: ID 1d6b:0002
Bus 006 Device 001: ID 1d6b:0001
Bus 007 Device 001: ID 1d6b:0001
Bus 008 Device 002: ID 046d:c404 Logitech, Inc. TrackMan Wheel
Bus 008 Device 001: ID 1d6b:0001
Bus 003 Device 001: ID 1d6b:0001
Bus 005 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle
(HCI mode)
Bus 005 Device 001: ID 1d6b:0001
Bus 001 Device 001: ID 1d6b:0002

cat /proc/bus/usb/devices | grep -e^[TPD] | grep -e Clsà -B1 -A1
T: Bus=05 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 3 Spd=12 MxCh= 0
D: Ver= 1.10 Clsà(unk. ) Sub=01 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=0a12 ProdID=0001 Rev= 8.28




Moin Thomas,

vielleicht ne' triviale Geschichte: Hast du den Kernel-Support an?
Ich erinnere mich, dass ich zudem noch die libs und tools installiert
hatte? Hat bluez das mitgezogen?

Gruß
André
André Glücksmann
- GnuPG Key-ID: 0x1489FF7D




Ähnliche fragen