[gentoo-user-de] Das automatische Mounten von USB-Devices unter Gnome funktioniert nicht mehr

26/11/2009 - 13:20 von Juergen Rose | Report spam
Seit einiger Zeit (vielleicht seit dem Upgrade auf gnome-2.28)
funktioniert das automatische Mounten von USB-Geraeten bei mir nicht
mehr.

Wenn ich einen USB-Stick einstecke geht eine Fenster auf, in dem steht:

Cannot mount volume.
Unable to mount the volume.

Details
IsCallerprivileged failed

Ich glaube, dass ich alle notwendigen Gruppenzugehoerigkeiten habe:

rose@lynx:/home/rose(4)$ id
uid03(rose) gid00(rose)
Gruppen00(rose),4(adm),6(disk),7(lp),10(wheel),14(uucp),18(audio),19(cdrom),27(video),35(games),100(users),250(portage),1000(rose),1004(plugdev),1010(vboxusers),1013(wireshark),1016(qemu),1020(kvm),1212(nwaccess),1217(tuntap)

Wenn ich dann noch etwas warte, geht ein zweitens Fenster auf mit der
Mitteilung:

Einhàngen von 16.1 GB Media nicht möglich
DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a
reply. Possible causes include: the remote application did not send a
reply, the message bus security policy blocked the reply, the reply
timeout expired, or the network connection was broken.


Der dbus und der hal daemon scheinen zu laufen:
rose@lynx:/home/rose(6)$ ps -ef | grep hal | grep -v grep
102 4253 1 0 Nov25 ? 00:00:03 /usr/sbin/hald
root 4257 4253 0 Nov25 ? 00:00:00 hald-runner
root 4349 4257 0 Nov25 ? 00:00:00 hald-addon-input:
Listening
on /dev/input/event4 /dev/input/event1 /dev/input/event3 /dev/input/event2 /dev/input/event0 /dev/input/event7
root 4351 4257 0 Nov25 ?
00:00:00 /usr/libexec/hald-addon-rfkill-killswitch
root 4357 4257 0 Nov25 ?
00:00:00 /usr/libexec/hald-addon-leds
root 4359 4257 0 Nov25 ?
00:00:00 /usr/libexec/hald-addon-generic-backlight
root 4362 4257 0 Nov25 ? 00:00:03 hald-addon-storage:
polling /dev/sr0 (every 2 sec)
root 4371 4257 0 Nov25 ?
00:00:00 /usr/libexec/hald-addon-cpufreq
102 4372 4257 0 Nov25 ? 00:00:00 hald-addon-acpi:
listening on acpid socket /var/run/acpid.socket
rose 5342 1 0 Nov25 ?
00:00:00 /usr/libexec/gvfs-hal-volume-monitor
root 26290 4257 0 11:47 ? 00:00:00 hald-addon-storage:
polling /dev/sdb (every 2 sec)
rose 26298 1 0 11:47 ? 00:00:00 /usr/bin/gnome-mount
rose@lynx:/home/rose(7)$ ps -ef | grep dbus | grep -v grep
101 2689 1 0 Nov25 ? 00:00:01 /usr/bin/dbus-daemon
rose 5177 1 0 Nov25 ? 00:00:00 /usr/bin/dbus-launch
rose 5178 1 0 Nov25 ? 00:00:00 /usr/bin/dbus-daemon
root 30019 1 0 Nov25 pts/7 00:00:00 dbus-launch --autolaunch
3b5f1fa327623a8a2a25c4534896d6a5 --binary-syntax --close-stderr
root 30021 1 0 Nov25 ? 00:00:00 /usr/bin/dbus-daemon

Hat jemand einen Tip?
 

Lesen sie die antworten

#1 Daniel Pielmeier
26/11/2009 - 15:10 | Warnen spam
Am 26. November 2009 12:33 schrieb Juergen Rose :
Hat jemand einen Tip?



Ja, ich würde mal auf Policykit tippen. Ist es installiert? Falls ja,
blockieren vermutlich die derzeitigen Einstelungen das Automounten.
Ich selbst verwende Policykit nicht aber Google ist sicher bei der
Problemlösung behilflich.

Daniel Pielmeier

Ähnliche fragen