[gentoo-user-de] Dazuko 3.1.0.0 Error

07/10/2009 - 15:20 von Bodo von Thadden | Report spam
Moin,

benutzt jemand von Euch das Kernel-Modul Dazuko ?

Ich habe das Problem, dass sich dazuko bei mir nicht übersetzen làsst.
Mit der aktuellen Kernel Version 2.6.31.2 bekomme ich folgende Meldung :

#make -C /lib/modules/`uname -r`/build SUBDIRS="`pwd`" modules
make[1]: Entering directory `/usr/src/linux-2.6.31.2'
CC [M] /usr/local/src/dazukofs-3.1.0/super.o
CC [M] /usr/local/src/dazukofs-3.1.0/inode.o
CC [M] /usr/local/src/dazukofs-3.1.0/file.o
/usr/local/src/dazukofs-3.1.0/file.c: In function 'dazukofs_open':
/usr/local/src/dazukofs-3.1.0/file.c:185: error: dereferencing pointer
to incomplete type
make[2]: *** [/usr/local/src/dazukofs-3.1.0/file.o] Error 1
make[1]: *** [_module_/usr/local/src/dazukofs-3.1.0] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.31.2'
make: *** [dazukofs_modules] Error 2

Kann das jemand bestàtigen, oder bin ich der einzigste, der das Problem
hat.

Bodo
 

Lesen sie die antworten

#1 Oliver Rath
07/10/2009 - 16:40 | Warnen spam
Bodo von Thadden schrieb:
Moin,

benutzt jemand von Euch das Kernel-Modul Dazuko ?

Ich habe das Problem, dass sich dazuko bei mir nicht übersetzen làsst.
Mit der aktuellen Kernel Version 2.6.31.2 bekomme ich folgende Meldung :

#make -C /lib/modules/`uname -r`/build SUBDIRS="`pwd`" modules
make[1]: Entering directory `/usr/src/linux-2.6.31.2'
CC [M] /usr/local/src/dazukofs-3.1.0/super.o
CC [M] /usr/local/src/dazukofs-3.1.0/inode.o
CC [M] /usr/local/src/dazukofs-3.1.0/file.o
/usr/local/src/dazukofs-3.1.0/file.c: In function 'dazukofs_open':
/usr/local/src/dazukofs-3.1.0/file.c:185: error: dereferencing pointer
to incomplete type
make[2]: *** [/usr/local/src/dazukofs-3.1.0/file.o] Error 1
make[1]: *** [_module_/usr/local/src/dazukofs-3.1.0] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.31.2'
make: *** [dazukofs_modules] Error 2

Kann das jemand bestàtigen, oder bin ich der einzigste, der das Problem
hat.



Scheint ein Compiler-Problem zu sein. von gcc-4.2 auf gcc-4.3 wurden ein
paar Warnungen in Fehler verschàrft. Sollte mit 4.2.4 bauen, oder
einfach gucken, was den Fehler verursacht und beheben. Alternativ den
gcc-Schalter -fpermissive einschalten, habe ich aber jetzt nicht getestet.

"make V=1" zeigt übrigens den kompletten gcc-Aufruf.

Gruß

Oliver

Ähnliche fragen