[gentoo-user-de] Drucken auf https-Drucker geht nicht mehr

15/07/2010 - 12:10 von Bernd Wurst | Report spam

Hallo.

Ich habe einen Netzwerkdrucker, den ich per https://kyocera/printers/lp1 in
CUPS eingetragen habe.

Wenn ich darauf drucken will, kommt seit gestern (der letzte Druckauftrag am
12.7. ging ohne Probleme durch) immer
| wiederherstellbar: Netzwerkhost „kyocera“ ist ausgelastet; erneuter Versuch
| in 5 Sekunden …

Gestern frà¼h hatte ich ein world-update laufen gelassen (das erste seit etwa
nem Monat), ich vermute mal dass es damit irgendwie zusammen hà¤ngt.


Wenn ich per strace den Prozess "https" der von CUPS gestartet wird,
untersuche, findet sich da wenig sinnvolles:

select(5, [4], NULL, NULL, {0, 0}) = 1 (in [4], left {0, 0})
poll([{fd=4, events=POLLIN}], 1, 1000) = 1 ([{fd=4, revents=POLLIN|POLLHUP}])
read(4, "", 16388) = 0
write(2, "DEBUG: Getting supported attributes...", 39) = 39
close(5) = 0
socket(PF_INET, SOCK_STREAM, IPPROTO_IP) = 5
setsockopt(5, SOL_SOCKET, SO_REUSEADDR, [1], 4) = 0
setsockopt(5, SOL_TCP, TCP_NODELAY, [1], 4) = 0
fcntl(5, F_SETFD, FD_CLOEXEC) = 0
connect(5, {sa_family=AF_INET, sin_port=htons(443),
sin_addr=inet_addr("192.168.0.110")}, 16) = 0
sendto(5, "POST /printers/lp1 HTTP/1.1Content-Length: 468Content-Type:
application/ippHost: kyoceraUser-Agent: CUPS/1.4.4Expect: 100-
continue", 144, 0, NULL, 0) = 144
sendto(5, "\1\1\0\v\0\0\0\1\1G\0\22attributes-
charset\0\5utf-8H\0\33attributes-natural-language\0\5de-deE\0\vprinter-uri\0
https://kyocera:443/printers/lp1D\0\24requested-
attributes\0#com.apple.print.recoverable-messageD\0\0\0\20copies-
supportedD\0\0\0\31document-format-supportedD\0\0\0marker-
colorsD\0\0\0\22marker-high-levelsD\0\0\0marker-levelsD\0\0\0\21marker-low-
levelsD\0\0\0\16marker-messageD\0\0\0\fmarker-namesD\0\0\0\fmarker-
typesD\0\0\0\31printer-is-accepting-jobsD\0\0\0printer-
stateD\0\0\0\25printer-state-messageD\0\0\0\25printer-state-reasons\3", 468,
0, NULL, 0) = 468
poll([{fd=5, events=POLLIN}], 1, 1000) = 1 ([{fd=5, revents=POLLIN}])
recvfrom(5, "", 2048, 0, NULL, NULL) = 0
write(2, "WARNING: wiederherstellbar: Netzwerkhost
\342\200\236kyocera\342\200\234 ist ausgelastet; erneuter Versuch in 20
Sekunden \342\200\246", 108) = 108
rt_sigprocmask(SIG_BLOCK, [CHLD], [PIPE], 8) = 0
rt_sigaction(SIGCHLD, NULL, {SIG_DFL, [], 0}, 8) = 0
rt_sigprocmask(SIG_SETMASK, [PIPE], NULL, 8) = 0
nanosleep({20, 0}, ^C <unfinished ...>


Auch Umstellen auf ipp:// oder http:// bringt keinen Erfolg. Lediglich die
Umstellung auf socket:// funktioniert dann.

Gab es bei CUPS unter Gentoo in jà¼ngerer Zeit irgendwelche Probleme beim
Upgrade?

GruàŸ, Bernd

<DigiGnome> Real life should have a fucking search function, or something.
<DigiGnome> I need my socks.



 

Lesen sie die antworten

#1 Bernd Wurst
15/07/2010 - 12:10 | Warnen spam

Am Donnerstag 15 Juli 2010, 11:10:08 schrieb Bernd Wurst:
Auch Umstellen auf ipp:// oder http:// bringt keinen Erfolg. Lediglich die
Umstellung auf socket:// funktioniert dann.



Okay, manchmal hilft Nachdenken:
Wenn ich im Drucker non-SSL-Zugriff erlaube, dann funktioniert ipp://.

Es liegt also irgendwie am SSL, das ich allerdings gerne benutzen würde.
Per Browser kann ich die URL https://kyocera/printers/lp1 aufrufen und
erhalten einen IPP-Bericht.

Gruß, Bernd

OS/2 - Wo ist die andere Hàlfte?



Ähnliche fragen