[gentoo-user-de] Eigene Sets für Portage

10/06/2012 - 13:10 von Michael Volland | Report spam
Hi,

hab versucht eigene sets für portage zu konfigurieren: Leider werden die
nicht erkannt.

Ich dachte es würde genügen z.B. eine Datei "cross" in
/etc/portage/sets
anzulegen und in dieser Atoms nach dem Muster:
cross-armv7a-unknown-linux-gnueabi/binutils
hinein zu schreiben.

aber:
# emerge -av @cross
emerge: There are no sets to satisfy 'cross'. The following sets exist:

selected
system
world
-
Hab zu dem Thema u.a.
http://forums.gentoo.org/viewtopic-...art-0.html
gelesen.
Aufgefallen ist mir dabei, dass es keine
/usr/share/portage/config/sets.conf
auf meinem Rechner gibt. (~amd64)
Dafür aber
/usr/share/portage/config/sets/portage.conf

Hat jemand eine Idee?

Gruß
Michael
 

Lesen sie die antworten

#1 Florian Philipp
10/06/2012 - 14:20 | Warnen spam
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)

Am 10.06.2012 13:06, schrieb Michael Volland:
Hi,

hab versucht eigene sets fà¼r portage zu konfigurieren: Leider werden die
nicht erkannt.

Ich dachte es wà¼rde genà¼gen z.B. eine Datei "cross" in
/etc/portage/sets
anzulegen und in dieser Atoms nach dem Muster:
cross-armv7a-unknown-linux-gnueabi/binutils
hinein zu schreiben.

aber:
# emerge -av @cross
emerge: There are no sets to satisfy 'cross'. The following sets exist:

selected
system
world
-
Hab zu dem Thema u.a.
http://forums.gentoo.org/viewtopic-...art-0.html
gelesen.
Aufgefallen ist mir dabei, dass es keine
/usr/share/portage/config/sets.conf
auf meinem Rechner gibt. (~amd64)
Dafà¼r aber
/usr/share/portage/config/sets/portage.conf

Hat jemand eine Idee?

GruàŸ
Michael





Welche Version von Portage verwendest du? Benutzerdefinierte Sets
funktionieren erst in portage-2.2

MfG.
Florian Philipp




Ähnliche fragen