[gentoo-user-de] emerge --update uebersieht was?

07/06/2008 - 13:20 von Klaus Fabritius | Report spam
Moin!

| root> emerge -p --update --deep --newuse world
|
| These are the packages that would be merged, in order:
|
| Calculating world dependencies... done!

Aber:

| root> emerge -p bc
|
| These are the packages that would be merged, in order:
|
| Calculating dependencies... done!
| [ebuild U ] sys-devel/bc-1.06.95 [1.06-r6] USE="-libedit%"

Warum weiss "emerge --update" nichts davon?


-kfk
gentoo-user-de@lists.gentoo.org mailing list
 

Lesen sie die antworten

#1 Andreas Prieß
07/06/2008 - 14:30 | Warnen spam

Hallo.

Zitat der eMail vom 07.06.2008 um 13:19 Uhr:
| root> emerge -p --update --deep --newuse world
|
| These are the packages that would be merged, in order:
|
| Calculating world dependencies... done!

Aber:

| root> emerge -p bc
|
| These are the packages that would be merged, in order:
|
| Calculating dependencies... done!
| [ebuild U ] sys-devel/bc-1.06.95 [1.06-r6] USE="-libedit%"

Warum weiss "emerge --update" nichts davon?



Ich wà¼rde mal sagen emerge weiàŸ davon, hà¤lt es aber fà¼r nicht so
wichtig. Wahrscheinlich ist bc nur eine buildtime dependency, die von
emerge --update nicht erfasst wird.

Probiere einfach mal
emerge --update --deep --newuse --with-bdeps y world

Bei mir steht das "--with-bdeps y" in der make.conf bei den
EMERGE_DEFAULT_OPTS, dann wird das immer mit erfasst.


Grà¼àŸe
Andreas



mailing list

Ähnliche fragen