[gentoo-user-de] emul-linux-x86-java wrong ELF class: ELFCLASS32/is not a valid NPAPI plugin

10/01/2008 - 21:20 von Chris Cohen | Report spam
Hi Listianer,

ich hab' noch ein Problem mit meiner neuen Gentoo installation, dass ich nicht
selber lösen kann:

Ich habe app-emulation/emul-linux-x86-java-1.6.0.03 installiert, ich nutze
www-client/mozilla-firefox-2.0.11 und net-www/nspluginwrapper-0.9.91.4.

Wenn ich auf eine Seite mit irgendwelche Java-Schnickschnack surfe wird das
Java-Plugin nicht gefunden und ich bekomme:

LoadPlugin: failed to initialize shared
library /opt/emul-linux-x86-java-1.6.0.03/plugin/i386/ns7/libjavaplugin_oji.so
[/opt/emul-linux-x86-java-1.6.0.03/plugin/i386/ns7/libjavaplugin_oji.so:
wrong ELF class: ELFCLASS32]

... und nspluginwrapper meint:
nspluginwrapper: /opt/emul-linux-x86-java-1.6.0.03/plugin/i386/ns7/libjavaplugin_oji.so
is not a valid NPAPI plugin

Wie bekomme ich mein Java nsplugin doch noch zum laufen?

Schönen Abend
Chris
gentoo-user-de@lists.gentoo.org mailing list
 

Lesen sie die antworten

#1 Arnold Krille
10/01/2008 - 21:50 | Warnen spam
2008/1/10, Chris Cohen :
ich hab' noch ein Problem mit meiner neuen Gentoo installation, dass ich nicht
selber lösen kann:
Ich habe app-emulation/emul-linux-x86-java-1.6.0.03 installiert, ich nutze
www-client/mozilla-firefox-2.0.11 und net-www/nspluginwrapper-0.9.91.4.
Wie bekomme ich mein Java nsplugin doch noch zum laufen?



Indem Du entweder dem firefox-ebuild beibringst, das es für 32-bit
gebaut werden soll. Oder firefox-bin verwendest...

Oder java mit 64bit...

Arnold
visit http://www.arnoldarts.de/
mailing list

Ähnliche fragen