[gentoo-user-de] Externe Platte via Label mounten

05/03/2008 - 00:40 von Roland Damm | Report spam
Moin,

ich fürchte ja, das ist ein alter Hut, aber ich bin nach Verwirrungen auf
folgendes Phànomen gestoßen:

Jetzt mit zweiter externe usb-Platte nebste gelegentlichem Memory-Stick wollte
ich mal weg von den Geràtebezeichnungen /dev/sd(xyz) hin zu labels. Dazu habe
ich labels vergeben.
[Einschub: Abgeblich geht mounten per label bei fat-Partitionen nicht. Die
eine externe Platte hat aber vfat und einen werksseitigen label, den ich
angezeigt bekomme und via dem ich mounten kann. Der usb-Stick hat aber keinen
Label. Bekomme ich da einen drauf (vfat-Dateisystem)?]
Jedenfalls 2 der 3 Geràte habe ich 'gelabelt', in der fstab mit
LABEL=labersülz eingetragen und kann sie per mount auch mounten. Sie
kommen auch da hin, wo sie hin sollen. Alles schön. Nur mit dem USB-Stick
geht das nicht, magels label. Aber da hilft ja uuid. Auch gut, damit geht
auch das.

Aber: Dank HAL und sowas erscheint auf dem KDE-Desktop nach einstecken eines
der Geràte ein Symbol und das Fenster, was mich fragt, was damit zu tun sein
(öffnen, abspielen). Klicke ich auf öffnen, bekomme ich die
Meldung 'Permissions denied' (mit der Betonung auf Permission_s_ :-)).
Schreibe ich die fstab wieder zurück auf die Angabe mit /dev/sd(xyz) dann
geht das wieder.
Dieses schöne mounten per Mausklick scheint wohl aus irgendwelchen Gründen
nicht zu gehen, wenn die Partition in der fstab anders als via /dev/...
angegeben ist. Wieso? mount von der Kommandozeile aus geht doch.

Also Frage: Wie kriege ich das hin, dass ich die externen Platten genau dort
gemountet bekomme, wo ich sie hin haben will (unabhàngig von der Reihenfolge
des Anschließens), aber dazu nicht per Kommandozeile mount eintippen
muss, sondern per Mausklick auf KDE-Oberflàche das mounten durchführen kann?
Muss man da doch wieder auf selbstgebaute Skripte zurückgreifen?

CU ROllo
gentoo-user-de@lists.gentoo.org mailing list
 

Lesen sie die antworten

#1 Jan
05/03/2008 - 02:00 | Warnen spam

On Mi, 05 Mà¤r 2008 00:28 +0100, Roland Damm wrote:
Moin,

ich fà¼rchte ja, das ist ein alter Hut, aber ich bin nach Verwirrungen auf
folgendes Phà¤nomen gestoàŸen:

Jetzt mit zweiter externe usb-Platte nebste gelegentlichem Memory-Stick wollte
ich mal weg von den Gerà¤tebezeichnungen /dev/sd(xyz) hin zu labels. Dazu habe
ich labels vergeben.
[Einschub: Abgeblich geht mounten per label bei fat-Partitionen nicht. Die
eine externe Platte hat aber vfat und einen werksseitigen label, den ich
angezeigt bekomme und via dem ich mounten kann. Der usb-Stick hat aber keinen
Label. Bekomme ich da einen drauf (vfat-Dateisystem)?]



mkfs -t vfat -n "label"
steht in der Manpage von mkdosfs. Nachtrà¤glich kann man das Label unter
Linux meines Wissens nach nicht à¤ndern.

Jedenfalls 2 der 3 Gerà¤te habe ich 'gelabelt', in der fstab mit
LABEL=labersà¼lz eingetragen und kann sie per mount auch mounten. Sie
kommen auch da hin, wo sie hin sollen. Alles schön. Nur mit dem USB-Stick
geht das nicht, magels label. Aber da hilft ja uuid. Auch gut, damit geht
auch das.

Aber: Dank HAL und sowas erscheint auf dem KDE-Desktop nach einstecken eines
der Gerà¤te ein Symbol und das Fenster, was mich fragt, was damit zu tun sein
(öffnen, abspielen). Klicke ich auf öffnen, bekomme ich die
Meldung 'Permissions denied' (mit der Betonung auf Permission_s_ :-)).
Schreibe ich die fstab wieder zurà¼ck auf die Angabe mit /dev/sd(xyz) dann
geht das wieder.
Dieses schöne mounten per Mausklick scheint wohl aus irgendwelchen Grà¼nden
nicht zu gehen, wenn die Partition in der fstab anders als via /dev/...
angegeben ist. Wieso? mount von der Kommandozeile aus geht doch.

Also Frage: Wie kriege ich das hin, dass ich die externen Platten genau dort
gemountet bekomme, wo ich sie hin haben will (unabhà¤ngig von der Reihenfolge
des AnschlieàŸens), aber dazu nicht per Kommandozeile mount eintippen
muss, sondern per Mausklick auf KDE-Oberflà¤che das mounten durchfà¼hren kann?
Muss man da doch wieder auf selbstgebaute Skripte zurà¼ckgreifen?



Ich habe hier das gleiche Problem mit Thunar. Wenn ich den Eintrag in
der fstab entferne, geht es aber.
Alternativ geht es auch mit einer udev-Regel, z.B.:
BUS=="scsi", KERNEL=="sd?1", SYSFS{model}=="DataTraveler 2.0",
GROUP="plugdev", SYMLINK="usbstick%n"
Die benötigten Daten erhà¤ltst du mit udevinfo -a -p /block/sdx/sdx1

GruàŸ, Jan



mailing list

Ähnliche fragen