[gentoo-user-de] firefox-bin 3.5x -> 3.6.8 und glibc

14/09/2010 - 12:20 von Max Bloch | Report spam
Hallo allerseits,

ich habe neulich mein firefox-bin von 3.5x auf 3.6.8 aktualisiert und
leider hat Portage nicht alle Abhàngigkeiten berücksichtigt und ich
bekomme beim ausführen von firefox-bin nun die Fehlermeldung:

$ firefox-bin
/opt/firefox/firefox-bin: /lib32/libc.so.6: version `GLIBC_2.9' not
found (required by /usr/lib32/libglib-2.0.so.0)
/opt/firefox/firefox-bin: /lib32/libc.so.6: version `GLIBC_2.9' not
found (required by /usr/lib32/libgio-2.0.so.0)

bei mir làuft noch glibc 2.8. Nun überlege ich ob ich lieber mein glibc
aktualisieren sollte oder auf firefox-bin 3.5x zurück gehen sollte. Ich
habe Bedenken glibc zu aktualisieren, da ich Angst habe andere
Abhàngigkeiten zu zerschießen und wenig Lust habe den ganzen Tag mein
System zusammenzufrickeln und ewig zu kompilieren, da ich einen lahmen
Prozessor habe und ich mit meinem System eigentlich zufrieden bin.

Weiss wer ob ich mit dem upgrade glibc 2.8 -> 2.9 bzw. -> 2.11
Komplikationen erwarten kann?
Weiss wer ob es ein Overlay mit àlteren firefox-bin gibt?

Vielen Dank
Max
 

Lesen sie die antworten

#1 Jan Kohnert
14/09/2010 - 15:20 | Warnen spam

Max Bloch schrieb:
ich habe neulich mein firefox-bin von 3.5x auf 3.6.8 aktualisiert und
leider hat Portage nicht alle Abhàngigkeiten berücksichtigt und ich
bekomme beim ausführen von firefox-bin nun die Fehlermeldung:

$ firefox-bin
/opt/firefox/firefox-bin: /lib32/libc.so.6: version `GLIBC_2.9' not
found (required by /usr/lib32/libglib-2.0.so.0)
/opt/firefox/firefox-bin: /lib32/libc.so.6: version `GLIBC_2.9' not
found (required by /usr/lib32/libgio-2.0.so.0)



Lass mch mal in meine Glaskugel schauen:
Du hast ein 64bit Profil mit Multilib und den 32bit firefox-bin genommen,
damit youpo, àh flash funktioniert?

Es ist dann wohl bei einem Upgrade der 32bit Packete was schiefgegangen:
glib braucht glibc-2.9. Das Problem hat mit dem firefox nur bedingt zu tun, da
dieser wieder glib braucht, welche nicht geladen werden kann wegen glibc. :)

Ich hab grad kein 64bit System zu Hand, deshalb schau mal nach, zu welchem
Paket /usr/lib32/libglib-2.0.so.0 gehört (z.B. mittels equery f $filname) und
schau dann in bugs.gentoo.org, ob da schon was bekannt ist. Sollte dem nicht
so sein, poste dort einen Bugreport. Wenn du ganz lieb sein willst, schau noch
nach, wie das 32bit-glibc Paket heißt (equery b /lib32/libc.so.6) und schau
nach, ob ein Upgrade des Paketes sauber làuft und das Problem behebt, dann
kannst du das an deinen Report als Lösung gleich anhàngen.

MfG Jan



Ähnliche fragen