[gentoo-user-de] ideviceinstaller - Fehlermeldung

21/08/2015 - 08:10 von Stefan Rohnke | Report spam
Hallo,
habe mir die Libimobiledevice und ifuse installiert.
Das mounten und der Rest klappt alles soweit.
Nun wollte ich mir mit idevieinstaller die appids listen lassen.
Dazu das Paket installiert und mit:
ideviceinstaller -l die Liste anzeigen.
Als einziges erscheint:
segfault
Ich rufe dmesg und sehe folgendes:

[1862331.213288] ideviceinstalle[22352]: segfault at d7d0 ip 00007fec6c061cf2 sp 00007ffe87b40958 error 4 in libimobiledevice.so.4.0.1[7fec6c058000+1d000]

Nun habe ich im Netz gefunden, dass es immer wieder zu solchen Meldungen
in den verschiedensten Distros kommt.
Lösungen gibt es irgendwie keine.

Làuft das bei euch erfolgreich oder auch nicht bzw. habt ihr
Lösungsvorschlàge?

Gruß
Stefan
 

Lesen sie die antworten

#1 Johann Schmitz (ercpe)
22/08/2015 - 08:20 | Warnen spam
Hash: SHA1

Hi,

On 21.08.2015 07:54, Stefan Rohnke wrote:
ideviceinstaller -l die Liste anzeigen. Als einziges erscheint:
segfault Ich rufe dmesg und sehe folgendes:



Du könntest zwei Dinge versuche:

strace ideviceinstaller -l

damit könntest du zumindest den letzten Call rausfinden der evtl. den
segfault auslöst. Vielleicht gibt das einen Hinweis.

Falls das nichts sinnvolles ergibt, versuch das Programm über gdb zu
starten um einen Backtrace zu bekommen (bin mir gerade nicht ganz
sicher wie man command line arguments im gdb an das Programm übergibt).

gdb ideviceinstaller

run -l

und wenn er kaputt geht:

bt

Damit solltest du zumindest die lib und die Funktion herausbekommen.
Vielleicht gibt dir das ein paar Hinweise.

Gruß,
Johann

Ähnliche fragen