[gentoo-user-de] KDE4 Anmeldung ging nach HALD-demon start nicht mehr

23/06/2009 - 18:40 von Thomas Bruns | Report spam
hallo NG,

ich habe ne USB-Tastatur und
ich habe folgendes gemacht:
den hald-demon in den runlevel default geschaufelt.

soweit so gut, danach hat KDE4 problemlos meinen IPOD usw erkannt.
nach einem neustart, ging die Anmeldung bei KDE4 nicht mehr, ich konnte das
richtige Passwort eingeben, ging nicht mehr. Auf der Konsole ging alles
wunderbar.

Der Fehler lag wohl an dem Hald-demon.

ich habe herausgefunden, das wenn der hald-demaon gestartet ist, die Tastatur
nicht mehr ordentlich erkannt wird, was sich wie folgt àußert, einige Tasten
werden gar nicht erkannt, andere Tastaturanchlàge doppelt, ergo keine
richtiges Passwort.

ich brauch doch aber den hald-demon :-(
Gruß
Thomas

CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -msse4.1 -msse4.2 -pipe"
CXXFLAGS="-march=core2 -O2 -msse4.1 -msse4.2 -pipe"
LDFLAGS="-Wl,-O1,--hash-style=gnu,--sort-common,--as-needed"
 

Lesen sie die antworten

#1 Alex Schuster
23/06/2009 - 19:10 | Warnen spam
Thomas Bruns schreibt:

ich habe ne USB-Tastatur und
ich habe folgendes gemacht:
den hald-demon in den runlevel default geschaufelt.

soweit so gut, danach hat KDE4 problemlos meinen IPOD usw erkannt.
nach einem neustart, ging die Anmeldung bei KDE4 nicht mehr, ich konnte
das richtige Passwort eingeben, ging nicht mehr. Auf der Konsole ging
alles wunderbar.

Der Fehler lag wohl an dem Hald-demon.



Eher daran, dass X durch HAL die Tastatur nun selbst erkennt, sie aber
zusàtzlich noch in der xorg.conf eingetragen ist. Lass mich raten, deine
Maus ist nun doppelt so schnell und macht nur noch Doppelklicks?

ich habe herausgefunden, das wenn der hald-demaon gestartet ist, die
Tastatur nicht mehr ordentlich erkannt wird, was sich wie folgt àußert,
einige Tasten werden gar nicht erkannt, andere Tastaturanchlàge doppelt,
ergo keine richtiges Passwort.

ich brauch doch aber den hald-demon :-(



Du könntest in xorg.conf ein
Option "AutoAddDevices" "false"
eintragen, das hat mir geholfen. Oder xorg-server ohne hal USE flag
übersetzen, wenn du auf de HAL Features verzichten willst. Oder Maus und
Tastatur aus der xorg.conf rausnehmen, deutsches Layout musst du dann aber
in /etc/hal/fdi/policy/ konfigurieren. Schau mal in den Xorg 1.5 Upgrade
Guide, da stehen einige Infos dazu.

<http://www.gentoo.org/proj/en/deskt...5-upgrade-
guide.xml>

Wonko

Ähnliche fragen