[gentoo-user-de] kernelversuch

19/08/2009 - 13:20 von Sebastian | Report spam
Hallo,
ich versuche gerade mal meinen Kernel von 2.6.26-r4 auf den Aktuellen
2.6.30-r4 zu bringen. Erhalte aber jetzt schon beim Kompilieren folgende
Fehlermeldung. Bei den Letzten versuchen bin ich immer beim booten des neuen
kernels gescheitert.

r2-gentoo linux # make && make modules_install
scripts/kconfig/conf -s arch/x86/Kconfig
CHK include/linux/version.h
CHK include/linux/utsrelease.h
SYMLINK include/asm -> include/asm-x86
CALL scripts/checksyscalls.sh
CHK include/linux/compile.h
GZIP kernel/config_data.gz
IKCFG kernel/config_data.h
CC kernel/configs.o
LD kernel/built-in.o
make[1]: *** Keine Regel vorhanden, um das Target »n/n«,
benötigt von »firmware/n.gen.o«, zu erstellen. Schluss.
make: *** [firmware] Fehler 2

Ich finde bei menuconfig nicht die richtigen schalten um das zu lösen.
oldconfig versucht keine Änderungen.

r2-gentoo linux # make oldconfig
scripts/kconfig/conf -o arch/x86/Kconfig
#
# configuration written to .config


Gruß
Sebastian
 

Lesen sie die antworten

#1 Christian Bricart
19/08/2009 - 14:40 | Warnen spam
Sebastian wrote:
Hallo,
ich versuche gerade mal meinen Kernel von 2.6.26-r4 auf den Aktuellen
2.6.30-r4 zu bringen. Erhalte aber jetzt schon beim Kompilieren folgende
Fehlermeldung. Bei den Letzten versuchen bin ich immer beim booten des
neuen
kernels gescheitert.

r2-gentoo linux # make && make modules_install
scripts/kconfig/conf -s arch/x86/Kconfig
CHK include/linux/version.h
CHK include/linux/utsrelease.h
SYMLINK include/asm -> include/asm-x86
CALL scripts/checksyscalls.sh
CHK include/linux/compile.h
GZIP kernel/config_data.gz
IKCFG kernel/config_data.h
CC kernel/configs.o
LD kernel/built-in.o
make[1]: *** Keine Regel vorhanden, um das Target »n/n«,
benötigt von »firmware/n.gen.o«, zu erstellen. Schluss.
make: *** [firmware] Fehler 2

Ich finde bei menuconfig nicht die richtigen schalten um das zu lösen.
oldconfig versucht keine à„nderungen.

r2-gentoo linux # make oldconfig
scripts/kconfig/conf -o arch/x86/Kconfig
#
# configuration written to .config



aus dem Bauch heraus würde ich mal unter:

Device Drivers ->
Generic Driver Options -->

bei den Firmware-Einstellungen schauen - hier scheint wohl der
Kconfig-Parser etwas falsch zu interpretieren..
Die Einstellungen:

[*] Select only drivers that don't need compile-time external firmware
[*] Prevent firmware from being built
-*- Userspace firmware loading support
[*] Include in-kernel firmware blobs in kernel binary
() External firmware blobs to build into the kernel binary
[ ] Driver Core verbose debug messages
[ ] Managed device resources verbose debug messages

tun auf jeden Fall bei mir ;-)

Christian

Ähnliche fragen