[gentoo-user-de] Knoten bei qt

21/10/2009 - 01:20 von Roland Damm | Report spam
Moin,

wie löst man diesen Knoten auf?

Es scheint, als ob da irgendwelche Pakete qt downgraden wollen (das leite ich
aus anderen Ausagen ab). Ausgabe:
=~ # emerge -Daut --newuse world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt-script:4

('ebuild', '/', 'x11-libs/qt-script-4.5.1', 'merge') pulled in by
~x11-libs/qt-script-4.5.1[-debug] required by
('ebuild', '/', 'x11-libs/qt-gui-4.5.1', 'merge')

('installed', '/', 'x11-libs/qt-script-4.5.2', 'nomerge') pulled in by
~x11-libs/qt-script-4.5.2[-debug] required by
('installed', '/', 'x11-libs/qt-gui-4.5.2-r2', 'nomerge')

=x11-libs/qt-script-4.5.1:4 required by


('ebuild', '/', 'kde-base/kwallet-4.3.1', 'merge')

=x11-libs/qt-script-4.5.1:4 required by


('ebuild', '/', 'kde-base/kjots-4.3.1', 'merge')
(and 173 more)

x11-libs/qt-sql:4

('ebuild', '/', 'x11-libs/qt-sql-4.5.1', 'merge') pulled in by
~x11-libs/qt-sql-4.5.1[qt3support,-debug] required by
('ebuild', '/', 'x11-libs/qt-qt3support-4.5.1', 'merge')

('installed', '/', 'x11-libs/qt-sql-4.5.2', 'nomerge') pulled in by

=x11-libs/qt-sql-4.5.1:4[qt3support] required by


('ebuild', '/', 'kde-base/kcminit-4.3.1', 'merge')
~x11-libs/qt-sql-4.5.2[qt3support,-debug] required by
('ebuild', '/', 'x11-libs/qt-qt3support-4.5.2', 'merge')

=x11-libs/qt-sql-4.5.1:4[qt3support] required by


('ebuild', '/', 'kde-base/kcheckpass-4.3.1', 'merge')
(and 173 more)

x11-libs/qt-core:4

('installed', '/', 'x11-libs/qt-core-4.5.2', 'nomerge') pulled in by
~x11-libs/qt-core-4.5.2[glib,qt3support,-debug] required by
('installed', '/', 'x11-libs/qt-gui-4.5.2-r2', 'nomerge')
~x11-libs/qt-core-4.5.2[-debug] required by
('installed', '/', 'x11-libs/qt-script-4.5.2', 'nomerge')
~x11-libs/qt-core-4.5.2[qt3support,-debug] required by
('ebuild', '/', 'x11-libs/qt-qt3support-4.5.2', 'merge')
(and 185 more)

('ebuild', '/', 'x11-libs/qt-core-4.5.1', 'merge') pulled in by
~x11-libs/qt-core-4.5.1[qt3support,-debug] required by
('ebuild', '/', 'x11-libs/qt-qt3support-4.5.1', 'merge')
~x11-libs/qt-core-4.5.1[glib,qt3support,-debug] required by
('ebuild', '/', 'x11-libs/qt-gui-4.5.1', 'merge')
~x11-libs/qt-core-4.5.1[-debug] required by
('ebuild', '/', 'x11-libs/qt-script-4.5.1', 'merge')
(and 2 more)

x11-libs/qt-gui:4

('ebuild', '/', 'x11-libs/qt-gui-4.5.1', 'merge') pulled in by
~x11-libs/qt-gui-4.5.1[qt3support,accessibility,-debug] required by
('ebuild', '/', 'x11-libs/qt-qt3support-4.5.1', 'merge')
~x11-libs/qt-gui-4.5.1[qt3support] required by
('ebuild', '/', 'x11-libs/qt-core-4.5.1', 'merge')

=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by


('ebuild', '/', 'kde-base/libkdeedu-4.3.1', 'merge')
(and 174 more)

('installed', '/', 'x11-libs/qt-gui-4.5.2-r2', 'nomerge') pulled in by
~x11-libs/qt-gui-4.5.2[qt3support] required by
('installed', '/', 'x11-libs/qt-core-4.5.2', 'nomerge')
~x11-libs/qt-gui-4.5.2[qt3support,accessibility,-debug] required by
('ebuild', '/', 'x11-libs/qt-qt3support-4.5.2', 'merge')
x11-libs/qt-gui:4 required by
('installed', '/', 'media-sound/musescore-0.9.4', 'nomerge')
(and 8 more)

x11-libs/qt-qt3support:4

('ebuild', '/', 'x11-libs/qt-qt3support-4.5.2', 'merge') pulled in by

=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by


('ebuild', '/', 'kde-base/kdepim-wizards-4.3.1', 'merge')

=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by


('ebuild', '/', 'kde-base/kurifilter-plugins-4.3.1', 'merge')
~x11-libs/qt-qt3support-4.5.2[-debug] required by
('installed', '/', 'x11-libs/qt-gui-4.5.2-r2', 'nomerge')
(and 172 more)

('ebuild', '/', 'x11-libs/qt-qt3support-4.5.1', 'merge') pulled in by
~x11-libs/qt-qt3support-4.5.1[-debug] required by
('ebuild', '/', 'x11-libs/qt-gui-4.5.1', 'merge')


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

=Jemand eine Idee, wie ich der Lösung auf die Spur komme?

Wahllos irgendwelche qt-Pakete deinstallieren hilft irgendwie nicht so recht,
haben mal testweise ein
emerge -C x11-libs/qt-script
probiert, àndert an obiger Ausgabe _nichts_.

CU Rollo
 

Lesen sie die antworten

#1 Dirk Heinrichs
21/10/2009 - 08:00 | Warnen spam

Am Mittwoch 21 Oktober 2009 01:17:09 schrieb Roland Damm:

Jemand eine Idee, wie ich der Lösung auf die Spur komme?



Siehe Thread "qt-dbus blocker" auf gentoo-user.

HTH...

Dirk



Ähnliche fragen