Forums Neueste Beiträge
 

[gentoo-user-de] media-video/em8300-modules-0.16.0-r1 failed!!!

28/03/2009 - 18:10 von Thomas Bruns | Report spam
Hallo NG,

ich hab da nen Problem, bei mir bricht das folgende Paket immer ab:

media-video/em8300-modules-0.16.0-r1

mich würde aber mal interessieren, warum es installiert werden soll, ich habe
diese Karten gar nicht :-(

Kann da jemand helfen????

LG
THomas


emerge -uND world
Calculating dependencies... done!




Verifying ebuild manifests

Starting parallel fetch

Emerging (1 of 3) media-video/em8300-modules-0.16.0-r1






* em8300-0.16.0.tar.gz RMD160 SHA1 SHA256 size ;-) ...
[ ok ]
* checking ebuild checksums ;-) ...
[ ok ]
* checking auxfile checksums ;-) ...
[ ok ]
* checking miscfile checksums ;-) ...
[ ok ]
* Determining the location of the kernel source code
* Found kernel source directory:
* /usr/src/linux
* Found kernel object directory:
* /lib/modules/2.6.24-gentoo-r8/build
* Found sources for kernel version:
* 2.6.24-gentoo-r8
* Checking for suitable kernel configuration options...
[ ok ]



Unpacking source...
Unpacking em8300-0.16.0.tar.gz






to /var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work
* Applying em8300-modules-0.16.0-i2c.patch ...
[ ok ]



Source unpacked






in /var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work



Compiling source






in /var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules ...
make -j2 KERNEL_LOCATION=/usr/src/linux
make -C /usr/src/linux
SUBDIRS=/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules
modules
make[1]: Entering directory `/usr/src/linux-2.6.24-gentoo-r8'
CC
[M] /var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/adv717x.o
CC
[M] /var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/bt865.o
In file included
from /var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/encoder.h:4,

from /var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/bt865.c:55:
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/../include/linux/em8300.h:269:
Fehler: expected specifier-qualifier-list before »snd_card_t«In file included
from /var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/adv717x.c:50:
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/../include/linux/em8300.h:269:
Fehler: expected specifier-qualifier-list before »snd_card_t«

/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/bt865.c:
In Funktion »bt865_setup«:
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/bt865.c:879:
Fehler: »struct em8300_s« hat kein Element namens »card_nr«
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/bt865.c:880:
Fehler: »struct em8300_s« hat kein Element namens »card_nr«
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/adv717x.c:
In Funktion »adv717x_setup«:
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/adv717x.c:573:
Fehler: »struct em8300_s« hat kein Element namens »card_nr«
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/adv717x.c:575:
Fehler: »struct em8300_s« hat kein Element namens »card_nr«
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/adv717x.c:580:
Fehler: »struct em8300_s« hat kein Element namens »card_nr«
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/adv717x.c:585:
Fehler: »struct em8300_s« hat kein Element namens »card_nr«
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/adv717x.c:586:
Fehler: »struct em8300_s« hat kein Element namens »card_nr«
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/adv717x.c:588:
Fehler: »struct em8300_s« hat kein Element namens »card_nr«
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/adv717x.c:591:
Fehler: »struct em8300_s« hat kein Element namens »card_nr«
make[2]: ***
[/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/bt865.o]
Fehler 1
make[2]: *** Warte auf noch nicht beendete Prozesse...
make[2]: ***
[/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules/adv717x.o]
Fehler 1
make[1]: ***
[_module_/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/modules]
Fehler 2
make[1]: Leaving directory `/usr/src/linux-2.6.24-gentoo-r8'
make: *** [build] Fehler 2
*
* ERROR: media-video/em8300-modules-0.16.0-r1 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3195: Called die
* The specific snippet of code:
* emake KERNEL_LOCATION="${KERNEL_DIR}" || die "emake failed."
* The die message:
* emake failed.
*
* If you need support, post the topmost build error, and the call stack if
relevant.
* A complete build log is located
at '/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/temp/build.log'.
* The ebuild environment file is located
at '/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/temp/environment'.
*




Failed to emerge media-video/em8300-modules-0.16.0-r1, Log file:

'/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/temp/build.log'







* Messages for package media-video/em8300-modules-0.16.0-r1:

*
* ERROR: media-video/em8300-modules-0.16.0-r1 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3195: Called die
* The specific snippet of code:
* emake KERNEL_LOCATION="${KERNEL_DIR}" || die "emake failed."
* The die message:
* emake failed.
*
* If you need support, post the topmost build error, and the call stack if
relevant.
* A complete build log is located
at '/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/temp/build.log'.
* The ebuild environment file is located
at '/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/temp/environment'.
*
 

Lesen sie die antworten

#1 Sandy Marko Knauer
28/03/2009 - 18:40 | Warnen spam
Hi Thomas,

du kannst ja mal mit equery depends prüfen welches Paket diese Module als
Abhàngigkeit installieren möchte.

Alternativ kannst du auch ein emerge -uNDpt world starten (t = tree) somit
solltest du herausfinden können wer dieses Paket anfordert.

Ich könnte mir auch vorstellen, wenn du vdr einsetzt das gewisse USE-Flags
dieses Paket als Abhàngigkeit Installieren möchte.

Ich hoffe das dir diese Infos weiterhelfen

Gruß


Am Samstag 28 Màrz 2009 18:00:55 schrieb Thomas Bruns:
Hallo NG,

ich hab da nen Problem, bei mir bricht das folgende Paket immer ab:

media-video/em8300-modules-0.16.0-r1

mich würde aber mal interessieren, warum es installiert werden soll, ich
habe diese Karten gar nicht :-(

Kann da jemand helfen????

LG
THomas


emerge -uND world
Calculating dependencies... done!

>>> Verifying ebuild manifests
>>>
>>> Starting parallel fetch
>>>
>>> Emerging (1 of 3) media-video/em8300-modules-0.16.0-r1

* em8300-0.16.0.tar.gz RMD160 SHA1 SHA256 size ;-) ...
[ ok ]
* checking ebuild checksums ;-) ...
[ ok ]
* checking auxfile checksums ;-) ...
[ ok ]
* checking miscfile checksums ;-) ...
[ ok ]
* Determining the location of the kernel source code
* Found kernel source directory:
* /usr/src/linux
* Found kernel object directory:
* /lib/modules/2.6.24-gentoo-r8/build
* Found sources for kernel version:
* 2.6.24-gentoo-r8
* Checking for suitable kernel configuration options...
[ ok ]

>>> Unpacking source...
>>> Unpacking em8300-0.16.0.tar.gz

to /var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work
* Applying em8300-modules-0.16.0-i2c.patch ...
[ ok ]

>>> Source unpacked

in /var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work

>>> Compiling source

in
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules ... make -j2 KERNEL_LOCATION=/usr/src/linux
make -C /usr/src/linux
SUBDIRS=/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0
.16.0/modules modules
make[1]: Entering directory `/usr/src/linux-2.6.24-gentoo-r8'
CC
[M]
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules/adv717x.o CC
[M]
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules/bt865.o In file included
from
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules/encoder.h:4,

from
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules/bt865.c:55:
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules/../include/linux/em8300.h:269: Fehler: expected
specifier-qualifier-list before »snd_card_t«In file included from
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules/adv717x.c:50:
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules/../include/linux/em8300.h:269: Fehler: expected
specifier-qualifier-list before »snd_card_t«

/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules/bt865.c: In Funktion »bt865_setup«:
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules/bt865.c:879: Fehler: »struct em8300_s« hat kein Element namens
»card_nr«
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules/bt865.c:880: Fehler: »struct em8300_s« hat kein Element namens
»card_nr«
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules/adv717x.c: In Funktion »adv717x_setup«:
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules/adv717x.c:573: Fehler: »struct em8300_s« hat kein Element namens
»card_nr«
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules/adv717x.c:575: Fehler: »struct em8300_s« hat kein Element namens
»card_nr«
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules/adv717x.c:580: Fehler: »struct em8300_s« hat kein Element namens
»card_nr«
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules/adv717x.c:585: Fehler: »struct em8300_s« hat kein Element namens
»card_nr«
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules/adv717x.c:586: Fehler: »struct em8300_s« hat kein Element namens
»card_nr«
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules/adv717x.c:588: Fehler: »struct em8300_s« hat kein Element namens
»card_nr«
/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/mo
dules/adv717x.c:591: Fehler: »struct em8300_s« hat kein Element namens
»card_nr«
make[2]: ***
[/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/m
odules/bt865.o] Fehler 1
make[2]: *** Warte auf noch nicht beendete Prozesse...
make[2]: ***
[/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-0.16.0/m
odules/adv717x.o] Fehler 1
make[1]: ***
[_module_/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/work/em8300-
0.16.0/modules] Fehler 2
make[1]: Leaving directory `/usr/src/linux-2.6.24-gentoo-r8'
make: *** [build] Fehler 2
*
* ERROR: media-video/em8300-modules-0.16.0-r1 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3195: Called die
* The specific snippet of code:
* emake KERNEL_LOCATION="${KERNEL_DIR}" || die "emake failed."
* The die message:
* emake failed.
*
* If you need support, post the topmost build error, and the call stack if
relevant.
* A complete build log is located
at '/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/temp/build.log'.
* The ebuild environment file is located
at
'/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/temp/environment'. *

>>> Failed to emerge media-video/em8300-modules-0.16.0-r1, Log file:
>>>
>>> '/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/temp/build.log'

* Messages for package media-video/em8300-modules-0.16.0-r1:

*
* ERROR: media-video/em8300-modules-0.16.0-r1 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3195: Called die
* The specific snippet of code:
* emake KERNEL_LOCATION="${KERNEL_DIR}" || die "emake failed."
* The die message:
* emake failed.
*
* If you need support, post the topmost build error, and the call stack if
relevant.
* A complete build log is located
at '/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/temp/build.log'.
* The ebuild environment file is located
at
'/var/tmp/portage/media-video/em8300-modules-0.16.0-r1/temp/environment'. *

Ähnliche fragen