[gentoo-user-de] Nicht-existentes Paket blockiert

22/09/2008 - 01:20 von Roland Damm | Report spam
Moin,

wie soll man damit umgehen:


emerge -Dau world



[blocks B ] <app-crypt/qca-1.0-r3 (is blocking app-crypt/qca-2.0.0-r2)

Gut. Sodann ein

emerge -C app-crypt/qca



entfernt die Version 1.0-r3

Schön. Dann wieder:

emerge -Dau world



[blocks B ] <app-crypt/qca-1.0-r3 (is blocking app-crypt/qca-2.0.0-r2)

Also wie gehabt. Wie kann ein nicht mehr installiertes Paket ein anderes
blockieren?
Es wird noch besser:


emerge app-crypt/qca


Installiert fehlerfrei die Version 2.0.0-r2

Sodann wieder:


emerge -Dau world



[blocks B ] <app-crypt/qca-1.0-r3 (is blocking app-crypt/qca-2.0.0-r2)

Wie ist das zu verstehen?

CU Rollo
 

Lesen sie die antworten

#1 Ingo Sieverdingbeck
22/09/2008 - 01:30 | Warnen spam

N'Abend,

das Problem ist bei mir auf einigen Systemen, die kein ACCEPTS_KEYWORDS
gesetzt haben auch aufgetreten.
Die Lösung bei mir war =app-crypt/qca-1.0-r3 ~x86 in die
package.keywords einzutragen. Es gibt auch einen Gentoo-Bugreport dazu,
aus dem sich das ableiten là¤sst, aber ich finde den Link gerade nicht
wieder.

MfG Ingo

On Mon, 22 Sep 2008 01:16:02 +0200
Roland Damm wrote:

Moin,

wie soll man damit umgehen:

emerge -Dau world



[blocks B ] <app-crypt/qca-1.0-r3 (is blocking app-crypt/qca-2.0.0-r2)

Gut. Sodann ein
emerge -C app-crypt/qca



entfernt die Version 1.0-r3

Schön. Dann wieder:
emerge -Dau world



[blocks B ] <app-crypt/qca-1.0-r3 (is blocking app-crypt/qca-2.0.0-r2)

Also wie gehabt. Wie kann ein nicht mehr installiertes Paket ein anderes
blockieren?
Es wird noch besser:

emerge app-crypt/qca


Installiert fehlerfrei die Version 2.0.0-r2

Sodann wieder:

emerge -Dau world



[blocks B ] <app-crypt/qca-1.0-r3 (is blocking app-crypt/qca-2.0.0-r2)

Wie ist das zu verstehen?

CU Rollo




Ähnliche fragen