[gentoo-user-de] Probleme beim bauen verschiedener Pakete

18/05/2008 - 13:10 von Andreas Volz | Report spam
Hallo,

Bei mir bricht das bauen von gcc-3.4.6-r2 und libsoup-2.2.105-r2 ab.
Siehe z.B. gcc:

checking for memmove... yes
checking for memcpy... yes
checking for dlopen in -ldl... (cached) yes
checking for socket libraries... checking for connect... yes
checking for gethostbyname... yes

checking for deflate in -lz... yes
checking for pkg-config... /usr/bin/pkg-config
checking for GTK+ - version >= 2.2.0... yes (version 2.12.1)
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GLIB - version >= 2.2.0...
*** 'pkg-config --modversion glib-2.0' returned 2.14.6, but GLIB
(2.14.5) *** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the
error *** by modifying your LD_LIBRARY_PATH enviroment variable, or by
editing *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable
PKG_CONFIG_PATH *** to point to the correct configuration files
no
make[1]: *** [configure-target-libjava] Error 1
make[1]: Leaving directory
`/var/tmp/portage/sys-devel/gcc-3.4.6-r2/work/build' make: ***
[profiledbootstrap] Error 2 *
* ERROR: sys-devel/gcc-3.4.6-r2 failed.

Aber:


pkg-config --modversion glib-2.0


2.14.6

-rw-r--r-- 1 root root 1217358 17. Mai 20:01 /usr/lib/libglib-2.0.a
-rw-r--r-- 1 root root 823 17. Mai 20:01 /usr/lib/libglib-2.0.la
lrwxrwxrwx 1 root root 23 17. Mai 20:01 /usr/lib/libglib-2.0.so ->libglib-2.0.so.0.1400.6
lrwxrwxrwx 1 root root 23 17. Mai 20:01 /usr/lib/libglib-2.0.so.0 -> libglib-2.0.so.0.1400.6
-rwxr-xr-x 1 root root 858296 17. Mai 20:01 /usr/lib/libglib-2.0.so.0.1400.6

Das sieht doch gut aus, oder? Wo könnte das Problem sein? Ein ldconfig habe ich auch
schon ausgeführt.

PS: Mittlerweile bin ich nur noch gefrustet stàndig solche làcherlichen Probleme zu lösen.
Ich bin nicht mehr weit davon entfernt, wie auf meinem Laptop, auch auf diesem Rechner
Ubuntu einzusetzen. Schade eigentlich, ich fand das Gentoo Konzept gut. Aber über die
Jahre[1] findet in Gentoo einfach keine Evolution beim Lösen solcher Probleme statt. Manchmal
habe ich das Gefühl für meinen Rechner da zu sein und nicht umgekehrt. :-(

[1] Ich bin Gentoo Nutzer seit min. 6 Jahren.

Gruß
Andreas
gentoo-user-de@lists.gentoo.org mailing list
 

Lesen sie die antworten

#1 Hartmut Figge
18/05/2008 - 13:20 | Warnen spam
Andreas Volz:

pkg-config --modversion glib-2.0
2.14.6



Wie es im Log stand. Zusàtzlich stand da aber noch
| *** 'pkg-config --modversion glib-2.0' returned 2.14.6, but GLIB
| (2.14.5) *** was found!

Was sagt denn bei Dir 'emerge -pv glib'? Hier:
[ebuild R ] dev-libs/glib-2.14.6 USE="doc -debug -hardened" 0 kB

Hartmut

mailing list

Ähnliche fragen