[gentoo-user-de] Probleme mit emerge und geblockten Paketen

27/08/2015 - 23:50 von Christian Schoepplein | Report spam

Hallo zusammen,

seit letztem Wochenende làuft hier ein Gentoo und nach und nach versuche
ich die verschiedenen Tools, vor allem erstmal emerge, zu verstehen. Ich
habe die letzten Jahre nur Debian verwendet, daher sind einige Dinge neu
für mich bzw. erinnern sie mich stark an die Zeiten, wo wir im Job noch
FreeBSD eingesetzt haben.

Konkret habe ich geraqde folgendes Problem und komme damit absolut nicht
weiter:

srv ~ # emerge --update --deep --with-bdeps=y --newuse @system
Calculating dependencies... done!
[ebuild NS ] sys-libs/ncurses-5.9-r3 [5.9-r101] USE="cxx unicode
-ada -debug
)"
[ebuild U ] dev-libs/openssl-1.0.2d [1.0.1p] USE="asm%* -sctp%"
[blocks B ] <sys-libs/ncurses-6:0 ("<sys-libs/ncurses-6:0" is
blocking sys-

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-libs/ncurses-5.9-r3:0/0::gentoo, ebuild scheduled for merge)
pulled in by
sys-libs/ncurses:0= required by
(app-emulation/qemu-2.3.0-r5:0/0::gentoo, in
sys-libs/ncurses:0= required by (sys-apps/openrc-0.17:0/0::gentoo,
installed
sys-libs/ncurses:0= required by (dev-util/cmake-3.2.2:0/0::gentoo,
installed
sys-libs/ncurses:0= required by
(dev-scheme/guile-1.8.8-r1:12/12::gentoo, in

(sys-libs/ncurses-5.9-r101:5/5::gentoo, installed) pulled in by
sys-libs/ncurses:5/5= required by
(app-emulation/qemu-2.3.0-r5:0/0::gentoo,
sys-libs/ncurses required by @selected

=sys-libs/ncurses-5.2 required by


(dev-lang/python-2.7.9-r1:2.7/2.7::gentoo
sys-libs/ncurses required by (sys-devel/gettext-0.19.4:0/0::gentoo,
installe

=sys-libs/ncurses-5.2-r5 required by


(sys-boot/grub-2.02_beta2-r7:2/2::gent

=sys-libs/ncurses-5.9-r1[unicode?]


(>=sys-libs/ncurses-5.9-r1[unicode]) req
sys-libs/ncurses required by
(net-misc/telnet-bsd-1.2-r1:0/0::gentoo, instal

=sys-libs/ncurses-5.2 required by


(sys-devel/bc-1.06.95-r1:0/0::gentoo, ins

=sys-libs/ncurses-5.2-r2 required by


(sys-apps/util-linux-2.25.2-r2:0/0::ge

=sys-libs/ncurses-5.2 required by


(sys-kernel/gentoo-sources-4.0.5:4.0.5/4.
sys-libs/ncurses required by (app-admin/eselect-1.4.4:0/0::gentoo,
installed

=sys-libs/ncurses-5.2-r2 required by


(app-shells/bash-4.3_p39:0/0::gentoo,

=sys-libs/ncurses-5.2 required by (sys-apps/less-478:0/0::gentoo,


installed

=sys-libs/ncurses-5.2-r2 required by


(sys-apps/texinfo-5.2:0/0::gentoo, ins
sys-libs/ncurses required by
(app-emulation/libvirt-1.2.15-r1:0/1.2.15::gent

=sys-libs/ncurses-5.2 required by


(dev-lang/python-3.4.1:3.4/3.4::gentoo, i

=sys-libs/ncurses-5.2-r2 required by


(app-editors/vim-7.4.273:0/0::gentoo,

=sys-libs/ncurses-5.7-r7 required by


(sys-process/psmisc-22.21-r2:0/0::gent

=sys-libs/ncurses-5.7-r7[unicode?]


(>=sys-libs/ncurses-5.7-r7[unicode]) req


=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_


_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3[abi_x86_64(-)])
require
sys-libs/ncurses:5/5= required by (dev-util/cmake-3.2.2:0/0::gentoo,
install
sys-libs/ncurses:5/5= required by (sys-apps/openrc-0.17:0/0::gentoo,
install
sys-libs/ncurses:5/5= required by
(dev-scheme/guile-1.8.8-r1:12/12::gentoo,


For more information about Blocked Packages, please refer to the
following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

srv ~ #

bzw.:

srv ~ # emerge --update --deep --with-bdeps=y --newuse @world
Calculating dependencies... done!
[ebuild NS ] sys-libs/ncurses-5.9-r3 [5.9-r101] USE="cxx unicode
-ada -debug -doc -gpm -minimal -profile -static-libs -tinfo -trace"
ABI_X86="(64) -32 (-x32
)"
[ebuild U ] dev-libs/libnl-3.2.26 [3.2.25]
[ebuild U ] dev-libs/openssl-1.0.2d [1.0.1p] USE="asm%* -sctp%"
[ebuild U ] dev-perl/Net-SSLeay-1.650.0-r1 [1.650.0]
[ebuild U ] app-vim/gentoo-syntax-20150823 [20130619]
[blocks B ] <sys-libs/ncurses-6:0 ("<sys-libs/ncurses-6:0" is
blocking sys-libs/ncurses-5.9-r101)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-libs/ncurses-5.9-r3:0/0::gentoo, ebuild scheduled for merge)
pulled in by
sys-libs/ncurses:0= required by
(app-emulation/qemu-2.3.0-r5:0/0::gentoo, installed)
sys-libs/ncurses:0= required by (sys-apps/openrc-0.17:0/0::gentoo,
installed)
sys-libs/ncurses:0= required by (dev-util/cmake-3.2.2:0/0::gentoo,
installed)
sys-libs/ncurses:0= required by
(dev-scheme/guile-1.8.8-r1:12/12::gentoo, installed)

(sys-libs/ncurses-5.9-r101:5/5::gentoo, installed) pulled in by
sys-libs/ncurses:5/5= required by
(app-emulation/qemu-2.3.0-r5:0/0::gentoo, installed)
sys-libs/ncurses required by @selected

=sys-libs/ncurses-5.2 required by


(dev-lang/python-2.7.9-r1:2.7/2.7::gentoo, installed)
sys-libs/ncurses required by (sys-devel/gettext-0.19.4:0/0::gentoo,
installed)

=sys-libs/ncurses-5.7-r7 required by


(sys-process/psmisc-22.21-r2:0/0::gentoo, installed)
sys-libs/ncurses required by
(net-misc/telnet-bsd-1.2-r1:0/0::gentoo, installed)

=sys-libs/ncurses-5.2 required by


(sys-devel/bc-1.06.95-r1:0/0::gentoo, installed)

=sys-libs/ncurses-5.2-r2 required by


(sys-apps/util-linux-2.25.2-r2:0/0::gentoo, installed)

=sys-libs/ncurses-5.2 required by


(sys-kernel/gentoo-sources-4.0.5:4.0.5/4.0.5::gentoo, installed)
sys-libs/ncurses required by (app-admin/eselect-1.4.4:0/0::gentoo,
installed)

=sys-libs/ncurses-5.2-r2 required by


(app-shells/bash-4.3_p39:0/0::gentoo, installed)

=sys-libs/ncurses-5.2 required by (sys-apps/less-478:0/0::gentoo,


installed)

=sys-libs/ncurses-5.2-r2 required by


(sys-apps/texinfo-5.2:0/0::gentoo, installed)
sys-libs/ncurses required by
(app-emulation/libvirt-1.2.15-r1:0/1.2.15::gentoo, installed)

=sys-libs/ncurses-5.2 required by


(dev-lang/python-3.4.1:3.4/3.4::gentoo, installed)

=sys-libs/ncurses-5.2-r2 required by


(app-editors/vim-7.4.273:0/0::gentoo, installed)

=sys-libs/ncurses-5.2-r5 required by


(sys-boot/grub-2.02_beta2-r7:2/2::gentoo, installed)


=sys-libs/ncurses-5.9-r3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi


_s390_32(-)?,abi_s390_64(-)?] (>=sys-libs/ncurses-5.9-r3[abi_x86_64(-)])
required by (sys-libs/readline-6.3_p8-r2:0/0::gentoo, installed)

=sys-libs/ncurses-5.7-r7[unicode?]


(>=sys-libs/ncurses-5.7-r7[unicode]) required by
(sys-process/procps-3.3.9-r2:0/0::gentoo, installed)
sys-libs/ncurses:5/5= required by (dev-util/cmake-3.2.2:0/0::gentoo,
installed)
sys-libs/ncurses:5/5= required by (sys-apps/openrc-0.17:0/0::gentoo,
installed)
sys-libs/ncurses:5/5= required by
(dev-scheme/guile-1.8.8-r1:12/12::gentoo, installed)


For more information about Blocked Packages, please refer to the
following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

srv ~ #

Ich verstehe so viel, dass sich irgendwie zwei Versionen von
sys-libs/ncurses in die Quere kommen, aber obwohl ich mir die
angesprochene Wiki-Page angesehen habe, hilft mir das nicht wirklich
weiter.

Hat jemand einen Tipp, was hier zu tun ist?

Ciao und danke,

Christian




 

Lesen sie die antworten

#1 Marco Ziebell
28/08/2015 - 07:00 | Warnen spam
Morgen,

das Problem ist bekannt, siehe[1]. Du musst nochmal ein "emerge --sync"
durchführen. Wenn du das Paket ncurses-5.9-r99 siehst, kannst du das
update problemlos durchführen.

Es kann sein dass deine Quelle, von der syncs, das "etwas" spàter
kriegt. Könnte also etwas dauern.

Viel Erfolg




[1] https://bugs.gentoo.org/show_bug.cgi?idU8856

Ähnliche fragen