[gentoo-user-de] Probleme mit virtualbox-bin-4.1.22-r1 und udev-197 bei Host-Only-Networking

27/01/2013 - 10:50 von Matthias Hanft | Report spam
Hallo,

leider habe ich zwei Updates mehr oder weniger gleichzeitig ausgeführt
(virtualbox-bin von IIRC 4.1.22 auf 4.1.22-r1 und udev von 171 auf 197),
daher bin ich nicht sicher, woran's genau liegt:

Ich habe einen VirtualBox-Guest im Host-Only-Network-Modus laufen, d.h.
auf dem Host müßte sich nach "VBoxHeadless -s guest &" eigentlich ein
"vboxnet0"-Interface mit der IP-Adresse 192.168.56.1 aktivieren (ging
bisher auch).

Seit dem Update bleibt das "vboxnet0"-Interface (immerhin gibts eins)
aber "DOWN", und eine IP-Adresse kriegt's auch nicht. Folgendes muß
ich jetzt von Hand eingeben:

ip link set vboxnet0 up
ip addr add 192.168.56.1/24 dev vboxnet0

und dann geht wieder alles prima.

Hat jemand eine Idee, woran das liegen könnte? Es ist nicht allzu
tragisch, weil das "VBoxHeadless -s" eh in /etc/local.d/guest.start
steht und ich die zwei ip-Befehle dann halt auch noch direkt
dahinter schreiben kann (vielleicht nach einem "sleep 2", damit
das vboxnet0-Interface überhaupt schon existiert), aber netter
wàre es natürlich, wenns einfach so automagisch ginge wie vorher...

Danke & Gruß Matthias.
 

Lesen sie die antworten

#1 assabajanischer_hinterwaeldler
27/01/2013 - 12:10 | Warnen spam
hallo matthias,

ich bin mir nicht 100% sicher, aber wenn ich es richtig im kopf hab,
gibt es bei udev ein skript, dass fuer die erstellung der zustaendigen
regeln zustaendig ist. ein erneutes triggern koennte abhilfe schaffen.

ob dabei die vm gestartet sein muss oder nicht, weis ich leider nicht
auswendig. hoff das bringt etwas

gruss
martin


On Sun, Jan 27, 2013 at 10:40:01AM +0100, Matthias Hanft wrote:
Hallo,

leider habe ich zwei Updates mehr oder weniger gleichzeitig ausgeführt
(virtualbox-bin von IIRC 4.1.22 auf 4.1.22-r1 und udev von 171 auf 197),
daher bin ich nicht sicher, woran's genau liegt:

Ich habe einen VirtualBox-Guest im Host-Only-Network-Modus laufen, d.h.
auf dem Host müßte sich nach "VBoxHeadless -s guest &" eigentlich ein
"vboxnet0"-Interface mit der IP-Adresse 192.168.56.1 aktivieren (ging
bisher auch).

Seit dem Update bleibt das "vboxnet0"-Interface (immerhin gibts eins)
aber "DOWN", und eine IP-Adresse kriegt's auch nicht. Folgendes muß
ich jetzt von Hand eingeben:

ip link set vboxnet0 up
ip addr add 192.168.56.1/24 dev vboxnet0

und dann geht wieder alles prima.

Hat jemand eine Idee, woran das liegen könnte? Es ist nicht allzu
tragisch, weil das "VBoxHeadless -s" eh in /etc/local.d/guest.start
steht und ich die zwei ip-Befehle dann halt auch noch direkt
dahinter schreiben kann (vielleicht nach einem "sleep 2", damit
das vboxnet0-Interface überhaupt schon existiert), aber netter
wàre es natürlich, wenns einfach so automagisch ginge wie vorher...

Danke & Gruß Matthias.


Ähnliche fragen