[gentoo-user-de] reinstall/update cross-compiler

06/03/2012 - 22:00 von Michael Volland | Report spam
Hi,

emerge -avuDN world wollte bei mir den cross-compiler
cross-armv7a-unknown-linux-gnueabi/gcc
reinstallieren.

Compilieren klappt prima, nur die Installation wird verweigert, weil der
gcc meines Host-Systems überschrieben würde.

Jetzt habe ich vorerst mal die Pakete der Toolchain in
var/lib/portage/world auskommentiert.

Weiß jemand ob ich eine Umgebungsvariable o.à. vergessen habe, oder wird
ein cross-compiler grundsàtzlich mit crossdev upgedated, oder?

Gruß
Michael
 

Lesen sie die antworten

#1 Randy Andy
07/03/2012 - 10:20 | Warnen spam

Hallo Michael.

Am 6. Mà¤rz 2012 21:55 schrieb Michael Volland :

Hi,

emerge -avuDN world wollte bei mir den cross-compiler
cross-armv7a-unknown-linux-gnueabi/gcc
reinstallieren.

Compilieren klappt prima, nur die Installation wird verweigert, weil der
gcc meines Host-Systems à¼berschrieben wà¼rde.

Jetzt habe ich vorerst mal die Pakete der Toolchain in
var/lib/portage/world auskommentiert.

WeiàŸ jemand ob ich eine Umgebungsvariable o.à¤. vergessen habe, oder wird
ein cross-compiler grundsà¤tzlich mit crossdev upgedated, oder?

GruàŸ
Michael





Ich hatte seit dem 03.03.12 das gleiche Problem, nur mit dem cross-i686
compiler.
Es wurde aber bereits am 04.03. gefixed und stand schon am 05.03. im Tree
zur Verfà¼gung.
Dieser fix soll auch fà¼r cross-arm & - cross-mingw32 gelten. Bei mir ging's
jedenfalls.

Siehe auch diesen Bug-Report: https://bugs.gentoo.org/show_bug.cgi?id=406765
oder auch den zugehörigen Forums Post:
http://forums.gentoo.org/viewtopic-...cd95fc4024


Hast du danach mal wieder gesynched und es nochmal versucht?

Ansonsten ergà¤nze am besten den bug report.

GruàŸ, Andy.


Hallo Michael.<br><br><div class="gmail_quote">Am 6. Mà¤rz 2012 21:55 schrieb Michael Volland <span dir="ltr">&lt;<a href="mailto:"></a>&gt;</span>:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Hi,<br>
<br>
emerge -avuDN world wollte bei mir den cross-compiler<br>
cross-armv7a-unknown-linux-gnueabi/gcc<br>
reinstallieren.<br>
<br>
Compilieren klappt prima, nur die Installation wird verweigert, weil der<br>
gcc meines Host-Systems à¼berschrieben wà¼rde.<br>
<br>
Jetzt habe ich vorerst mal die Pakete der Toolchain in<br>
var/lib/portage/world auskommentiert.<br>
<br>
WeiàŸ jemand ob ich eine Umgebungsvariable o.à¤. vergessen habe, oder wird<br>
ein cross-compiler grundsà¤tzlich mit crossdev upgedated, oder?<br>
<br>
GruàŸ<br>
<span class="HOEnZb"><font color="#888888">Michael<br>
<br>
<br>
</font></span></blockquote></div><br>Ich hatte seit dem 03.03.12 das gleiche Problem, nur mit dem cross-i686 compiler.<br>Es wurde aber bereits am 04.03. gefixed und stand schon am 05.03. im Tree zur Verfà¼gung.<br>Dieser fix soll auch fà¼r cross-arm
&amp; - cross-mingw32 gelten. Bei mir ging&#39;s jedenfalls.<br><br>Siehe auch diesen Bug-Report: <a href="https://bugs.gentoo.org/show_bug.cg...;>https://bugs.gentoo.org/show_bug.cgi?id=406765</a><br>oder auch den zugehörigen Forums Post:<br>
<a href="http://forums.gentoo.org/viewtopic-...t;>http://forums.gentoo.org/viewtopic-t-915088-highlight-.html?sid=2bd1955d4c7fc0435313bbcd95fc4024</a><br><br><br>
Hast du danach mal wieder gesynched und es nochmal versucht?<br><br>Ansonsten ergà¤nze am besten den bug report.<br><br>GruàŸ, Andy.<br><br>

Ähnliche fragen