[gentoo-user-de] revdep-rebuild: VMWare-Tools gehören zu keinem Package

04/08/2012 - 17:40 von Matthias Hanft | Report spam
Hallo,

im Zuge eines Kernel-Updates auf einer Gentoo-Maschine, die ein VMWare-
Guest ist, habe ich auch mal wieder die vmware-tools geupdatet (also das
Package emerget, das iso mit loop eingebunden und ./INSTALL gemacht).
Ging auch (genauso gut wie bisher), nur im Gegensatz zu bisher mault
jetzt plötzlich revdep-rebuild:

schnipp

* !!! /usr/lib/vmware-tools/bin32/gksu not owned by any package is broken !!!
* /usr/lib/vmware-tools/bin32/gksu -> (none)
* !!! /usr/lib/vmware-tools/lib32/libconf/gtk-2.0/2.10.0/loaders/libpixbufloader-jpeg.so not
owned by any package is broken !!!
* /usr/lib/vmware-tools/lib32/libconf/gtk-2.0/2.10.0/loaders/libpixbufloader-jpeg.so -> (none)
* !!! /usr/lib/vmware-tools/lib32/libconf/gtk-2.0/2.10.0/loaders/libpixbufloader-tiff.so not
owned by any package is broken !!!
* /usr/lib/vmware-tools/lib32/libconf/gtk-2.0/2.10.0/loaders/libpixbufloader-tiff.so -> (none)
* !!! /usr/lib/vmware-tools/lib32/libconf/gtk-2.0/modules/libatk-bridge.so not owned by any
package is broken !!!
* /usr/lib/vmware-tools/lib32/libconf/gtk-2.0/modules/libatk-bridge.so -> (none)
* !!! /usr/lib/vmware-tools/lib32/libgksu2.so.0/libgksu2.so.0 not owned by any package is broken !!!
* /usr/lib/vmware-tools/lib32/libgksu2.so.0/libgksu2.so.0 -> (none)
* !!! /usr/lib/vmware-tools/lib32/libspi.so.0/libspi.so.0 not owned by any package is broken !!!
* /usr/lib/vmware-tools/lib32/libspi.so.0/libspi.so.0 -> (none)
* !!! /usr/lib/vmware-tools/lib32/libvmware-toolbox.so/libvmware-toolbox.so not owned by any
package is broken !!!
* /usr/lib/vmware-tools/lib32/libvmware-toolbox.so/libvmware-toolbox.so -> (none)
* !!! /usr/lib/vmware-tools/plugins32/vmusr/libdesktopEvents.so not owned by any package is
broken !!!
* /usr/lib/vmware-tools/plugins32/vmusr/libdesktopEvents.so -> (none)
* !!! /usr/lib/vmware-tools/plugins32/vmusr/libdndcp.so not owned by any package is broken !!!
* /usr/lib/vmware-tools/plugins32/vmusr/libdndcp.so -> (none)
* !!! /usr/lib/vmware-tools/plugins32/vmusr/libresolutionSet.so not owned by any package is
broken !!!
* /usr/lib/vmware-tools/plugins32/vmusr/libresolutionSet.so -> (none)
* !!! /usr/lib/vmware-tools/plugins32/vmusr/libunity.so not owned by any package is broken !!!
* /usr/lib/vmware-tools/plugins32/vmusr/libunity.so -> (none)

schnapp

Das meiste davon hört sich ziemlich nach graphischen Oberflàchen/Desktops o.à.
an (und wird von den VMWare-Tools wohl "vorsichtshalber" installiert), aber
davon hab ich auf der Maschine natürlich RGN (Rein Gar Nix). Nachdem ich keine
Lust habe, irgendwelche nutzlosen graphischen Pakete zu installieren, nur damit
diese Fehlermeldungen verschwinden: Kann man da nicht irgendwie ein Ignore-Flag
setzen? Oder wie kriegt man das sonst (ohne hàßliche Seiteneffekte) weg?

Danke & Gruß Matthias.
 

Lesen sie die antworten

#1 Sandy Marko Knauer
04/08/2012 - 18:30 | Warnen spam
Am Samstag, den 04.08.2012, 17:30 +0200 schrieb Matthias Hanft:
Hallo,

im Zuge eines Kernel-Updates auf einer Gentoo-Maschine, die ein VMWare-
Guest ist, habe ich auch mal wieder die vmware-tools geupdatet (also das
Package emerget, das iso mit loop eingebunden und ./INSTALL gemacht).
Ging auch (genauso gut wie bisher), nur im Gegensatz zu bisher mault
jetzt plötzlich revdep-rebuild:

schnipp

* !!! /usr/lib/vmware-tools/bin32/gksu not owned by any package is broken !!!
* /usr/lib/vmware-tools/bin32/gksu -> (none)
* !!! /usr/lib/vmware-tools/lib32/libconf/gtk-2.0/2.10.0/loaders/libpixbufloader-jpeg.so not
owned by any package is broken !!!
* /usr/lib/vmware-tools/lib32/libconf/gtk-2.0/2.10.0/loaders/libpixbufloader-jpeg.so -> (none)
* !!! /usr/lib/vmware-tools/lib32/libconf/gtk-2.0/2.10.0/loaders/libpixbufloader-tiff.so not
owned by any package is broken !!!
* /usr/lib/vmware-tools/lib32/libconf/gtk-2.0/2.10.0/loaders/libpixbufloader-tiff.so -> (none)
* !!! /usr/lib/vmware-tools/lib32/libconf/gtk-2.0/modules/libatk-bridge.so not owned by any
package is broken !!!
* /usr/lib/vmware-tools/lib32/libconf/gtk-2.0/modules/libatk-bridge.so -> (none)
* !!! /usr/lib/vmware-tools/lib32/libgksu2.so.0/libgksu2.so.0 not owned by any package is broken !!!
* /usr/lib/vmware-tools/lib32/libgksu2.so.0/libgksu2.so.0 -> (none)
* !!! /usr/lib/vmware-tools/lib32/libspi.so.0/libspi.so.0 not owned by any package is broken !!!
* /usr/lib/vmware-tools/lib32/libspi.so.0/libspi.so.0 -> (none)
* !!! /usr/lib/vmware-tools/lib32/libvmware-toolbox.so/libvmware-toolbox.so not owned by any
package is broken !!!
* /usr/lib/vmware-tools/lib32/libvmware-toolbox.so/libvmware-toolbox.so -> (none)
* !!! /usr/lib/vmware-tools/plugins32/vmusr/libdesktopEvents.so not owned by any package is
broken !!!
* /usr/lib/vmware-tools/plugins32/vmusr/libdesktopEvents.so -> (none)
* !!! /usr/lib/vmware-tools/plugins32/vmusr/libdndcp.so not owned by any package is broken !!!
* /usr/lib/vmware-tools/plugins32/vmusr/libdndcp.so -> (none)
* !!! /usr/lib/vmware-tools/plugins32/vmusr/libresolutionSet.so not owned by any package is
broken !!!
* /usr/lib/vmware-tools/plugins32/vmusr/libresolutionSet.so -> (none)
* !!! /usr/lib/vmware-tools/plugins32/vmusr/libunity.so not owned by any package is broken !!!
* /usr/lib/vmware-tools/plugins32/vmusr/libunity.so -> (none)

schnapp

Das meiste davon hört sich ziemlich nach graphischen Oberflàchen/Desktops o.à.
an (und wird von den VMWare-Tools wohl "vorsichtshalber" installiert), aber
davon hab ich auf der Maschine natürlich RGN (Rein Gar Nix). Nachdem ich keine
Lust habe, irgendwelche nutzlosen graphischen Pakete zu installieren, nur damit
diese Fehlermeldungen verschwinden: Kann man da nicht irgendwie ein Ignore-Flag
setzen? Oder wie kriegt man das sonst (ohne hàßliche Seiteneffekte) weg?

Danke & Gruß Matthias.




Hallo Matthias,

ignore Library kann man mit der Variable
LD_LIBRARY_MASK setzten. Ich hab es aber noch nie verwendet.

Sandy

Ähnliche fragen