Forums Neueste Beiträge
 

[gentoo-user-de] Staendiges Up/Down der NIC

26/03/2012 - 19:40 von Holger Posny | Report spam
Hallo,

ich habe ein Problem mit meiner NIC. Kurz zur Umgebung: Das System ist
direkt am ISP-Modem angeschlossen, also kein Proxy, keine Firewall o.
ae. Es handelt sich um die NIC "Atheros AR8151" (ASUS K37SV), die mit
dem Modul "atl1c" laeuft.

Nachdem ich nun den Kernel und den NIC-Treiber statisch (ein)kompiliert
habe, geht es mit der NIC auf und ab. Soll heissen, sie wird staendig
hoch- und wieder runtergefahren.

# dmesg
[...]
[ 24.294962] atl1c 0000:04:00.0: atl1c: eth0 NIC Link is Down
[ 25.923322] atl1c 0000:04:00.0: atl1c: eth0 NIC Link is Up<100 Mbps
Ful Duplex>
[ 26.715962] atl1c 0000:04:00.0: atl1c: eth0 NIC Link is Down

Das macht sich natuerlich dann auch beim Beziehen der IP per DHCP wie
folgt bemerkbar:

# dpchpd -n -t 10 eth0
dhcpcd[2414]: version 5.2.12 starting
dhcpcd[2414]: eth0: waiting for carrier
dhcpcd[2414]: eth0: carrier acquired
dhcpcd[2414]: eth0: broadcasting for a lease
dhcpcd[2414]: eth0: carrier lost
dhcpcd[2414]: eth0: carrier acquired
[...]

Auch ein Neustart der NIC (# ifconfig eth0 down && ifconfig eth0 up)
brachte kein Erfolg. Ich habe den Verdacht, dass es an der
Kernel-Konfiguration liegt - aber wo genau?

Parallel zur Erstinstallation habe ich mir auch den generischen Kernel
kompiliert. Hier kann ich das Modul nicht laden. So wie es aussieht,
werden wohl beim generischen Kernel die "EXPERIMENTAL" Optionen
deaktiviert!? - Und genau das ist das Modul "atl1c".

Waere schoen, wenn ich das irgendwie loesen koennte, damit ich endlich
von den "grossen" Distributionen wegkomme.

Holger
 

Lesen sie die antworten

#1 Stefan Nowy
26/03/2012 - 21:10 | Warnen spam
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)

Hallo!

On 26.03.2012 19:30, Holger Posny wrote:
# dmesg
[...]
[ 24.294962] atl1c 0000:04:00.0: atl1c: eth0 NIC Link is Down
[ 25.923322] atl1c 0000:04:00.0: atl1c: eth0 NIC Link is Up<100 Mbps
Ful Duplex>
[ 26.715962] atl1c 0000:04:00.0: atl1c: eth0 NIC Link is Down



andere Möglichkeit: das Modem ist defekt!
das hatte ich bei einem Kunden und dessen ISP schon mehrmals.
(Workaround war teils möglich, in dem man die Geschwindigkeit manuell
auf 10MBit gesetzt hat)


HTH
Stefan




Ähnliche fragen