[gentoo-user-de] UDEV soll Geraete by force neu suchen und einrichten

16/01/2009 - 04:20 von Support | Report spam
# uname -ar
Linux primary_2007 2.6.27-gentoo-r6_2008-12-17 #2 SMP Wed Dec 17 22:59:44
CET 2008 x86_64 Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz GenuineIntel
GNU/Linux

# emerge -p udev
[ebuild R ] sys-fs/udev-135-r3


Nabend ^^,

sagt bitte, ist es moeglich UDEV manuell anzuweisen, nach neuen Geraeten
zu suchen und auch gleich die passenden Geraete-Nodes (ggf. neu) zu
erstellen?

Der konkrete Fall:
Ich nutze einen IPod Classic 160 und habe bei der Initialladung einmal
alle "wichtigen" Songs und Alben auf den Pod geladen. Nun kommt es ab
und an vor, dass der Player den Akku aufgeladen haben moechte. Dies
geschieht bei diesem Geraet ueber den USB-Anschluss. Das nutze ich
natuerlich auch, um den neusten Schwung Musik auf den Player zu laden.


Nun gehe ich wiefolgt vor:

1) IPod per USB mit dem PC verbinden --> Der Player zeigt an, dass er
verbunden ist und ich jetzt ueber itunes lecker Werbung downloaden darf
(denkste :D)
2) mounten von (meistens ist es) /dev/sdc1 --> df zeigt sdc1 als
gemountet an
3) Starten von gtkpod (yep gnome) und Einlesen des Pods
4) ich lade Songs auf den Player, update Termine etc
5) Zum Abschluss speichert gtkpod die noch nicht geschriebenen Daten zum
Pod --> danach gtkpod schliessen
6) umount /dev/sdc1 --> df zeigt, dass sdc1 nicht mehr gemountet ist;
Der Pod ist der Meinung, dass er noch angeschlossen ist.
7) eject /dev/sdc1 --> Pod zeigt an, dass die Verbindung jetzt getrennt
werden kann --> /dev/sdc1 verschwindet aus /dev

Soweit so gut.. ich lasse den Playerakku weiter laden.. dann muss ich
einen neuen Termin oder einen tollen Song auf den Player laden, waehrend
der Akku noch laed. Leider ist /dev/sdc1 aber nach der letzten Benutzung
verschwunden und ich kann die Partition des Players nicht mehr
"anfassen", sprich mounten. /dev/sdc ist aber noch da! --> Ein cfdisk
/dev/sdc zeigt auch brav /dev/sdc1 an.. jedoch gibts sdc1 nicht mehr in /dev

Nun koennte man freilich einfach das USB-Kabel abziehen und wieder
anstecken. UDEV wuerde das Geraet einrichten... jedoch waere dann der
Ladezyklus des Akkus unterbrochen, was fuer diesen freilich nicht gerate
zutraeglich ist.
erstellen, quasi JETZT nach neuen Geraeten suchen, waere das die
Loesung. Kennt da jemand einen Trick?
Habe allerlei FAQs gelesen und das Web durchstoebert, aber dazu habe ich
nichts gefunden. :(

Vielen Dank schonmal im Voraus!
Cif
 

Lesen sie die antworten

#1 Bernd Wurst
16/01/2009 - 07:00 | Warnen spam

Hallo Support.

(Ist Support nicht normal der, der die Antworten liefert?)


Am Freitag, 16. Januar 2009 schrieb Support:
sagt bitte, ist es moeglich UDEV manuell anzuweisen, nach neuen Geraeten
zu suchen und auch gleich die passenden Geraete-Nodes (ggf. neu) zu
erstellen?



udevadm trigger

GruàŸ, Bernd

Wer meint, seine Methode gefunden zu habenm mag in sich gehen und
grà¼ndlich nachforschen, ob nicht ein Teil des Gehirns
eingeschlafen ist. - Hanry Ford (am. Industrieller, 1863-1947)



Ähnliche fragen