[gentoo-user-de] Waiting for IPv6 addresses ...

18/11/2011 - 18:00 von Matthias Hanft | Report spam
Hallo,

ich lerne gerade fleißig, wie IPv6 funktioniert, und bringe soweit auch alles
ganz gut zum Laufen, allerdings gibts noch einen Effekt, den ich gern ver-
stehen würde:

/etc/conf.d/net:

config_eth0="213.95.70.228/28
2001:780:125:1::e4/64"

routes_eth0="default via 213.95.70.225
default via 2001:780:125:1::1"

/var/log/rc.log:

* Starting syslog-ng ...
[ ok ]
* Loading iptables state and starting firewall ...
[ ok ]
* Bringing up interface eth0
* 213.95.70.228/28 ...
[ ok ]
* 2001:780:125:1::e4/64 ...
[ ok ]
* Adding routes
* default via 213.95.70.225 ...
[ ok ]
* default via 2001:780:125:1::1 ...
[ ok ]
* Waiting for IPv6 addresses ...
[ ok ]
* Starting named ...
* Checking named configuration ...
[ ok ]

ip addr show eth0:

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1378 qdisc pfifo_fast state UP qlen 1000
link/ether 00:50:56:83:00:46 brd ff:ff:ff:ff:ff:ff
inet 213.95.70.228/28 brd 213.95.70.239 scope global eth0
inet6 2001:780:125:1:250:56ff:fe83:46/64 scope global dynamic
valid_lft 2591966sec preferred_lft 604766sec
inet6 2001:780:125:1::e4/64 scope global
valid_lft forever preferred_lft forever
inet6 fe80::250:56ff:fe83:46/64 scope link
valid_lft forever preferred_lft forever

So. Die interne fe80-Adresse mit hinten ...46 kommt wohl einfach aus
der MAC-Adresse und wird automatisch gebildet. So weit, so gut. Aaaaber:

- Warum wird beim Booten auf IPv6 addresses "gewartet"? Ich habe
nirgendwo (wissentlich) DHCP konfiguriert.
- Warum wird aus meinem Prefix und der MAC-Adresse eine weitere
("dynamic") IPv6-Adresse konstruiert? Ich will die nicht :-)
- Warum ist die 30 Tage gültig und 7 Tage preferred? Wo kommt
das her?
- Wenn ich sie mit "ip addr del" lösche, ist sie nach kurzer Zeit
wieder da. Hartnàckiges Biest :-)

Was sind das für Mechanismen?

Danke & Gruß Matthias.
 

Lesen sie die antworten

#1 Jan Kohnert
18/11/2011 - 19:30 | Warnen spam

Matthias Hanft schrieb:
/etc/conf.d/net:

config_eth0="213.95.70.228/28
2001:780:125:1::e4/64"



Solch eine Konfig hatte ich auch mal. AFAIK ist das keine gültige IPv6-
Adresse, sondern ein Subnetzwerk. Das kann also nicht funktionieren. (Man
korrigiere mich bitte, falls ich mich falsch erinnere...)

MfG Jan



Ähnliche fragen