[gentoo-user-de] wieder zurÃŒck aber ohne de

23/12/2015 - 23:40 von Sebastian | Report spam
Hallo,

nach vielen Jahren habe ich es geschafft wieder ein lauffàhiges Gentoo zu
haben.
Leider schaffe ich es nicht die Lokalisierung richtig hinzubekommen neben
anderen Kleinigkeiten dazu aber spàter.

Mir fehlt an fielen stellen eine deutsche Lokalisierung der Programme obwohl
ich nach der Anleitung:
https://wiki.gentoo.org/wiki/Handbook:AMD64/Portage/Tools/de
vorgegangen bin. Da diese aber nicht vollstàndig übersetzt ist könnte ich da
auch etwas verkehrt verstanden haben. Auch das ich es mit meinen versuchen
noch schlimmer gemacht habe kann ich nicht ausschließen.
Zudem fehlt mir das at auf dem Q.

Folgende Ausgabe kann ich schon mal als Anhaltspunkt mitgeben. Wo ich genau
suchen muss weiß ich aber nicht.

l1-gentoo sebastian # eselect locale list
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or
directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or
directory
Available targets for the LANG variable:
[1] C
[2] POSIX
[3] de_DE
[4] de_DE.iso88591
[5] de_DE.iso885915@euro
[6] de_DE@euro
[7] deutsch
[8] en_US
[9] en_US.iso88591
[10] en_US.utf8
[11] german
[12] de_DE.utf8@euro *
[ ] (free form)
l1-gentoo sebastian # locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=de_DE.utf8@euro
LC_CTYPE="de_DE.utf8@euro"
LC_NUMERIC="de_DE.utf8@euro"
LC_TIME="de_DE.utf8@euro"
LC_COLLATE=C
LC_MONETARY="de_DE.utf8@euro"
LC_MESSAGES="de_DE.utf8@euro"
LC_PAPER="de_DE.utf8@euro"
LC_NAME="de_DE.utf8@euro"
LC_ADDRESS="de_DE.utf8@euro"
LC_TELEPHONE="de_DE.utf8@euro"
LC_MEASUREMENT="de_DE.utf8@euro"
LC_IDENTIFICATION="de_DE.utf8@euro"
LC_ALLl1-gentoo sebastian #

/usr/bin/locale gibt es ist soll ich die 300 Zeilen auch mal mitsenden?
Ansonsten ist das System gestern Abend mit avuND world aktualisiert worden. es
gab ein paar Abhàngigkeiten welche gelöst werden mussten beim dazu
installieren verschiedener Programme diese wurden aber vorgeschlagen und in
die Configdateien eingetragen.
Ich verwende default/linux/amd64/13.0/desktop mit KDE 4...

Gruß
Sebastian
 

Lesen sie die antworten

#1 René Neumaier
24/12/2015 - 00:40 | Warnen spam

On Wednesday 23 December 2015 23:39:36 Sebastian wrote:
nach vielen Jahren habe ich es geschafft wieder ein lauffàhiges Gentoo zu
haben.


Na dann herzlichen Glückwunsch und willkommen zurück! :-)


Leider schaffe ich es nicht die Lokalisierung richtig hinzubekommen neben
anderen Kleinigkeiten dazu aber spàter.

Mir fehlt an fielen stellen eine deutsche Lokalisierung der Programme
obwohl ich nach der Anleitung:
https://wiki.gentoo.org/wiki/Handbook:AMD64/Portage/Tools/de
vorgegangen bin.


Hm? Falscher Link? Was hast du bereits gesetzt?
Wirklich nichts übersehen?
https://wiki.gentoo.org/wiki/Handbook:AMD64/Installation/Base/de#Konfiguration_der_Locale

Im Prinzip:
-/etc/locale.gen zurecht kommentieren
-locale-gen abfeuern
-mittels eselect nach belieben setzen
-variablen/profil auffrischen
-variable LINGUAS in der make.conf setzen/kontrollieren
https://wiki.gentoo.org/wiki/Locali...de#LINGUAS
-emerge -auvDN @world


Zudem fehlt mir das at auf dem Q.


Keymap richtig gesetzt? OpenRC oder systemd?

https://wiki.gentoo.org/wiki/Locali...he_console
https://wiki.gentoo.org/wiki/Xorg/G...figurieren
Der letzter Link ist für dein X wichtig.


Der Vollstàndigkeit halber:
Hast du aus einer anderen Linux-Installation eine modifizierte .bashrc oder
àhnliches übernommen?


LG,
René

___________________________
GPG-Fingerprint:
2DC2 9D47 5A72 4C0C 801D B65F BDCA F831 85DF 9ADB


Ähnliche fragen