[gentoo-user-de] X-Server macht nur noch 60Hz

18/07/2009 - 23:30 von Magnus Rosenbaum | Report spam
Hallo Leute,

seit ich vor einiger Zeit den X-Server auf einem meiner Rechner
aktualisiert habe, làuft dieser nur noch mit 60 Hz Bildwiederholfrequenz.
An dem Rechner hàngen 2 Röhrenmonitore.

Ich habe versucht, in xorg.conf eine Modeline vorzugeben, aber dann stürzt
der X-Server gleich beim Starten ab:

8<

(II) Loading /usr/lib64/xorg/modules/linux//libfglrxdrm.so
(II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
compiled for 1.4.99.906, module version = 8.55.2
ABI class: X.Org Server Extension, version 1.1
(II) fglrx(0): Using adapter: 1:0.0.
(II) fglrx(0): [FB] MC range(MCFBBase = 0xc0000000, MCFBSize = 0x10000000)
(--) fglrx(0): Video RAM: 262144 kByte, Type: DDR SGRAM / SDRAM
(II) fglrx(0): PCIE card detected
(II) fglrx(0): board/chipset is supported by this driver (original ATI board)
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Module "ddc" already built-in
(II) fglrx(0): ***Display: ConnectedDisplayTypes=0x00000011,
disabled=0x00000000
(II) fglrx(0): Connected Display1: CRT on primary DAC [crt1]
(II) fglrx(0): Display1 EDID data
(II) fglrx(0): Manufacturer: SNY Model: 390 Serial#: 16843009
(II) fglrx(0): Year: 2000 Week: 21
(II) fglrx(0): EDID Version: 1.2
(II) fglrx(0): Analog Display Input, Input Voltage Level: 0.700/0.300 V
(II) fglrx(0): Sync: Separate Composite SyncOnGreen
(II) fglrx(0): Max Image Size [cm]: horiz.: 37 vert.: 27
(II) fglrx(0): Gamma: 2.50
(II) fglrx(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
(II) fglrx(0): First detailed timing is preferred mode
(II) fglrx(0): GTF timings supported
(II) fglrx(0): redX: 0.625 redY: 0.340 greenX: 0.280 greenY: 0.605
(II) fglrx(0): blueX: 0.155 blueY: 0.070 whiteX: 0.283 whiteY: 0.298
(II) fglrx(0): Supported VESA Video Modes:
(II) fglrx(0): 720x400@70Hz
(II) fglrx(0): 720x400@88Hz
(II) fglrx(0): 640x480@60Hz
(II) fglrx(0): 640x480@67Hz
(II) fglrx(0): 640x480@72Hz
(II) fglrx(0): 640x480@75Hz
(II) fglrx(0): 800x600@56Hz
(II) fglrx(0): 800x600@60Hz
(II) fglrx(0): 800x600@72Hz
(II) fglrx(0): 800x600@75Hz
(II) fglrx(0): 832x624@75Hz
(II) fglrx(0): 1024x768@87Hz (interlaced)
(II) fglrx(0): 1024x768@60Hz
(II) fglrx(0): 1024x768@70Hz
(II) fglrx(0): 1024x768@75Hz
(II) fglrx(0): 1280x1024@75Hz
(II) fglrx(0): 1152x870@75Hz
(II) fglrx(0): Manufacturer's mask: 0
(II) fglrx(0): Supported Future Video Modes:
(II) fglrx(0): #0: hsize: 1800 vsize 1440 refresh: 60 vid: 32962
(II) fglrx(0): #1: hsize: 1600 vsize 1200 refresh: 75 vid: 20393
(II) fglrx(0): #2: hsize: 1280 vsize 960 refresh: 85 vid: 22913
(II) fglrx(0): #3: hsize: 1280 vsize 960 refresh: 75 vid: 20353
(II) fglrx(0): #4: hsize: 1152 vsize 864 refresh: 85 vid: 22897
(II) fglrx(0): #5: hsize: 1024 vsize 768 refresh: 85 vid: 22881
(II) fglrx(0): #6: hsize: 800 vsize 600 refresh: 85 vid: 22853
(II) fglrx(0): #7: hsize: 640 vsize 480 refresh: 85 vid: 22833
(II) fglrx(0): Supported additional Video Mode:
(II) fglrx(0): clock: 157.5 MHz Image Size: 352 x 264 mm
(II) fglrx(0): h_active: 1280 h_sync: 1344 h_sync_end 1504 h_blank_end
1728 h_border: 0
(II) fglrx(0): v_active: 1024 v_sync: 1025 v_sync_end 1028 v_blanking:
1072 v_border: 0
(II) fglrx(0): Ranges: V min: 48 V max: 120 Hz, H min: 30 H max: 96 kHz,
PixClock max 300 MHz
(II) fglrx(0): Monitor name: CPD-E400E
(II) fglrx(0): Serial No: 6028977
(II) fglrx(0): EDID (in hex):
(II) fglrx(0): 00ffffffffffff004dd9900301010101
(II) fglrx(0): 150a01020e251b96eb0cc9a057479b27
(II) fglrx(0): 12484cffff80c280a94f8159814f7159
(II) fglrx(0): 615945593159863d00c05100304040a0
(II) fglrx(0): 130060081100001e000000fd0030781e
(II) fglrx(0): 601e000a202020202020000000fc0043
(II) fglrx(0): 50442d45343030450a202020000000ff
(II) fglrx(0): 00363032383937370a2020202020004e
(II) fglrx(0): End of Display1 EDID data --
(II) fglrx(0): Connected Display2: CRT on secondary DAC [crt2]
(II) fglrx(0): Display2: No EDID information from DDC.
(EE) fglrx(0): Unknown EDID version 0
(II) fglrx(0): Display2: Failed to get EDID information.
(II) fglrx(0): Primary Controller - CRT on primary DAC
(II) fglrx(0): Secondary Controller - CRT on secondary DAC
(II) fglrx(0): Internal Desktop Setting: 0x00000001
(II) fglrx(0): POWERplay version 3. 1 power state available:
(II) fglrx(0): 1. 398/203MHz @ 50Hz [enable load balancing]

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x26) [0x4e7e36]
1: /usr/bin/X(xf86SigHandler+0x39) [0x490799]
2: /lib/libc.so.6 [0x7f9b82b41290]

Fatal server error:
Caught signal 11. Server aborting

8<

Hier die xorg.conf:

8<

Section "ServerLayout"
Identifier "Simple Layout"
Screen 0 "ScreenLeft" 0 0
Screen 1 "ScreenRight" RightOf "ScreenLeft"
Option "Xinerama" "on"
InputDevice "Mouse" "CorePointer"
InputDevice "Keyboard" "CoreKeyboard"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
Option "Xinerama" "true"
EndSection

Section "Module"
Load "glx"
Load "dri"
Load "dbe" # Double buffer extension
SubSection "extmod"
# don't initialise the DGA extension
Option "omit xfree86-dga"
EndSubSection
Load "freetype"
EndSection

Section "Files"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/75dpi/"
FontPath "/usr/local/share/fonts/"
EndSection

Section "InputDevice"
Identifier "Keyboard"
Driver "kbd"
Option "AutoRepeat" "500 30"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
Identifier "Mouse"
Driver "mouse"
Option "Protocol" "Auto" # Auto detect
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "SONY"
ModelName "CPD-E400E"
DisplaySize 365 275
HorizSync 30.0 - 96.0
VertRefresh 48.0 - 120.0
Option "DPMS" "true"
UseModes "Modes"
EndSection

Section "Monitor"
Identifier "Monitor2"
VendorName "SONY"
ModelName "CPD-E400E"
DisplaySize 365 275
HorizSync 30.0 - 96.0
VertRefresh 48.0 - 120.0
Option "DPMS" "true"
UseModes "Modes"
EndSection

Section "Modes"
Identifier "Modes"
ModeLine "1280x960" 165.88 1280 1336 1616 1728 960 962 974
1000 # 96Hz
EndSection

Section "Device"
Identifier "ATI Technologies Inc RV380 [Radeon X600 (PCIE)] VGA"
Driver "fglrx"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"
Identifier "ATI Technologies Inc RV380 [Radeon X600 (PCIE)] DVI"
Driver "fglrx"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "ScreenLeft"
Device "ATI Technologies Inc RV380 [Radeon X600 (PCIE)] VGA"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 8
Modes "1280x960" "1152x864" "1024x768" "800x600"
"768x576" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x960" "1152x864" "1024x768" "800x600"
"768x576" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x960" "1152x864" "1024x768" "800x600"
"768x576" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 32
Modes "1280x960" "1152x864" "1024x768" "800x600"
"768x576" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "ScreenRight"
Device "ATI Technologies Inc RV380 [Radeon X600 (PCIE)] DVI"
Monitor "Monitor2"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 8
Modes "1280x960" "1152x864" "1024x768" "800x600"
"768x576" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x960" "1152x864" "1024x768" "800x600"
"768x576" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x960" "1152x864" "1024x768" "800x600"
"768x576" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 32
Modes "1280x960" "1152x864" "1024x768" "800x600"
"768x576" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

8<

Hat jemand ne Idee, was da los sein könnte?

Ciao, Magnus

Carl Magnus Rosenbaum M.A.
Administration - Programmierung - Weiterbildung http://cmr.cx/
Tel: +49 89 70066626 Fax: +49 89 70066686 Mobil: +49 163 1737001
PGP Fingerprint: DEBC 3C99 EF1D 74F0 D4C7 EFF5 C268 3690 0EA1 7641
 

Lesen sie die antworten

#1 Oliver Rath
19/07/2009 - 00:00 | Warnen spam
Warum setzt Du das vertRefresh nicht einfach hoch? Alternativ - wenn Du
kde nutzt - kannst Du die Wiederholfrequenz in der Systemsteuerung
einstellen.

Ansonsten nimm den xorg-server-1.6.x, der braucht keine xorg.conf mehr
und sucht sich die besten Parameter normalerweise selber.

HTH

Oliver



Magnus Rosenbaum schrieb:
Hallo Leute,

seit ich vor einiger Zeit den X-Server auf einem meiner Rechner
aktualisiert habe, làuft dieser nur noch mit 60 Hz Bildwiederholfrequenz.
An dem Rechner hàngen 2 Röhrenmonitore.

Ich habe versucht, in xorg.conf eine Modeline vorzugeben, aber dann stürzt
der X-Server gleich beim Starten ab:

8<

(II) Loading /usr/lib64/xorg/modules/linux//libfglrxdrm.so
(II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
compiled for 1.4.99.906, module version = 8.55.2
ABI class: X.Org Server Extension, version 1.1
(II) fglrx(0): Using adapter: 1:0.0.
(II) fglrx(0): [FB] MC range(MCFBBase = 0xc0000000, MCFBSize = 0x10000000)
(--) fglrx(0): Video RAM: 262144 kByte, Type: DDR SGRAM / SDRAM
(II) fglrx(0): PCIE card detected
(II) fglrx(0): board/chipset is supported by this driver (original ATI board)
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Module "ddc" already built-in
(II) fglrx(0): ***Display: ConnectedDisplayTypes=0x00000011,
disabled=0x00000000
(II) fglrx(0): Connected Display1: CRT on primary DAC [crt1]
(II) fglrx(0): Display1 EDID data
(II) fglrx(0): Manufacturer: SNY Model: 390 Serial#: 16843009
(II) fglrx(0): Year: 2000 Week: 21
(II) fglrx(0): EDID Version: 1.2
(II) fglrx(0): Analog Display Input, Input Voltage Level: 0.700/0.300 V
(II) fglrx(0): Sync: Separate Composite SyncOnGreen
(II) fglrx(0): Max Image Size [cm]: horiz.: 37 vert.: 27
(II) fglrx(0): Gamma: 2.50
(II) fglrx(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
(II) fglrx(0): First detailed timing is preferred mode
(II) fglrx(0): GTF timings supported
(II) fglrx(0): redX: 0.625 redY: 0.340 greenX: 0.280 greenY: 0.605
(II) fglrx(0): blueX: 0.155 blueY: 0.070 whiteX: 0.283 whiteY: 0.298
(II) fglrx(0): Supported VESA Video Modes:
(II) fglrx(0):
(II) fglrx(0):
(II) fglrx(0):
(II) fglrx(0):
(II) fglrx(0):
(II) fglrx(0):
(II) fglrx(0):
(II) fglrx(0):
(II) fglrx(0):
(II) fglrx(0):
(II) fglrx(0):
(II) fglrx(0): (interlaced)
(II) fglrx(0):
(II) fglrx(0):
(II) fglrx(0):
(II) fglrx(0):
(II) fglrx(0):
(II) fglrx(0): Manufacturer's mask: 0
(II) fglrx(0): Supported Future Video Modes:
(II) fglrx(0): #0: hsize: 1800 vsize 1440 refresh: 60 vid: 32962
(II) fglrx(0): #1: hsize: 1600 vsize 1200 refresh: 75 vid: 20393
(II) fglrx(0): #2: hsize: 1280 vsize 960 refresh: 85 vid: 22913
(II) fglrx(0): #3: hsize: 1280 vsize 960 refresh: 75 vid: 20353
(II) fglrx(0): #4: hsize: 1152 vsize 864 refresh: 85 vid: 22897
(II) fglrx(0): #5: hsize: 1024 vsize 768 refresh: 85 vid: 22881
(II) fglrx(0): #6: hsize: 800 vsize 600 refresh: 85 vid: 22853
(II) fglrx(0): #7: hsize: 640 vsize 480 refresh: 85 vid: 22833
(II) fglrx(0): Supported additional Video Mode:
(II) fglrx(0): clock: 157.5 MHz Image Size: 352 x 264 mm
(II) fglrx(0): h_active: 1280 h_sync: 1344 h_sync_end 1504 h_blank_end
1728 h_border: 0
(II) fglrx(0): v_active: 1024 v_sync: 1025 v_sync_end 1028 v_blanking:
1072 v_border: 0
(II) fglrx(0): Ranges: V min: 48 V max: 120 Hz, H min: 30 H max: 96 kHz,
PixClock max 300 MHz
(II) fglrx(0): Monitor name: CPD-E400E
(II) fglrx(0): Serial No: 6028977
(II) fglrx(0): EDID (in hex):
(II) fglrx(0): 00ffffffffffff004dd9900301010101
(II) fglrx(0): 150a01020e251b96eb0cc9a057479b27
(II) fglrx(0): 12484cffff80c280a94f8159814f7159
(II) fglrx(0): 615945593159863d00c05100304040a0
(II) fglrx(0): 130060081100001e000000fd0030781e
(II) fglrx(0): 601e000a202020202020000000fc0043
(II) fglrx(0): 50442d45343030450a202020000000ff
(II) fglrx(0): 00363032383937370a2020202020004e
(II) fglrx(0): End of Display1 EDID data --
(II) fglrx(0): Connected Display2: CRT on secondary DAC [crt2]
(II) fglrx(0): Display2: No EDID information from DDC.
(EE) fglrx(0): Unknown EDID version 0
(II) fglrx(0): Display2: Failed to get EDID information.
(II) fglrx(0): Primary Controller - CRT on primary DAC
(II) fglrx(0): Secondary Controller - CRT on secondary DAC
(II) fglrx(0): Internal Desktop Setting: 0x00000001
(II) fglrx(0): POWERplay version 3. 1 power state available:
(II) fglrx(0): 1. 398/203MHz @ 50Hz [enable load balancing]

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x26) [0x4e7e36]
1: /usr/bin/X(xf86SigHandler+0x39) [0x490799]
2: /lib/libc.so.6 [0x7f9b82b41290]

Fatal server error:
Caught signal 11. Server aborting

8<

Hier die xorg.conf:

8<

Section "ServerLayout"
Identifier "Simple Layout"
Screen 0 "ScreenLeft" 0 0
Screen 1 "ScreenRight" RightOf "ScreenLeft"
Option "Xinerama" "on"
InputDevice "Mouse" "CorePointer"
InputDevice "Keyboard" "CoreKeyboard"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
Option "Xinerama" "true"
EndSection

Section "Module"
Load "glx"
Load "dri"
Load "dbe" # Double buffer extension
SubSection "extmod"
# don't initialise the DGA extension
Option "omit xfree86-dga"
EndSubSection
Load "freetype"
EndSection

Section "Files"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/100dpi/"
FontPath "/usr/share/fonts/75dpi/"
FontPath "/usr/local/share/fonts/"
EndSection

Section "InputDevice"
Identifier "Keyboard"
Driver "kbd"
Option "AutoRepeat" "500 30"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
Identifier "Mouse"
Driver "mouse"
Option "Protocol" "Auto" # Auto detect
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "SONY"
ModelName "CPD-E400E"
DisplaySize 365 275
HorizSync 30.0 - 96.0
VertRefresh 48.0 - 120.0
Option "DPMS" "true"
UseModes "Modes"
EndSection

Section "Monitor"
Identifier "Monitor2"
VendorName "SONY"
ModelName "CPD-E400E"
DisplaySize 365 275
HorizSync 30.0 - 96.0
VertRefresh 48.0 - 120.0
Option "DPMS" "true"
UseModes "Modes"
EndSection

Section "Modes"
Identifier "Modes"
ModeLine "1280x960" 165.88 1280 1336 1616 1728 960 962 974
1000 # 96Hz
EndSection

Section "Device"
Identifier "ATI Technologies Inc RV380 [Radeon X600 (PCIE)] VGA"
Driver "fglrx"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"
Identifier "ATI Technologies Inc RV380 [Radeon X600 (PCIE)] DVI"
Driver "fglrx"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "ScreenLeft"
Device "ATI Technologies Inc RV380 [Radeon X600 (PCIE)] VGA"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 8
Modes "1280x960" "1152x864" "1024x768" "800x600"
"768x576" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x960" "1152x864" "1024x768" "800x600"
"768x576" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x960" "1152x864" "1024x768" "800x600"
"768x576" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 32
Modes "1280x960" "1152x864" "1024x768" "800x600"
"768x576" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "ScreenRight"
Device "ATI Technologies Inc RV380 [Radeon X600 (PCIE)] DVI"
Monitor "Monitor2"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 8
Modes "1280x960" "1152x864" "1024x768" "800x600"
"768x576" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x960" "1152x864" "1024x768" "800x600"
"768x576" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x960" "1152x864" "1024x768" "800x600"
"768x576" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 32
Modes "1280x960" "1152x864" "1024x768" "800x600"
"768x576" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

8<

Hat jemand ne Idee, was da los sein könnte?

Ciao, Magnus


Ähnliche fragen