Forums Neueste Beiträge
 

GNU tar --wildcards

02/07/2008 - 09:51 von Thomas Guettler | Report spam
Hallo,

seit einem Systemupdate will tar die Option --wildcards, damit
man einzelne Dateien mittels Wildcards extrahieren kann.

Vorher ging das auch ohne die Option. Aus meiner Sicht ist
das eine sinnlose Änderung, die nicht abwàrtskompatibel ist.

Leider habe ich Scripte, die mit der alten und mit der neuen
tar-Version arbeiten müssen.

Wie könnte man am besten herausbekommen ob die Option --wildcards
übergeben werden muss oder nicht?

Ich habe nun folgende Lösung:

if $(tar --help | grep -q -- --wildcard) ; then TAR_WILD="--wildcards"; else TAR_WILD=""; fi

Schön ist das nicht, aber da muss man wohl durch ...

Gruß,
Thomas


Thomas Guettler, http://www.thomas-guettler.de/
E-Mail: guettli (*) thomas-guettler + de
 

Lesen sie die antworten

#1 Cyrus Kriticos
02/07/2008 - 10:07 | Warnen spam
Thomas Guettler wrote:

seit einem Systemupdate will tar die Option --wildcards, damit
man einzelne Dateien mittels Wildcards extrahieren kann.



Unter welchem Unix mit welchem tar ist das denn so?

Vorher ging das auch ohne die Option. Aus meiner Sicht ist
das eine sinnlose Änderung, die nicht abwàrtskompatibel ist.



Best regards | Monica Lewinsky's X-Boyfriend's
Cyrus | Wife for President

Ähnliche fragen