Gnumeric/Ubuntu/Python Installationsproblem

29/01/2008 - 21:52 von Thomas Preymesser | Report spam
Hallo,

ich wollte (u.a.) gnumeric installieren und stoße dabei auf die
folgende Fehlermeldung, aus der ich nicht so ganz schlau werde:

Richte gnumeric ein (1.7.11-1ubuntu3) ...
Traceback (most recent call last):
File "/usr/sbin/gconf-schemas", line 8, in <module>
import sys,os,os.path,shutil,tempfile
File "/usr/lib/python2.5/tempfile.py", line 33, in <module>
from random import Random as _Random
File "/usr/lib/python2.5/random.py", line 43, in <module>
from math import log as _log, exp as _exp, pi as _pi, e as _e,
ceil as _ceil
ImportError: No module named math
dpkg: Fehler beim Bearbeiten von gnumeric (--configure):
Unterprozess post-installation script gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
gnumeric
E: Sub-process /usr/bin/dpkg returned an error code (1)

was muß ich da machen, damit es klappt? Ich habe leider mit Python
keine so große Erfahrung mehr - ich will nur, daß gnumeric installiert
werden kann.

Gnumeric làßt sich trotz dieses Fehler aber starten - kann ich obigen
Fehler ignorieren, oder kann es trotzdem noch zu Problemen mit der
Anwendung kommen?



-Thomas
 

Lesen sie die antworten

#1 Peter Otten
30/01/2008 - 09:38 | Warnen spam
Thomas Preymesser wrote:

ich wollte (u.a.) gnumeric installieren und stoße dabei auf die
folgende Fehlermeldung, aus der ich nicht so ganz schlau werde:

Richte gnumeric ein (1.7.11-1ubuntu3) ...
Traceback (most recent call last):
File "/usr/sbin/gconf-schemas", line 8, in <module>
import sys,os,os.path,shutil,tempfile
File "/usr/lib/python2.5/tempfile.py", line 33, in <module>
from random import Random as _Random
File "/usr/lib/python2.5/random.py", line 43, in <module>
from math import log as _log, exp as _exp, pi as _pi, e as _e,
ceil as _ceil
ImportError: No module named math
dpkg: Fehler beim Bearbeiten von gnumeric (--configure):
Unterprozess post-installation script gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
gnumeric
E: Sub-process /usr/bin/dpkg returned an error code (1)

was muß ich da machen, damit es klappt? Ich habe leider mit Python
keine so große Erfahrung mehr - ich will nur, daß gnumeric installiert
werden kann.

Gnumeric làßt sich trotz dieses Fehler aber starten - kann ich obigen
Fehler ignorieren, oder kann es trotzdem noch zu Problemen mit der
Anwendung kommen?



Ich habe Gnumeric gerade mal zur Probe installiert, allerdings unter Kubuntu
für AMD64, aber das sollte eigentlich keinen Unterschied machen. Bei mir
tritt das Problem nicht auf, auch das Python-Plugin làsst sich problemlos
aktivieren.

Da es sich bei dem kaputten Python bei Dir offenbar um das von der
Distribution mitgelieferte handelt, vermute ich, dass Deine Installation in
einem inkonsistenten Zustand ist und Du àhnliche Probleme von jetzt an
öfter siehst.

Wie ein Linux-Profi sowas behandelt weiß ich nicht; ich tendiere in solchen
Fàllen zur Neuinstallation...

Peter

Ähnliche fragen