Googleearth unter Sid

23/11/2013 - 12:50 von Klaus Becker | Report spam
Moin,

unter Sid habe ich googleeart-package installiert, dann "dpkg -i ./googleearth...".

Hat soweit geklappt, aber wenn ich googleearth starten will, sagt er:

/usr/lib/googleearth/googleearth-bin: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or director

libGL.so.1 taucht in der Beschreibung folgender Pakete auf:
libgl1-mesa-swx11-dbg libgl1-mesa-swx11-dbg:i386 libgl1-mesa-swx11 libgl1-mesa-swx11:i386 libgl1-mesa-swx11-i686:i386, die sich aber nicht installieren lassen, auch nicht einzeln.

Auf http://packages.debian.org/search?s...p;arch=any fàllt die Wahl schwer.

Ich habe:

$ dpkg -l | grep -i libgl
ii libgl1-fglrx-glx:am 1:13.11~betav1 amd64 proprietary libGL for the non-free ATI/AMD
ii libgl1-mesa-dev 9.2.2-1 amd64 free implementation of the OpenGL API -- GL
rc libgl1-mesa-dri:amd 9.1.7-1 amd64 free implementation of the OpenGL API -- DR
ii libgl1-mesa-dri:i38 9.2.2-1 i386 free implementation of the OpenGL API -- DR
ii libgl1-mesa-glx:amd 9.2.2-1 amd64 free implementation of the OpenGL API -- GL
ii libgl1-mesa-glx:i38 9.2.2-1 i386 free implementation of the OpenGL API -- GL
ii libglade2-0 1:2.6.4-1 amd64 library to load .glade files at runtime
ii libglapi-mesa:amd64 9.2.2-1 amd64 free implementation of the GL API -- shared
ii libglapi-mesa:i386 9.2.2-1 i386 free implementation of the GL API -- shared
ii libgle3 3.1.0-7 amd64 OpenGL tubing and extrusion library
ii libgles2-mesa:amd64 9.2.2-1 amd64 free implementation of the OpenGL|ES 2.x AP
ii libglew1.10:amd64 1.10.0-3 amd64 OpenGL Extension Wrangler - runtime environ
rc libglew1.7:amd64 1.7.0-3 amd64 OpenGL Extension Wrangler - runtime environ
ii libglib-perl 3:1.302-1 amd64 interface to the GLib and GObject libraries
ii libglib2.0-0:amd64 2.36.4-1 amd64 GLib library of C routines
ii libglib2.0-0:i386 2.36.4-1 i386 GLib library of C routines
ii libglib2.0-bin 2.36.4-1 amd64 Programs for the GLib library
ii libglib2.0-data 2.36.4-1 all Common files for GLib library
ii libglibmm-2.4-1c2a: 2.36.2-1 amd64 C++ wrapper for the GLib toolkit (shared li
ii libglu1-mesa:amd64 9.0.0-2 amd64 Mesa OpenGL utility library (GLU)
ii libglu1-mesa:i386 9.0.0-2 i386 Mesa OpenGL utility library (GLU)
ii libglu1-mesa-dev 9.0.0-2 amd64 Mesa OpenGL utility library -- development

# apt-get -f install ergibt nichts.

Weiss jemand, wie man googleearth unter Sid installiert?

Gruss

Klaus



Zum AUSTRAGEN schicken Sie eine Mail an debian-user-german-REQUEST@lists.debian.org
mit dem Subject "unsubscribe". Probleme? Mail an listmaster@lists.debian.org (engl)
Archive: http://lists.debian.org/1654600.yK104ZA9NV@1stein
 

Lesen sie die antworten

#1 Klaus Becker
23/11/2013 - 13:50 | Warnen spam
Le samedi 23 novembre 2013, 12:49:10 Klaus Becker a écrit :
Moin,

unter Sid habe ich googleeart-package installiert, dann "dpkg -i ./googleearth...".

Hat soweit geklappt, aber wenn ich googleearth starten will, sagt er:

/usr/lib/googleearth/googleearth-bin: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or director

libGL.so.1 taucht in der Beschreibung folgender Pakete auf:
libgl1-mesa-swx11-dbg libgl1-mesa-swx11-dbg:i386 libgl1-mesa-swx11 libgl1-mesa-swx11:i386 libgl1-mesa-swx11-i686:i386, die sich aber nicht installieren lassen, auch nicht einzeln.

Auf http://packages.debian.org/search?s...p;arch=any fàllt die Wahl schwer.

Ich habe:

$ dpkg -l | grep -i libgl
ii libgl1-fglrx-glx:am 1:13.11~betav1 amd64 proprietary libGL for the non-free ATI/AMD
ii libgl1-mesa-dev 9.2.2-1 amd64 free implementation of the OpenGL API -- GL
rc libgl1-mesa-dri:amd 9.1.7-1 amd64 free implementation of the OpenGL API -- DR
ii libgl1-mesa-dri:i38 9.2.2-1 i386 free implementation of the OpenGL API -- DR
ii libgl1-mesa-glx:amd 9.2.2-1 amd64 free implementation of the OpenGL API -- GL
ii libgl1-mesa-glx:i38 9.2.2-1 i386 free implementation of the OpenGL API -- GL
ii libglade2-0 1:2.6.4-1 amd64 library to load .glade files at runtime
ii libglapi-mesa:amd64 9.2.2-1 amd64 free implementation of the GL API -- shared
ii libglapi-mesa:i386 9.2.2-1 i386 free implementation of the GL API -- shared
ii libgle3 3.1.0-7 amd64 OpenGL tubing and extrusion library
ii libgles2-mesa:amd64 9.2.2-1 amd64 free implementation of the OpenGL|ES 2.x AP
ii libglew1.10:amd64 1.10.0-3 amd64 OpenGL Extension Wrangler - runtime environ
rc libglew1.7:amd64 1.7.0-3 amd64 OpenGL Extension Wrangler - runtime environ
ii libglib-perl 3:1.302-1 amd64 interface to the GLib and GObject libraries
ii libglib2.0-0:amd64 2.36.4-1 amd64 GLib library of C routines
ii libglib2.0-0:i386 2.36.4-1 i386 GLib library of C routines
ii libglib2.0-bin 2.36.4-1 amd64 Programs for the GLib library
ii libglib2.0-data 2.36.4-1 all Common files for GLib library
ii libglibmm-2.4-1c2a: 2.36.2-1 amd64 C++ wrapper for the GLib toolkit (shared li
ii libglu1-mesa:amd64 9.0.0-2 amd64 Mesa OpenGL utility library (GLU)
ii libglu1-mesa:i386 9.0.0-2 i386 Mesa OpenGL utility library (GLU)
ii libglu1-mesa-dev 9.0.0-2 amd64 Mesa OpenGL utility library -- development

# apt-get -f install ergibt nichts.

Weiss jemand, wie man googleearth unter Sid installiert?

Gruss

Klaus



Ich habe gerade festgestellt:

$ locate libGL.so.1
/etc/alternatives/glx--libGL.so.1-x86_64-linux-gnu
/opt/usr/X11R6/lib64/libGL.so.1
/opt/usr/X11R6/lib64/libGL.so.1.2
/opt/usr/X11R6/lib/libGL.so.1.2
/usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1
/usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1.2.0
/usr/lib/mesa-diverted/x86_64-linux-gnu/libGL.so.1
/usr/lib/mesa-diverted/x86_64-linux-gnu/libGL.so.1.2.0
/usr/lib/x86_64-linux-gnu/fglrx/fglrx-libGL.so.1.2
/usr/lib/x86_64-linux-gnu/fglrx/libGL.so.1
/usr/lib/x86_64-linux-gnu/libGL.so.1

Ich habe versucht: # ln -s /usr/lib/i386-linux-gnu/libGL.so.1 /usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1, aber dann crasht das Programm.

Ist meine Idee richtig oder muss ich einen anderen Link erzeugen?

Klaus


Zum AUSTRAGEN schicken Sie eine Mail an
mit dem Subject "unsubscribe". Probleme? Mail an (engl)
Archive: http://lists.debian.org/

Ähnliche fragen