gpg Fehler unter X

24/02/2008 - 13:13 von Frank Albrecht II | Report spam
Hallo,

erstmal: Die Schlüssel sind in Ordnung, denn (zum Glück) kann
ich in der Textkonsole (Alt-F1) die datei entschlüsseln.

$ gpg (-t) -d web.txt.gpg
/
can't connect to `/tmp/gpg-4tR8yV/S.gpg-agent': Datei oder \
Verzeichnis nicht gefunden
gpg: Verbindung zum gpg-agent nicht möglich - Ersatzmethode \
wird versucht
\

Das macht erstmal nichts, das werde ich spàter untersuchen.

/
can�t lock memory: Cannot allocate memory
Warning: using insecure memory!

** ERROR **: could not grab keyboard
aborting...
gpg-agent[14417]: command get_passphrase failed: Dateiende
gpg: Problem mit dem Agenten: IPC Schreibfehler
gpg: Ungültige Passphrase; versuchen Sie es bitte noch einmal
/

Versucht habe ich, gpg suid root zu setzen, weiters mit strace
geschaut, keine Hinweise. Keine Meldungen in den logfiles.

Die Versionen, die mit gpg zusammenhàngen, sind allesamt
Auslieferungzustand. Kein apparmor oder selinux.

Linux f1 2.6.24-8-default #1 SMP 2008/02/08 10:55:16 UTC i686
athlon i386 GNU/Linux

Bei einer zweiten SuSE 10.3 tritt das Problem auch auf.
Frontends wie gpa oder kgpg zeigen alle dasselbe Verhalten.

Ergooglen konnte ich nichts. Ich habe kürzlich von SuSE 10.2
auf 10.3 gewechselt. Unter 10.2 trat das Problem nicht auf.

Hat irgend jemand eine Idee, was da schieflàuft und wie man
das wieder hinbiegt?

Frank Albrecht II
(im Usenet ist ein Namensvetter untewegs, deshalb die "II")
 

Lesen sie die antworten

#1 Frank Albrecht II
27/02/2008 - 14:21 | Warnen spam
Frank Albrecht II wrote:

erstmal: Die Schlüssel sind in Ordnung, denn (zum Glück) kann
ich in der Textkonsole (Alt-F1) die datei entschlüsseln.

$ gpg (-t) -d web.txt.gpg



[...]
/
can�t lock memory: Cannot allocate memory
Warning: using insecure memory!

** ERROR **: could not grab keyboard
aborting...
gpg-agent[14417]: command get_passphrase failed: Dateiende
gpg: Problem mit dem Agenten: IPC Schreibfehler
gpg: Ungültige Passphrase; versuchen Sie es bitte noch einmal
/



[...]
Bei einer zweiten SuSE 10.3 tritt das Problem auch auf.
Frontends wie gpa oder kgpg zeigen alle dasselbe Verhalten.



Interessiert vermutlich keinen, trotzdem fürs Archiv: unter
fluxbox funktioniert pinentry-gtk2 nicht korrekt. Ich habe
/usr/bin/pinentry dahingehend abgeàndert, dass ein anderes
frontend (pinentry-qt oder pinentry-ncurses funktionieren
beide).

Dass ich SuSE im Verdacht hatte und überhaupt hier gepostet
habe, lag daran, dass die gleiche Konstellation unter Ubuntu
funktioniert. Dort sind die gpg-Pakete allerdings auch
komplett anders geschnürt.

Frank Albrecht II
(im Usenet ist ein Namensvetter untewegs, deshalb die "II")

Ähnliche fragen