Großbuchstaben finden?

11/10/2009 - 22:40 von MaKrue | Report spam
Ich habe folgendes Problem: In einer Spalte einer sehr langen Excel-
Tabelle sind mehrere Namen hintereinander durch Semikolon getrennt.
Nachname und Vorname sind durch Komma getrennt. Die Vornamen bestehen
nur aus dem ersten Buchstaben. Das könnte dann so aussehen:

Spalte A
Müller, A; Meier, B; Schulze, C
Schmidt, DX; Krüger, EXY; Mustermann, F

Meine Aufgabe besteht nun darin hinter die Großbuchstaben der Vornamen
einen Punkt zu setzen.

Spalte A
Müller, A.; Meier, B.; Schulze, C.
Schmidt, D.X.; Krüger, E.X.Y.; Mustermann, F.


Bisher habe ich mit der Funktion Suchen und Ersetzen einge Punkte
einfügen können. Allerdings gelingt mir das nicht für Namen mit
mehreren Vornamen.
Welche Lösungsansàtze gibt es hierzu?

Freue mich wie immer über Antworten.
Vielen Dank im voraus,
Mandy K.
 

Lesen sie die antworten

#1 Klaus \Perry\ Pago
11/10/2009 - 23:49 | Warnen spam
Hallo Mandy,

"MaKrue" schrieb im Newsbeitrag
news:
Ich habe folgendes Problem: In einer Spalte einer sehr langen Excel-
Tabelle sind mehrere Namen hintereinander durch Semikolon getrennt.
Nachname und Vorname sind durch Komma getrennt. Die Vornamen bestehen
nur aus dem ersten Buchstaben. Das könnte dann so aussehen:

Spalte A
Müller, A; Meier, B; Schulze, C
Schmidt, DX; Krüger, EXY; Mustermann, F

Meine Aufgabe besteht nun darin hinter die Großbuchstaben der Vornamen
einen Punkt zu setzen.

Spalte A
Müller, A.; Meier, B.; Schulze, C.
Schmidt, D.X.; Krüger, E.X.Y.; Mustermann, F.



Hier mal "quick&dirty" ein Verfahren für Vornamen mit nur einem Buchstaben:

mittels Menuepunkt Daten => Text in Spalten => getrennt => Semikolon
fügt Excel jeden Namen in eine eigene Spalte

Da vermutkich nicht alle Zellen nur drei Namen enthalten
muss man jetzt die làngste Zeile plus zwei Leerspalten
ermitteln und dann folgende Formel eintragen:

zB für F1:
=WENN(A1="";"";WENN(B1="";A1&".";A1&".; "))
und nach Bedarf nach rechts kopieren.

Dann werden die einzelnen Spalten wieder zusammengebaut
zB in K1:
ñ&G1&H1&I1&J1

Mit "Kopieren" und "Einfügen Werte" kann man alles wieder nach Spalte A
transportieren

Gruß
Klaus

Ähnliche fragen