Grub: merkwürdiges Verhalten

19/08/2008 - 11:59 von Hubert Gabler | Report spam
Hallo,

vielleicht können mir die Experten hier eine Erklàrung liefern.
Ich habe auf meiner Festplatte Debian Lenny (als Arbeitsprogramm),
Debian Sid und Fedora 9 installiert. Einige weitere Partitionen benütze
ich zum Ausprobieren von verschiedenen Distributionen, die mich gerade
interessieren.

Bei der Installation solcher Neulinge kommt es manchmal vor - sei es
durch meine Unachtsamkeit oder weil's nicht anders geht - dass sich die
Distribution im MBR einnistet und beim Neustart nur diese neue
Installation in der menu.lst aufscheint.

In den meisten Fàllen kann ich mir helfen, indem ich mir Zugriff auf die
Lenny-Partition verschaffe (mount /dev/sda2 /bootdaten) und mit
grub-install --root-directory=/bootdaten /dev/sda ist dann der alte
Zustand wieder hergestellt.

Bei manchen Testkandidaten aber funkt das nicht, zuletzt bei Suse11. Das
bewàhrte Rezept grub-install lieferte die Meldung:
"/bootdaten/boot/grub/stage1 not read correctly". Auch wenn ich die
Boot-Daten von Sid nehme (/dev/sda3) kommt dieselbe Fehlermeldung.

Durch Zufall habe ich einen Umweg gefunden: wenn ich Fedora 9 als Boot-
kandidat nehme dann geht das grub-install. Ich bin den Testkandidaten
los und kann Fedora booten. Und jetzt kommts: von Fedora heraus làsst
sich ohne jede Fehlermeldung das Lenny-Grub installieren und alles ist
wieder wie es sein soll.

Ich würde mich freuen, wenn mir jemand eine Erklàrung für dieses
seltsame Verhalten geben könnte.

MfG,
Hubert
 

Lesen sie die antworten

#1 Wolfgang Steiner
20/08/2008 - 12:05 | Warnen spam
Hubert Gabler schrieb:

Bei manchen Testkandidaten aber funkt das nicht, zuletzt bei Suse11. Das
bewàhrte Rezept grub-install lieferte die Meldung:
"/bootdaten/boot/grub/stage1 not read correctly". Auch wenn ich die
Boot-Daten von Sid nehme (/dev/sda3) kommt dieselbe Fehlermeldung.



[...]

Ich würde mich freuen, wenn mir jemand eine Erklàrung für dieses
seltsame Verhalten geben könnte.



Erklàrung kann ich zwar keine liefern, aber für Lenny/Sid das Problem
bestàtigen. Bei mir ging das so weit, dass sich grub nicht einmal auf
Diskette installieren ließ. Aus den Fehlermeldungen war nur ersichtlich
dass grub versuchte, sich unter /target/ (wo Lenny wàhrend der
Installation das filesystem mounted) zu installieren, was fehlschlug.
Aber nach abklemmen des zweiten Festplatte ging's wieder...


Grüße,
Wolfgang


Auch der Zufall ist nicht unergründlich - er hat seine Regelmàßigkeit.
(Novalis, Fragmente)

Ähnliche fragen