grub Probleme beim Aufsetzen eines Systemes aus vorhandenen Archiven

28/02/2010 - 15:03 von Robert Berghaus | Report spam
Hallo

Ich habe ein System mit Debian etchnhalf auf einem relativ
leistungsschwachen PC (GEODE Prozessor).
Die Partitionierung ist folgendermaßen:
hda1 -> eingehàngt als Wurzelverzeichnis, ca. 10GB
hda2 -> erweiterte Partition
hda5 -> Swap Partition
hda6 -> Rest der Platte, eingehàngt als /home

Hda1 und 6 sind mit ext3 formatiert.
Grub (0.9) ist im MBR installiert.

Von diesem System habe ich mir tar Archive gezogen, eines für / und
eines für /home; außerdem 466 Bytes vom MBR mittels dd gesichert.

Dieser PC wurde dann in einen Schaltschrank eingebaut und làuft seitdem.

Jetzt sollte ich einen weiteren PC genauso aufbauen.
Dafür habe ich die Partitionen eingerichtet und formatiert,
anschließend die Archive zurückgespielt und den MBR wieder mit dd
aus der Datei geschrieben.

Am Bildschirm erscheint ein fortlaufendes "GRUB ".
Alle meine bisherigen Versuche, grub zu reparieren, waren bisher
erfolglos.

War der Ansatz, die Sicherung mit tar durchzuführen schon falsch?
Kann das System noch repariert werden, oder muß ich komplett neu
aufsetzen?

Für jede hilfreiche Antwort bin ich dankbar.

Robert
 

Lesen sie die antworten

#1 Christian Zietz
28/02/2010 - 15:41 | Warnen spam
Robert Berghaus schrieb:

Jetzt sollte ich einen weiteren PC genauso aufbauen.
Dafür habe ich die Partitionen eingerichtet und formatiert,
anschließend die Archive zurückgespielt und den MBR wieder mit dd
aus der Datei geschrieben.



Wimre legt grub auch Daten in dem Bereich zwischen dem MBR und der
ersten Partition ab. Die musst Du auch wiederherstellen, andernfalls
sollte eine Neuinstallation von grub das Problem beheben.

Christian
Christian Zietz - CHZ-Soft - czietz (at) gmx.net
WWW: http://www.chzsoft.de/
PGP/GnuPG-Key-ID: 0x6DA025CA

Ähnliche fragen