GRUB unter 10.0

13/09/2007 - 18:50 von Juergen F. Pennings | Report spam
Liebe Wissende,
vor ein paar Wochen habe ich mir ein altes Notebook TARGA Traveller 800
gekauft. 333 MHz, leider nicht mehr als 160 MB Speicher möglich, die FP
habe ich inzwischen auf 57 GB erweitert. Eine MS-Windows 98 erste Ausgabe
Version war auch dabei. Natürlich habe ich die Festplatte so unterteilt,
dass ich verschiedene Versionen von Linux auf dem Geràt nutzen kann. Auf
der ersten Partition in der Größe von 5 GB habe ich das MS-Windows 98
installiert, auf weiteren Partitionen danach die SuSE 8.1 (hda3, letzte
primàre), 10.0 (hda5) und 10.2 (hda6). GRUB von 10.0 befand sich im mbr,
weil ich die 10.0 als am Besten für das Geràt identifiziert habe und am
meisten benutze.
Selbstverstàndlich funktionierte MS-Windows nach Installation diverser
Programme nicht mehr sauber, eine Datei wurde beim Starten stàndig
angemeckert, so dass ich mich veranlasst sah, es im Reparaturmodus neu
aufzubügeln. MS-Windows hat natürlich den mbr gnadenlos ohne Nachfrage
überschrieben, woran ich aber leider nicht vorher gedacht hatte. Ist ja
auch normalerweise kein Problem, SuSE 10.0 Installation von CD gestartet,
Installation abgebrochen, die hda5 im darauf erscheinenden Menu "System von
Festplatte starten" als Startpartition angewàhlt, was auch gut
funktionierte, mittels "grub-install /dev/hda" den mbr neu geschrieben, und
das System neu gestartet. Sollte eigentlich kein Problem sein.
Ja, denkste!
Grub startet, und bevor der Auswahlbildschirm mit den diversen Möglichkeiten
erscheint, startet der Rechner komplett neu und geht dadurch in eine
Endlosschleife. Sowohl grub von 8.1 als auch grub von 10.2 lassen sich
mittels "grub-install /dev/hda" problemlos wieder in den mbr schreiben, nur
die 10.0er Version will nich so wiese soll. Alle patches sind übrigens
installiert, daran kann es also nicht liegen. Was mache ich bloß falsch,
wenn ich grub von 10.0 zum Starten der Maschine benutzen möchte?
Schöne Grüße vom Möhnesee

Jürgen
 

Lesen sie die antworten

#1 Juergen F. Pennings
14/09/2007 - 13:36 | Warnen spam
Liebe Wissende,
warum kommen keine Antworten, habe ich hier ein unlösbares Problem oder bei
der Fragestellung was falsch gemacht?
Schöne Grüße vom Möhnesee

Jürgen

Ähnliche fragen