[GRUB2 / Ubuntu 12.04] Dualboot Problem mit grub2

08/05/2012 - 19:56 von Michael Limburg | Report spam
Hallo,

mal so eben sollte Ubuntu 12.04 neben ein vorhandenes Win7 installiert
werden. Dazu wurden wàhrend der Ubuntu-Installation manuell die Win7
Partition verkleinert und in den nun freien Speicherplatz ein paar
logische Partitionen eingefügt.
Installation und Update liefen auch durch und angeblich wurde grub2
installiert. Nach dem Neustart ist nix mit grub-Menü, sondern Win7
startet direkt durch.
Die Supergrub2-liveCD findet dann auch die Ubuntu-Partition, die sich
dann auch starten ließ, jedoch findet SG2 keinen installierten Grub2-
Bootloader, obwohl dessen Installation (in diesem Fall) nach /deb/sda
im Installationsmenü angemahnt wurde.
Auch manuelles installieren bei über SG2 gestartetem System löst das
Problem nicht.

Was tun?

Übrigens hat ein nachtràglich installiertes 10.04 (auf einer anderen
der angelegten logischen Partionen) kein Problem, seinen grub2 zu
installieren und nebenher das Win7 sowie das 12.04 ins Bootmenü
einzutagen.
Ist aber irgendwie nicht Sinn der Sache, ein 10.04 installieren zu
müsse, um damit das 12.04 neben dem Win7 starten zu können.

MfG Michael
 

Lesen sie die antworten

#1 m
08/05/2012 - 22:55 | Warnen spam
In <jobmoc$jid$ schrieb Michael:
Hallo,



Hallo,

mal so eben sollte Ubuntu 12.04 neben ein vorhandenes Win7 installiert
werden. Dazu wurden wàhrend der Ubuntu-Installation manuell die Win7
Partition verkleinert und in den nun freien Speicherplatz ein paar
logische Partitionen eingefügt.



Hier sind auf einer Festplatte 3x XP, 1x Win 7, 1x Ubuntu 12.04, 1x
openSuSE 12.1 und die Lenovo-Wiederherstellungspartionen.
Alles wird vom Grub2 vom Ubuntu gestartet.
Ich habe Ubuntu so installiert, dass ich dessen Grub2 nicht in die
root-Partition installiert habe, sondern ganz einfach nach /dev/sda.

Damit kann ich dann Ubuntu und openSUSE natürlich starten, aber auch die
XPs und auch Win7, bei Win7 habe ich auch nochmal ein eigenes Startmenü
aktiv.

Installation und Update liefen auch durch und angeblich wurde grub2
installiert. Nach dem Neustart ist nix mit grub-Menü, sondern Win7
startet direkt durch.
Die Supergrub2-liveCD findet dann auch die Ubuntu-Partition, die sich
dann auch starten ließ, jedoch findet SG2 keinen installierten Grub2-
Bootloader, obwohl dessen Installation (in diesem Fall) nach /deb/sda
im Installationsmenü angemahnt wurde.
Auch manuelles installieren bei über SG2 gestartetem System löst das
Problem nicht.

Was tun?



Wenn du dein Ubuntu "fremd" starten kannst und am Laufen hast, kannst
den Grub2 aus dem laufenden System nachinstallieren.
Anleitung hier:
<http://wiki.ubuntuusers.de/GRUB_2/Installation>
In kurzen Worten erklàrt: alle Grub2 betreffenden Pakete mit "sudo
apt-get purge <Pakete>" entfernen und danach wieder neu installieren,
das ruft automatisch die entsprechenden Konfigurationen auf, in dem man
dann das Ziel von Grub2 auswàhlen kann.
Bei mir war das /dev/sda (SATA-Festplatte).

Grub2 mittels Live-CD von "aussen" nachinstallieren. Ist echt easy und
funktioniert einwandfrei. Dazu gibt es Anleitung im Netz.
Z.B. gleiche Seite wie oben oder
<http://memus.de/j/index.php?option=...cle&id7:grub2recovery&catid9:ubuntu&Itemid4&lang=de>,
ist zwar eine Anleitung für 10.04, du mußt natürlich die Live-CD von
12.04 verwenden.
Am besten erstmal die obige Seite und auch den Part der anderen Seite
ausdrucken, dann von Live-CD starten und das machen.

Ich hab das übrigens, als ich noch 10.04 drauf hatte, mehrfach gemacht,
hat immer geklappt.

Übrigens brauchst du dir keine Gedanken zu machen, was alles in das
Grub-Menü eingefügt wird, Grub2 macht das vollautomatisch und findet
alle bootbaren Partition (auch von Windowsen) und nimmt die automatisch
ins Bootmenü.

Uwe

Ähnliche fragen