HAL hängt USB-Partition mit NTFS nicht ein

01/05/2008 - 12:26 von Olaf Meltzer | Report spam
Gegeben sei eine externe USB-Festplatte mit drei Partitionen: Eine
primàre Partition sdd1 mit NTFS formatiert, und zwei logische
Partitionen sdd5 und sdd6 mit jeweils EXT3.

Das Yast-Partitionierungs-Modul zeigt die Partitionsnamen richtig an:
WIN-BACKUPS, LIN-RSYNC, LIN-BACKUPS. Es sind _keine_ Mountpoints
vorgesehen.

Beim Anschalten der Platte werden die beiden EXT3-Partitionen
automatisch unter /media/LIN-RSYNC und /media/LIN-BACKUPS eingehàngt,
aber für die NTFS-Partition erscheint eine Fehlermeldung, die
sinngemàß besagt: "Du Trottel versuchst die NTFS-Partition mit der
Option utf8 zu mounten. Ich werde es stattdessen mal mit der Option
nls=utf8 versuchen. Mach das beim nàchsten Mal gefàlligst selbst, Du
Arsch! Du kannst auch mal nachsehen, was dmesg Dir verràt." Aber die
Partition wird _nicht_ eingehàngt.

dmesg sagt zu diesem Komplex:

NTFS driver 2.1.28 [Flags: R/W MODULE].
NTFS-fs error (device sdd1): parse_options(): Unrecognized mount
option locale.
NTFS-fs warning (device sdd1): parse_options(): Option utf8 is no
longer supported, using option nls=utf8. Please use option nls=utf8
in the future and make sure utf8 is compiled either as a module or
into the kernel.

Nun bin der Arsch ja eigentlich nicht ich, sondern wohl eher der
Kollege HAL. Denn wenn ich die fragliche Partition selbst als root
mit 'mount /dev/sdd1 /mnt -t ntfs-3g' mounte, funktioniert es
anstandslos, und user können darauf zugreifen.

Wie kann ich also Kollege HAL beibringen, es auf àhnliche Weise wie
ich zu versuchen. Ich kann mir auch vorstellen, daß der wesentliche
Punkt wàre, es mit ntfs-3g und nicht ntfs zu versuchen.

Gruß -- Olaf Meltzer
 

Lesen sie die antworten

#1 Bernd Weigelt
01/05/2008 - 12:41 | Warnen spam
Olaf Meltzer wrote:
Doppelt gemoppelt.. àhh gepostet?

Wie kann ich also Kollege HAL beibringen, es auf àhnliche Weise wie
ich zu versuchen. Ich kann mir auch vorstellen, daß der wesentliche
Punkt wàre, es mit ntfs-3g und nicht ntfs zu versuchen.


Habe temporàr das gleiche Problem, habe mal eine externe HD
NTFS-verunstaltet. ;-)

Aber ich bin bei http://de.opensuse.org/NTFS fündig geworden
Ob es hilft weiss ich nicht, da ich normalerweise keine externe
NTFS-Partitionen habe, wg des o.g. Problem, habe auch nicht unbedingt vor
es zu lösen

Bernd


OS: openSUSE 10.3 (X86-64)
Kernel: 2.6.24.1-76.3-default
KDE: 3.5.9 "release 60.2"

Ähnliche fragen