Hänger

13/03/2016 - 11:37 von Ulrich Korndoerfer | Report spam
Hallo Gemeinde :-)

Habe seit einiger Zeit folgendes Problem:

Programme (keine VB-Programme), laufend auf einem in Ehren ergrauenden
System mit XP SP3 (fast ohne sog. Sicherheitsupdates nach SP3) als OS,
hàngen oft für viele Sekunden bis zu teilweise Minuten, wenn Zugriffe
aufs Dateisystem nötig sind. Oder der Programmstart verzögert sich (der
Prozess ist dabei schon im Taskmanager sichtbar): es tut sich einfach
nichts bis dann endlich das Programm sich zeigt.

Der Taskmanager zeigt dabei bei keinem der laufenden Prozesse
irgendwelche hektischen Aktivitàten. Auch hektische
Festplattenaktivitàten sind keine zu vermelden, zumal es sich bei den
angeforderten Daten oft nur um kleine Mengen handelt (zB Registryzugriffe).

Das jeweils betroffene Programm "hàngt" einfach (bis hin zur beliebten
Windows-Meldung "Das Programm reagiert nicht"). Es findet kein
GUI-Update mehr statt, das Programm ist scheinbar tot. Und dann, ping,
als ob nichts gewesen wàre, gehts weiter.

Besonders betroffen sind davon alternative Dateimanager. Ursache dafür
sind meines Erachtens nicht unmàßige und unmàßige Mengen von
Shellextensions.

Vielleicht sollte ich noch erwàhnen, daß ich aktuell über einen Hub 6
USB3.0-Festplatten (alle NTFS, bis auf zwei alles 2TB Platten) an einen
der USB2.0 Ports des Rechners (hat USB3.0 nicht) angeschlossen habe, an
einem 2ten Port noch ein 4fach Hub (für Bluetooth und DVB-T Sticks)
hàngt und die restlichen 6 Ports sind auch alle belegt (Tastatur und
Mausdongles, WLAN-Stick, nochn DVB-T Stick, Scanner, Drucker). Die
externen HDs brechen manchmal (ohne Useraktivitàt) in Hektik aus ohne
das ich wüßte warum. Indexdienst ist natürlich abgeschaltet.

Nun habe ich beim Googlen von einem anderen Betroffenen gelesen, der
wohl àhnliche Probleme auf einem 64 Bit Windows 7 hat. Bei ihm hàngt ein
von ihm erzeugtes VB Programm. Das Programm hat eine lànger laufende
Aktion, wàhrend derer er durch DoEvents der Messageloop Luft zum Atmen
gibt. Das funktioniert anscheinend unter XP einwandfrei, auf genau einem
Windows 7 64 bit System aber nicht. Dort bekommt der User die bekannte
"Das Programm reagiert nicht" Meldung zu sehen. Bei seiner
Ursachenforschung ist er inzwischen zum Schluss gekommen, daß mit diesem
Rechner mit diesem Windows 7 System "etwas nicht in Ordnung ist".

Hab ich jetzt den Bitrot an der Hacke? Naja, Bitrot direkt eher nicht,
aber irgendwas im System ist degeneriert. Sachdienliche Hinweise zur
Abhilfe werden gerne entgegengenommen.

Ich bin dabei endlich die interne HD auf eine SSD umzuziehen, das dürfte
vielleicht etwas Linderung bringen. Aber da ja wàhrend der Hàngerei
keine hörenswerten Kopfbewegungen stattfinden, bringts wahrscheinlich
doch nichts.

Ulrich Korndoerfer

VB tips, helpers, solutions -> http://www.prosource.de/Downloads/
MS Newsgruppen Alternativen -> http://www.prosource.de/ms-ng-umzug.html
 

Lesen sie die antworten

#1 Ulrich Möller
13/03/2016 - 14:21 | Warnen spam
Am 13.03.2016 um 11:37 schrieb Ulrich Korndoerfer:
Hallo Gemeinde :-)

Habe seit einiger Zeit folgendes Problem:

Programme (keine VB-Programme), laufend auf einem in Ehren ergrauenden
System mit XP SP3 (fast ohne sog. Sicherheitsupdates nach SP3) als OS,
hàngen oft für viele Sekunden bis zu teilweise Minuten, wenn Zugriffe
aufs Dateisystem nötig sind. Oder der Programmstart verzögert sich
(der Prozess ist dabei schon im Taskmanager sichtbar): es tut sich
einfach nichts bis dann endlich das Programm sich zeigt.

Der Taskmanager zeigt dabei bei keinem der laufenden Prozesse
irgendwelche hektischen Aktivitàten. Auch hektische
Festplattenaktivitàten sind keine zu vermelden, zumal es sich bei den
angeforderten Daten oft nur um kleine Mengen handelt (zB
Registryzugriffe).

Das jeweils betroffene Programm "hàngt" einfach (bis hin zur beliebten
Windows-Meldung "Das Programm reagiert nicht"). Es findet kein
GUI-Update mehr statt, das Programm ist scheinbar tot. Und dann, ping,
als ob nichts gewesen wàre, gehts weiter.

Besonders betroffen sind davon alternative Dateimanager. Ursache dafür
sind meines Erachtens nicht unmàßige und unmàßige Mengen von
Shellextensions.

Vielleicht sollte ich noch erwàhnen, daß ich aktuell über einen Hub 6
USB3.0-Festplatten (alle NTFS, bis auf zwei alles 2TB Platten) an
einen der USB2.0 Ports des Rechners (hat USB3.0 nicht) angeschlossen
habe, an einem 2ten Port noch ein 4fach Hub (für Bluetooth und DVB-T
Sticks) hàngt und die restlichen 6 Ports sind auch alle belegt
(Tastatur und Mausdongles, WLAN-Stick, nochn DVB-T Stick, Scanner,
Drucker). Die externen HDs brechen manchmal (ohne Useraktivitàt) in
Hektik aus ohne das ich wüßte warum. Indexdienst ist natürlich
abgeschaltet.

Nun habe ich beim Googlen von einem anderen Betroffenen gelesen, der
wohl àhnliche Probleme auf einem 64 Bit Windows 7 hat. Bei ihm hàngt
ein von ihm erzeugtes VB Programm. Das Programm hat eine lànger
laufende Aktion, wàhrend derer er durch DoEvents der Messageloop Luft
zum Atmen gibt. Das funktioniert anscheinend unter XP einwandfrei, auf
genau einem Windows 7 64 bit System aber nicht. Dort bekommt der User
die bekannte "Das Programm reagiert nicht" Meldung zu sehen. Bei
seiner Ursachenforschung ist er inzwischen zum Schluss gekommen, daß
mit diesem Rechner mit diesem Windows 7 System "etwas nicht in Ordnung
ist".

Hab ich jetzt den Bitrot an der Hacke? Naja, Bitrot direkt eher nicht,
aber irgendwas im System ist degeneriert. Sachdienliche Hinweise zur
Abhilfe werden gerne entgegengenommen.

Ich bin dabei endlich die interne HD auf eine SSD umzuziehen, das
dürfte vielleicht etwas Linderung bringen. Aber da ja wàhrend der
Hàngerei keine hörenswerten Kopfbewegungen stattfinden, bringts
wahrscheinlich doch nichts.



Hallo Ulrich,

in solchen und àhnlichen Fàllen habe ich in der Regel das System neu
aufgesetzt. Aus meiner Erfahrung ist das zumeist sogar schneller, als
eine langwierige Fehlersuche. Alle Daten habe ich dabei einfach mit
SystemRescueCD auf eine externe Festplatte als Dateien gesichert - für
jede Partition einen eigener Ordner. SystemRescueCD hat bei NTFS den
Vorteil, das die Zugriffsberechtigungen auf "Jeder" gesetzt wird, damit
ich mit dem neu installierten System wieder einfach darauf zugreifen
kann. Hat bis jetzt immer geklappt.

Ulrich

Ähnliche fragen