Hardware WLAN-Schalter funktioniert nicht

26/07/2012 - 14:34 von Ch. Hanisch | Report spam
Hallo,

ich habe an einem DELL XPS L702x unter Ubuntu 12.04 (64Bit) das Problem,
daß der Hardware WLAN-Schalter Fn+F2 nicht reagiert.

Wie ich da auch drauf drücke, das Antennen Symbol blinkt einfach nicht.

Und es erscheint ausgegraut:
Funknetzwerke sind durch Hardware-Schalter deaktiviert.

Wie kriege ich diesen Schalter wieder aktiviert?

An einem fast baugleichen DELL XPS L702x funktioniert der
Hardwareschalter Fn+F2.
Auch unter Windows 7 funktioniert der Schalter.

Gruß
Ch. Hanisch
 

Lesen sie die antworten

#1 Kay Martinen
26/07/2012 - 22:36 | Warnen spam
Ch. Hanisch schrob:

Kenne deinen Dell nicht aber ein paar Ideen die du mal testen könntest

ich habe an einem DELL XPS L702x unter Ubuntu 12.04 (64Bit) das Problem,
daß der Hardware WLAN-Schalter Fn+F2 nicht reagiert.



Dann wird die Betàtigung des Schalters warscheinlich nicht ausgewertet oder
es fehlt ein programm/treiber dazu. Ob es an der 64-Bit Version liegt kann
ich nicht beurteilen. Was den Kernel angeht, vermute ich mal - eher nein.

Wie ich da auch drauf drücke, das Antennen Symbol blinkt einfach nicht.



Gibt es evtl. noch alternative Hotkeys die du stattdessen drücken kannst?
Was passiert wenn du im Networkmanager Wireless aktivierst? Siehst du dann
drahtlose Netzwerke? Wenn, ja, dann funktioniert es - nur der Schalter wàre
dann wirkungslos.

Und es erscheint ausgegraut:
Funknetzwerke sind durch Hardware-Schalter deaktiviert.

Wie kriege ich diesen Schalter wieder aktiviert?



Das sind jetzt nur ein paar verdàchtige aber, schau mal ob die folgenden
Programme oder pakete installiert sind - und wenn nicht installiere sie und
teste noch mal.

- treiber für deine wlan-karte (ist auch eine eingebaut?) geladen?
jockey kann dir da evtl. weiter helfen
- acpi
- rfkill
- wireless pakete die evtl. zum network-manager gehören

Schau einfach mal in synaptic rein, und suche nach diesen Stichworten.

An einem fast baugleichen DELL XPS L702x funktioniert der
Hardwareschalter Fn+F2.
Auch unter Windows 7 funktioniert der Schalter.



Nur der Schalter der das WLAN ausschaltet, oder bekommst du da auch
verbindung mit einem Accesspoint? Wenn letzeres dann liegt es schon mal
nicht an irgendeiner BIOS-Einstellung.

Wenn das nicht hilft, vielleicht postest du mal die ausgabe von 'dmesg' nach
dem booten. Der output von 'lshw' und 'lspci' wàre auch hilfreich. Und was
zeigt 'lsmod' an (alles in einer konsole ein zu geben)?

Gruß
Kay

Ähnliche fragen