Forums Neueste Beiträge
 

hartnäckige I/O-Fehler

11/07/2011 - 16:14 von E. Braun | Report spam
Hier làuft ein Rechner unter Debian Squeeze, dessen Platten seltsame
I/O-Fehler zeigen. Das Problem àndert sich auch nicht, wenn andere
Platten oder ein anderer Controller verwendet wird, ebenso àndert ein
anderer Kernel oder ein aktuelles GRML nichts am Fehlerbild. Der
Fehler tritt wiederholt auf, zwischen 30 Minuten und 5 Tage nach einem
Neustart. Hat jemand eine Idee, woher der Fehler kommen kann bzw. wie
er behoben werden kann?

Der Fehler ist:
ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen

Danach kommen viele Folgefehler:

[439809.825078] ata1.00: cmd ca/00:06:c7:8b:0c/00:00:00:00:00/e0 tag 0 dma 3072 out
[439809.825078] res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
[439809.825078] ata1.00: status: { DRDY }
[439815.629142] ata1: link is slow to respond, please be patient (ready=0)
[439821.970298] ata1: device not ready (errno=-16), forcing hardreset
[439821.970298] ata1: soft resetting link
[...]


Vollstàndige Kernel-Logs und ein lspci finden sich unter
http://users.minet.uni-jena.de/~erik/fehler/


Danke,
Erik
 

Lesen sie die antworten

#1 Tilman Ahr
11/07/2011 - 20:10 | Warnen spam
"E. Braun" writes:

Hier làuft ein Rechner unter Debian Squeeze, dessen Platten seltsame
I/O-Fehler zeigen. Das Problem àndert sich auch nicht, wenn andere
Platten oder ein anderer Controller verwendet wird, ebenso àndert ein
anderer Kernel oder ein aktuelles GRML nichts am Fehlerbild. Der
Fehler tritt wiederholt auf, zwischen 30 Minuten und 5 Tage nach einem
Neustart. Hat jemand eine Idee, woher der Fehler kommen kann bzw. wie
er behoben werden kann?

Der Fehler ist:
ata1.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen

Danach kommen viele Folgefehler:

[439809.825078] ata1.00: cmd ca/00:06:c7:8b:0c/00:00:00:00:00/e0 tag 0 dma 3072 out
[439809.825078] res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
[439809.825078] ata1.00: status: { DRDY }
[439815.629142] ata1: link is slow to respond, please be patient (ready=0)
[439821.970298] ata1: device not ready (errno=-16), forcing hardreset
[439821.970298] ata1: soft resetting link
[...]



Ich bin mir nicht sicher, ob es derselbe Fehler ist, aber die Meldungen
sehen etwas so aus wie die, die mein Rechner vor Jahren immer
ausgeworfen hat. Damals lag es an einem Molex-Stecker mit Wackelkontakt
(einer der Kontakte saß locker, und wurde anscheinend ab und an
"losvibriert"…

Ich hab' damals Wochen (und größere Mengen Nerven) gebraucht, bis ich
eher aus Versehen über die Ursache gestolpert bin¹.

Da das etwas ist, daß sich leicht überprüfen ließe, lohnt es sich
vielleicht, diese Ursache schonmal auszuschließen.


-
1: Eigentlich unglaublich, aber es gab damals tatsàchlich keinen
Datenverlust, abgestürzt ist über diese doch recht …low-level…
Probleme auch nie ernstlich was, und die Platte tat noch jahrelang
unverdrossen ihren Dienst. Manchmal muß man halt auch einfach Schwein
haben…
Grüße aus Berlin,
Tilman

Ähnliche fragen