Hat Mac OS ein Problem mit großenMengen an Dateien auf einem Server?

24/01/2015 - 08:28 von Th.me | Report spam
Hallo,

mein Mini làuft ja inzwischen wieder, und ich bin weiter am Umsortieren
und aufràumen. Dabei passiert es inzwischen mehrfach, das große Mengen
an Dateien umkopiert werden sollen. Nur komischerweise braucht der Mini
dazu Tage statt Stunden. Irgendwie komisch. Ist das ein grundsàtzliches
Problem von Mac OS 10.10.x oder des verwendeten Protokolls? Details:

Mac Mini late 2014, 16 GB RAM, aktuellstes Mac OS, SSD als
Systemlaufwerk

Server HP Proliant N40L, 16 GB ECC-RAM, FreeNAS 9.2.1
Serverplatten: 4 * 4 TB NAS-Laufwerke intern, 2 als RAID(Striped), 1 3TB
am DVD-Anschluß, BIOS ungepatcht.

Netzwerk: Durchgehend Gigabit Ethernet, Switch (oben) Level One GSW
0608, unten Fritz!Box 7490. Laut Statusanzeigen der Switche alle
Leitungen grün (also Gigabit erkannt)

Verbindunganzeige laut Finder-Info-Fenster:
afp://Speicher._afpovertcp._tcp.local/ada4_303 TMP
afp://Speicher._afpovertcp._tcp.local/Eigene Daten

Aufgabe: In einem iTunes Ordner (50GB Datenmenge, ca. 120000 Dateien in
iTune üblicher Sortierung (Name, Album, Lied)): Es sollen 2500 Dateien
in einem Ordner in einen in dieser Ebenen angelegten neuen Ordner
kopiert werden. Dauer 36 Stunden...

iTunes-Daten (50GB mp3) in eine neue leere Bibliothek einlesen (Quelle
und Ziel liegen auf dem Server): fast 50 Stunden.


Es sollen 150000 Dateien (Fotos, teileweise mit XMP-Dateien) vom Server
auf eine externe USB3-HDD (am Mac) umkopiert werden. Dauer
(voraussichtlich) 3 Tage. Datenduchsatz laut Aktivitàtsanzeige und
Webgui: 2MByte/s (120 habe ich beim kopieren EINER großen Datei schon
erreicht)

Löschen von 3500 Dateien in einem Ordner einer Ordnerhierachie (3. Ebene
von 4 Ebenen): rund 30 Stunden.


Irgendwie kommt mir das komisch vor. So lahm kann doch kein aktuelles
System sein...

Der Server macht jetzt gerade (seit o:oo Uhr) nebenbei ein Scrub über
das RAID mit 80-240 MByte/s. Daher vermute ich das der Server nicht das
Problem ist.

Vorschlàge oder Ideen warm das alles so langsam làuft?

Kennst du groops.de, die Freizeitgemeinschaft im deutschsprachigem
Raum? Reinschauen kostet nichts...
Urlaubsbilder: http://www.thomas-heier.de
Filme: http://www.youtube.com/user/thshDE?...e=mhum#g/u
 

Lesen sie die antworten

#1 Michael
28/01/2015 - 10:59 | Warnen spam
Am 24.01.15 um 08:28 schrieb Thomas Heier:
Hallo,

mein Mini làuft ja inzwischen wieder, und ich bin weiter am Umsortieren
und aufràumen. Dabei passiert es inzwischen mehrfach, das große Mengen
an Dateien umkopiert werden sollen. Nur komischerweise braucht der Mini
dazu Tage statt Stunden. Irgendwie komisch. Ist das ein grundsàtzliches
Problem von Mac OS 10.10.x oder des verwendeten Protokolls? Details:

Mac Mini late 2014, 16 GB RAM, aktuellstes Mac OS, SSD als
Systemlaufwerk

Server HP Proliant N40L, 16 GB ECC-RAM, FreeNAS 9.2.1
Serverplatten: 4 * 4 TB NAS-Laufwerke intern, 2 als RAID(Striped), 1 3TB
am DVD-Anschluß, BIOS ungepatcht.

Netzwerk: Durchgehend Gigabit Ethernet, Switch (oben) Level One GSW
0608, unten Fritz!Box 7490. Laut Statusanzeigen der Switche alle
Leitungen grün (also Gigabit erkannt)

Verbindunganzeige laut Finder-Info-Fenster:
afp://Speicher._afpovertcp._tcp.local/ada4_303 TMP
afp://Speicher._afpovertcp._tcp.local/Eigene Daten

Aufgabe: In einem iTunes Ordner (50GB Datenmenge, ca. 120000 Dateien in
iTune üblicher Sortierung (Name, Album, Lied)): Es sollen 2500 Dateien
in einem Ordner in einen in dieser Ebenen angelegten neuen Ordner
kopiert werden. Dauer 36 Stunden...

iTunes-Daten (50GB mp3) in eine neue leere Bibliothek einlesen (Quelle
und Ziel liegen auf dem Server): fast 50 Stunden.


Es sollen 150000 Dateien (Fotos, teileweise mit XMP-Dateien) vom Server
auf eine externe USB3-HDD (am Mac) umkopiert werden. Dauer
(voraussichtlich) 3 Tage. Datenduchsatz laut Aktivitàtsanzeige und
Webgui: 2MByte/s (120 habe ich beim kopieren EINER großen Datei schon
erreicht)

Löschen von 3500 Dateien in einem Ordner einer Ordnerhierachie (3. Ebene
von 4 Ebenen): rund 30 Stunden.


Irgendwie kommt mir das komisch vor. So lahm kann doch kein aktuelles
System sein...

Der Server macht jetzt gerade (seit o:oo Uhr) nebenbei ein Scrub über
das RAID mit 80-240 MByte/s. Daher vermute ich das der Server nicht das
Problem ist.

Vorschlàge oder Ideen warm das alles so langsam làuft?






Lösung habe ich nicht wirklich, aber so oder àhnlich auch schon erlebt
(auch "interne" Kopiervorgànge). Ich habe dann den Vorgang abgebrochen,
die paar schon kopierten "Leichen" gelöscht und nochmal angefangen, dann
gings. Woran das lag weiß ich aber nicht, kommt aber alle paar Wochen
mal vor.


Gruß

Michael

Ähnliche fragen