Haufenweise retransmits zwischen host und VM

04/04/2009 - 00:46 von Marc Haber | Report spam
Hallo,

ich habe auf einem Linux-Host eine virtuelle Maschine (ebenfalls ein
Linux) unter VirtualBox laufen. Host und Gast sind über eine bridge
und ein tap-Interface miteinander verbunden (netzwerktyp host, host
interface br0).

Wenn ich vom Host auf den Gast eine ssh-Session aufbaue, fühlt sich
das alles ganz normal an. Wenn ich jedoch dann beginne, Daten vom Host
auf den Gast zu schaufeln, ist das ganze extrem langsam (Größenordnung
100 KB/s), wàhrend sich die CPU nur langweilt.

Unter http://q.bofh.de/~mh/stuff/tshark-dump habe ich einen
tshark-Dump hinterlegt, auf dem es voller TCP Retransmissions und Dup
Acks nur so wimmelt.

Woran kann das liegen? Ein MTU-Problem ist's eher nicht, das sieht
auch so aus wenn ich die MTU unrealistisch weit herunterdrehe. Hints?

Grüße
Marc

Marc Haber | " Questions are the | Mailadresse im Header
Mannheim, Germany | Beginning of Wisdom " | http://www.zugschlus.de/
Nordisch by Nature | Lt. Worf, TNG "Rightful Heir" | Fon: *49 621 72739834
 

Lesen sie die antworten

#1 Detlef
04/04/2009 - 13:00 | Warnen spam
On 4 Apr., 00:46, Marc Haber <mh+ wrote:
Hallo,

ich habe auf einem Linux-Host eine virtuelle Maschine (ebenfalls ein
Linux) unter VirtualBox laufen. Host und Gast sind über eine bridge
und ein tap-Interface miteinander verbunden (netzwerktyp host, host
interface br0).

Wenn ich vom Host auf den Gast eine ssh-Session aufbaue, fühlt sich
das alles ganz normal an. Wenn ich jedoch dann beginne, Daten vom Host
auf den Gast zu schaufeln, ist das ganze extrem langsam (Größenordnung
100 KB/s), wàhrend sich die CPU nur langweilt.




Du wirst mich jetzt würgen, und den Dump habe ich auch noch nicht
angesehen, aber kann es sein, daß Du tatsàchlich _Verluste_ hast?
Wackelkontakt? Putte Hardware?

Zumindest wàre das das erste, wonach ich jetzt schauen würde.

Ähnliche fragen